Bug#918916: Unicorn not reporting proper version for gemfile?

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Bug#918916: Unicorn not reporting proper version for gemfile?

TheSin-2
Package: unicorn
Version: 5.4.1-1

Preparing to unpack .../25-unicorn_5.4.1-1_amd64.deb ...
Unpacking unicorn (5.4.1-1) over (5.4.0-1+b1) ...
Setting up unicorn (5.4.1-1) ...
insserv: warning: current start runlevel(s) (empty) of script `unicorn' overrides LSB defaults (2 3 4 5).
insserv: warning: current stop runlevel(s) (0 1 2 3 4 5 6) of script `unicorn' overrides LSB defaults (0 1 6).
Processing triggers for gitlab (11.5.6+dfsg-1) ...
Could not find gem 'unicorn (~> 5.1)' in any of the gem sources listed in your
Gemfile.


I tried to update the Gemfile, I even tried making the depend '>= 0’. But then dependancy have depends on it like

Processing triggers for gitlab (11.5.6+dfsg-1) ...
Bundler could not find compatible versions for gem "unicorn":
  In Gemfile:
    unicorn

    unicorn-worker-killer (~> 0.4.4) was resolved to 0.4.4, which depends on
      unicorn (< 6, >= 4)


So I rolled back to unicorn_5.4.0-1+b1_amd64.deb and it works again.  Seems something is wrong with how unicorn 5.4.1 reports its version.

Reply | Threaded
Open this post in threaded view
|

Bug#918916: [DRE-maint] Bug#918916: Unicorn not reporting proper version for gemfile?

Hleb Valoshka-2
Now the package provides unicorn-0.gemspec instead, it might be a gem2deb issue.

Reply | Threaded
Open this post in threaded view
|

Bug#918916: Unicorn not reporting proper version for gemfile?

Dominik George-7
In reply to this post by TheSin-2
Control: severity -1 grave
Control: tag -1 + patch

Hi,

On Thu, Jan 10, 2019 at 08:08:29AM -0700, Justin Hallett wrote:

> Package: unicorn
> Version: 5.4.1-1
>
> Preparing to unpack .../25-unicorn_5.4.1-1_amd64.deb ...
> Unpacking unicorn (5.4.1-1) over (5.4.0-1+b1) ...
> Setting up unicorn (5.4.1-1) ...
> insserv: warning: current start runlevel(s) (empty) of script `unicorn' overrides LSB defaults (2 3 4 5).
> insserv: warning: current stop runlevel(s) (0 1 2 3 4 5 6) of script `unicorn' overrides LSB defaults (0 1 6).
> Processing triggers for gitlab (11.5.6+dfsg-1) ...
> Could not find gem 'unicorn (~> 5.1)' in any of the gem sources listed in your
> Gemfile.
Stumled upon the same problem today.

Looking at the package, it seems the fix-gemspec.patch has been dropped
in the last upload, for no obvious reason and without being mentioned in
the changelog.

I tried to add it again, rebuilt the package, and it fixes the issue.

-nik

unicorn_bug_918916.debdiff (1K) Download Attachment
signature.asc (919 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Bug#918916: Unicorn not reporting proper version for gemfile?

Dominik George-7
In reply to this post by TheSin-2
>I've checked debian's git, this patch was introduced when
>ENV["VERSION"] was required to use the gemspec. Now as the upstream
>gemspec provides the same it's not required.
>
>The problem is not in Unicorn. The problem is in gem2deb which
>generated incorrect unicorn-0.gemspec for the package.

OK... But, why was it fixed when I rebuilt with the patch?

-nik

Reply | Threaded
Open this post in threaded view
|

Bug#918916: Unicorn not reporting proper version for gemfile?

Julian Calaby
In reply to this post by TheSin-2
Package: unicorn
Version: 5.4.1-1
Followup-For: Bug #918916

For reference:

As a workaround, changing _both_ versions in the shipped gemspec and the
version in the filename from 0 to 5.4.1 fixes packages which depend on
this, e.g. gitlab.

Detailed steps:

1. Edit /usr/share/rubygems-integration/2.5.0/specifications/unicorn-0.gemspec
2. On line 2, change 0 to 5.4.1 so it reads: # stub: unicorn 5.4.1 ruby lib
3. On line 7, change 0 to 5.4.1 so it reads:   s.version = "5.4.1"
4. Rename the file to unicorn-5.4.1.gemspec

Thanks,

Julian Calaby