Bug#919569: r-cran-rnexml: autopkgtest depends on r-cran-rdflib which is not in testing

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Bug#919569: r-cran-rnexml: autopkgtest depends on r-cran-rdflib which is not in testing

Graham Inggs-3
Source: r-cran-rnexml
Version: 2.1.2-2
X-Debbugs-CC: [hidden email]
User: [hidden email]
Usertags: fails-always

Hi Maintainer

Autopkgtests of r-cran-rnexml fail when tested with packages only from
testing [1], yet pass when tested with packages from unstable [2].

This is due to the test dependency on r-cran-rdflib which has not yet
migrated to testing after 48 days, which in turn is due to dependencies
on r-cran-jsonld, r-cran-v8 and libv8-3.14.

Regards
Graham


[1] https://ci.debian.net/packages/r/r-cran-rnexml/testing/amd64/
[2] https://ci.debian.net/packages/r/r-cran-rnexml/unstable/amd64/

Reply | Threaded
Open this post in threaded view
|

Bug#919569: r-cran-rnexml: autopkgtest depends on r-cran-rdflib which is not in testing

Andreas Tille-2
Control: tags -1 help

Hi Dylan,

you have uploaded


r-cran-v8 (1.5+git20180203-1) experimental; urgency=medium

  * Team upload.
  * New upstream snapshot 1.5+git20180203.
  * Switch Build-Dep from libv8-dev to libnode-dev.

 -- Dylan Aïssi <[hidden email]>  Sun, 03 Feb 2019 14:10:05 +0100


to experimental.  Since r-cran-v8 is needed for several other packages
we will loose if it is not in testing I wonder whether you have a plan
for the experimental -> unstable (and thus testing) migration.

Kind regards and thanks in any case for your contribution to this package

     Andreas.


On Thu, Jan 17, 2019 at 11:45:33AM +0200, Graham Inggs wrote:

> Source: r-cran-rnexml
> Version: 2.1.2-2
> X-Debbugs-CC: [hidden email]
> User: [hidden email]
> Usertags: fails-always
>
> Hi Maintainer
>
> Autopkgtests of r-cran-rnexml fail when tested with packages only from
> testing [1], yet pass when tested with packages from unstable [2].
>
> This is due to the test dependency on r-cran-rdflib which has not yet
> migrated to testing after 48 days, which in turn is due to dependencies on
> r-cran-jsonld, r-cran-v8 and libv8-3.14.
>
> Regards
> Graham
>
>
> [1] https://ci.debian.net/packages/r/r-cran-rnexml/testing/amd64/
> [2] https://ci.debian.net/packages/r/r-cran-rnexml/unstable/amd64/
>
> _______________________________________________
> R-pkg-team mailing list
> [hidden email]
> https://alioth-lists.debian.net/cgi-bin/mailman/listinfo/r-pkg-team

--
http://fam-tille.de

Reply | Threaded
Open this post in threaded view
|

Bug#919569: r-cran-rnexml: autopkgtest depends on r-cran-rdflib which is not in testing

Dylan Aïssi-3
Hi Andreas,

Le mer. 6 févr. 2019 à 12:05, Andreas Tille <[hidden email]> a écrit :
> to experimental.  Since r-cran-v8 is needed for several other packages
> we will loose if it is not in testing I wonder whether you have a plan
> for the experimental -> unstable (and thus testing) migration.

Upstream will release a new version of r-cran-v8 this week, so yes I
will upload this one in unstable asap ;-)
https://github.com/jeroen/V8/issues/49#issuecomment-460897217

Best,
Dylan