Bug#919983: gyoto: autopkgtest failure on i386

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Bug#919983: gyoto: autopkgtest failure on i386

Graham Inggs-3
Source: gyoto
Version: 1.3.0-1
X-Debbugs-CC: [hidden email]
User: [hidden email]
Usertags: regression

Hi Maintainer

Since the upload of 1.3.0-1, gyoto has been failing its autopkgtests on
i386 [1] with the following error:

Reading parameter file:
/tmp/autopkgtest.mHCx9P/build.XrZ/src/doc/examples/example-torusjet.xml
  Copyright (c) 2011-2019 Frédéric Vincent, Thibaut Paumard,
                          Odele Straub and Frédéric Lamy.
...

j = 18/32
j = 19/32
j = 20/32In gyoto-mpi-worker.C: Error initializing libgyoto: In
ThermalBrems: alphanu undefined!
--------------------------------------------------------------------------
Child job 2 terminated normally, but 1 process returned
a non-zero exit code. Per user-direction, the job has been aborted.
--------------------------------------------------------------------------
--------------------------------------------------------------------------
mpirun.openmpi detected that one or more processes exited with non-zero
status, thus causing
the job to be terminated. The first process to do so was:

   Process name: [[32154,2],3]
   Exit code:    1
--------------------------------------------------------------------------
autopkgtest [16:14:18]: test gyoto-mpi: -----------------------]
gyoto-mpi            FAIL non-zero exit status 1


It is not entirely clear that this is a new failure on i386 as previous
tests always failed.  Test are now successful on amd64 in Debian [2] and
all other tested architectures in Ubuntu; amd64, arm64, armhf, ppc64el
and s390x.

Regards
Graham


[1] http://autopkgtest.ubuntu.com/packages/gyoto/disco/i386
[2] https://ci.debian.net/packages/g/gyoto/unstable/amd64/