Bug#920291: lxc: Upgrade to 3.1.0+really3.0.3-2 fails in postinst step (possibly related to AppArmor)

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Bug#920291: lxc: Upgrade to 3.1.0+really3.0.3-2 fails in postinst step (possibly related to AppArmor)

Francis M
Package: lxc
Version: 1:3.1.0+really3.0.3-2
Severity: normal

Apologies if this is a duplicate.  This issue may relate to bug #919185
but a different file is concerned so I'm uncertain if this is a seperate
issue or not.

Basically, I've just upgraded 3.0.3-2 to 3.1.0+really3.0.3-2 and I'm
getting the following dpkg error:

  Setting up lxc (1:3.1.0+really3.0.3-2) ...
  Installing new version of config file /etc/apparmor.d/abstractions/lxc/container-base ...
  Warning: unable to find a suitable fs in /proc/mounts, is it mounted?
  Use --subdomainfs to override.
  dpkg: error processing package lxc (--configure):
   installed lxc package post-installation script subprocess returned error exit status 1
  [...]
  Processing triggers for libc-bin (2.28-5) ...
  Errors were encountered while processing:
   lxc

Note: AppArmor is disabled on the kernel command line (apparmor=0), which
I'm guessing is related, however the userspace portion (apparmor package)
is installed as below.


-- System Information:
Debian Release: buster/sid
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: amd64 (x86_64)

Kernel: Linux 4.19.0-1-amd64 (SMP w/1 CPU core)
Locale: LANG=en_GB.UTF-8, LC_CTYPE=en_GB.UTF-8 (charmap=UTF-8), LANGUAGE=en_GB.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)
LSM: SELinux: enabled - Mode: Permissive - Policy name: default

Versions of packages lxc depends on:
ii  debconf [debconf-2.0]  1.5.70
ii  libc6                  2.28-5
ii  libcap2                1:2.25-1.2
ii  libgnutls30            3.6.5-2
ii  liblxc1                1:3.1.0+really3.0.3-2
ii  libseccomp2            2.3.3-3
ii  libselinux1            2.8-1+b1
ii  lsb-base               10.2018112800

Versions of packages lxc recommends:
ii  bridge-utils                 1.5-16
ii  debootstrap                  1.0.114
ii  dirmngr                      2.2.12-1
ii  dnsmasq-base [dnsmasq-base]  2.80-1
ii  gnupg                        2.2.12-1
ii  iproute2                     4.20.0-2
ii  iptables                     1.8.2-3
ii  libpam-cgfs                  1:3.1.0+really3.0.3-2
ii  lxc-templates                3.0.3-1
ii  lxcfs                        3.0.3-2
ii  nftables                     0.9.0-2
ii  openssl                      1.1.1a-1
ii  rsync                        3.1.3-1
ii  uidmap                       1:4.5-1.1

Versions of packages lxc suggests:
ii  apparmor     2.13.2-3
ii  btrfs-progs  4.19.1-2
pn  lvm2         <none>
pn  python3-lxc  <none>

-- Configuration Files:
/etc/lxc/default.conf changed [not included]

-- debconf information:
* lxc/auto_update_config: true