Bug#921042: dpdk-dev: dpdk 18.11-4 and dpdk-dev conflict

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Bug#921042: dpdk-dev: dpdk 18.11-4 and dpdk-dev conflict

Nicolas S. Dade-3
Package: dpdk-dev
Version: 18.11-4~bpo9+1
Severity: important

Dear Maintainer,

Installing the dpdk-dev-18.11-4~bpo9+1 is not possible. dpkg refuses,
claiming dpdk-dev breaks dpdk 18.11-4. For example:


# dpkg --install dpdk-dev_18.11-4~bpo9+1_amd64.deb
Selecting previously unselected package dpdk-dev.
dpkg: regarding dpdk-dev_18.11-4~bpo9+1_amd64.deb containing dpdk-dev:
dpdk-dev breaks dpdk (<< 18.11-4)
 dpdk (version 18.11-4~bpo9+1) is present and installed.

dpkg: error processing archive dpdk-dev_18.11-4~bpo9+1_amd64.deb (--install):
installing dpdk-dev would break dpdk, and
deconfiguration is not permitted (--auto-deconfigure might help)
Errors were encountered while processing:
dpdk-dev_18.11-4~bpo9+1_amd64.deb


The Replaces lines in the debian/control file for the dpdk and dpdk-dev
sections look strange to me. Why would dpdk replace dpdk-dev?

However I am not able to work around this except by commenting out
the Replaces and Breaks lines entirely.




-- System Information:
Debian Release: 9.7
  APT prefers stable-updates
  APT policy: (500, 'stable-updates'), (500, 'stable')
Architecture: amd64 (x86_64)

Kernel: Linux 4.9.0-8-amd64 (SMP w/8 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8), LANGUAGE= (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages dpdk-dev depends on:
ii  libbsd0                    0.8.3-1
ii  libc6                      2.24-11+deb9u3
ii  libdpdk-dev                18.11-4~bpo9+1
ii  libelf1                    0.168-1
ii  libgcc1                    1:6.3.0-18+deb9u1
ii  libjansson4                2.9-1
ii  libnuma1                   2.0.11-2.1
ii  librte-acl18.11            18.11-4~bpo9+1
pn  librte-acl2                <none>
ii  librte-bbdev18.11          18.11-4~bpo9+1
ii  librte-bpf18.11            18.11-4~bpo9+1
ii  librte-bus-dpaa18.11       18.11-4~bpo9+1
ii  librte-bus-pci18.11        18.11-4~bpo9+1
ii  librte-bus-vdev18.11       18.11-4~bpo9+1
ii  librte-cfgfile18.11        18.11-4~bpo9+1
pn  librte-cfgfile2            <none>
ii  librte-cmdline18.11        18.11-4~bpo9+1
pn  librte-cmdline2            <none>
ii  librte-common-dpaax18.11   18.11-4~bpo9+1
ii  librte-compressdev18.11    18.11-4~bpo9+1
ii  librte-cryptodev18.11      18.11-4~bpo9+1
pn  librte-cryptodev2          <none>
pn  librte-distributor1        <none>
ii  librte-distributor18.11    18.11-4~bpo9+1
ii  librte-eal18.11            18.11-4~bpo9+1
pn  librte-eal3                <none>
ii  librte-efd18.11            18.11-4~bpo9+1
ii  librte-ethdev18.11         18.11-4~bpo9+1
pn  librte-ethdev5             <none>
ii  librte-eventdev18.11       18.11-4~bpo9+1
ii  librte-flow-classify18.11  18.11-4~bpo9+1
ii  librte-gro18.11            18.11-4~bpo9+1
ii  librte-gso18.11            18.11-4~bpo9+1
ii  librte-hash18.11           18.11-4~bpo9+1
pn  librte-hash2               <none>
pn  librte-ip-frag1            <none>
ii  librte-ip-frag18.11        18.11-4~bpo9+1
pn  librte-jobstats1           <none>
ii  librte-kni18.11            18.11-4~bpo9+1
pn  librte-kni2                <none>
pn  librte-kvargs1             <none>
ii  librte-kvargs18.11         18.11-4~bpo9+1
ii  librte-lpm18.11            18.11-4~bpo9+1
pn  librte-lpm2                <none>
ii  librte-mbuf18.11           18.11-4~bpo9+1
pn  librte-mbuf2               <none>
ii  librte-member18.11         18.11-4~bpo9+1
ii  librte-mempool-dpaa18.11   18.11-4~bpo9+1
ii  librte-mempool18.11        18.11-4~bpo9+1
pn  librte-mempool2            <none>
pn  librte-meter1              <none>
ii  librte-meter18.11          18.11-4~bpo9+1
ii  librte-metrics18.11        18.11-4~bpo9+1
pn  librte-net1                <none>
ii  librte-net18.11            18.11-4~bpo9+1
ii  librte-pci18.11            18.11-4~bpo9+1
pn  librte-pdump1              <none>
ii  librte-pdump18.11          18.11-4~bpo9+1
ii  librte-pipeline18.11       18.11-4~bpo9+1
pn  librte-pipeline3           <none>
ii  librte-pmd-bnxt18.11       18.11-4~bpo9+1
pn  librte-pmd-bond1           <none>
ii  librte-pmd-bond18.11       18.11-4~bpo9+1
ii  librte-pmd-dpaa18.11       18.11-4~bpo9+1
ii  librte-pmd-i40e18.11       18.11-4~bpo9+1
ii  librte-pmd-ixgbe18.11      18.11-4~bpo9+1
pn  librte-pmd-null1           <none>
ii  librte-pmd-ring18.11       18.11-4~bpo9+1
pn  librte-pmd-ring2           <none>
ii  librte-pmd-softnic18.11    18.11-4~bpo9+1
pn  librte-pmd-xenvirt1        <none>
ii  librte-port18.11           18.11-4~bpo9+1
pn  librte-port3               <none>
pn  librte-power1              <none>
ii  librte-power18.11          18.11-4~bpo9+1
pn  librte-reorder1            <none>
ii  librte-reorder18.11        18.11-4~bpo9+1
pn  librte-ring1               <none>
ii  librte-ring18.11           18.11-4~bpo9+1
pn  librte-sched1              <none>
ii  librte-sched18.11          18.11-4~bpo9+1
ii  librte-security18.11       18.11-4~bpo9+1
ii  librte-table18.11          18.11-4~bpo9+1
pn  librte-table2              <none>
ii  librte-telemetry18.11      18.11-4~bpo9+1
pn  librte-timer1              <none>
ii  librte-timer18.11          18.11-4~bpo9+1
pn  librte-vhost3              <none>
ii  libxenstore3.0             4.8.5+shim4.10.2+xsa282-1+deb9u11
ii  zlib1g                     1:1.2.8.dfsg-5

dpdk-dev recommends no packages.

dpdk-dev suggests no packages.

Reply | Threaded
Open this post in threaded view
|

Bug#921042: [Pkg-dpdk-devel] Bug#921042: dpdk-dev: dpdk 18.11-4 and dpdk-dev conflict

Luca Boccassi-3
On Thu, 2019-01-31 at 16:10 -0800, Nicolas S. Dade wrote:

> Package: dpdk-dev
> Version: 18.11-4~bpo9+1
> Severity: important
>
> Dear Maintainer,
>
> Installing the dpdk-dev-18.11-4~bpo9+1 is not possible. dpkg refuses,
> claiming dpdk-dev breaks dpdk 18.11-4. For example:
>
>
> # dpkg --install dpdk-dev_18.11-4~bpo9+1_amd64.deb 
> Selecting previously unselected package dpdk-dev. 
> dpkg: regarding dpdk-dev_18.11-4~bpo9+1_amd64.deb containing dpdk-
> dev: 
> dpdk-dev breaks dpdk (<< 18.11-4) 
>  dpdk (version 18.11-4~bpo9+1) is present and installed. 
>
> dpkg: error processing archive dpdk-dev_18.11-4~bpo9+1_amd64.deb (
> --install): 
> installing dpdk-dev would break dpdk, and 
> deconfiguration is not permitted (--auto-deconfigure might help) 
> Errors were encountered while processing: 
> dpdk-dev_18.11-4~bpo9+1_amd64.deb
>
>
> The Replaces lines in the debian/control file for the dpdk and dpdk-
> dev
> sections look strange to me. Why would dpdk replace dpdk-dev?
>
> However I am not able to work around this except by commenting out
> the Replaces and Breaks lines entirely.
This is due to 18.11-4~ working out as lower than 18.11-4, which I
should have thought about. Sorry about that, will be fixed in the next
upload.

--
Kind regards,
Luca Boccassi

signature.asc (499 bytes) Download Attachment