Bug#921268: [mumble] Mumble's Audio Tuning Wizard doesn't play test samples/sounds, TTS is possibly also broken

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Bug#921268: [mumble] Mumble's Audio Tuning Wizard doesn't play test samples/sounds, TTS is possibly also broken

Mikaela Suomalainen
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512

Package: mumble
Version: 1.3.0~git20190125.440b173+dfsg-1
Severity: normal

- --- Please enter the report below this line. ---

Hi,

I think this issue was introduced by 1.3.0~git20190114.9fcc588+dfsg-1.
When I open the audio wizard, the third screen is device tuning which
says "You should hear a voice sample. Change the slider below to the
lowest value which gives no interruptions or jitter in the sound", and
here I don't hear sound at all.

Later there is "Positional Audio" configuration, where the last phrase
is "You should hear the audio move between the channels". There is no
audio here either. I experience this issue on both headset and laptop
internal speaker/microphone, and also HDMI audio.

I am not entirely sure when I should hear TTS, but I think it's also
broken as I don't hear messages while connecting and disconnecting to
server, which I think I heard previously.

Regardless of these issues, I have successfully used these two Mumble
versions for voice chat, even if I don't know if my audio settings are
optimal.

- --- System information. ---
Architecture: Kernel:       Linux 4.19.0-1-amd64

Debian Release: buster/sid
  990 testing         sdscoq7snqtznauu.onion   990 testing
deb.torproject.org   990 testing         deb.debian.org   500 unstable
       riot.im   500 syncthing       apt.syncthing.net   500 stable
       dl.google.com   500 buster          s3-us-west-2.amazonaws.com
  500 buster          brave-browser-apt-release.s3.brave.com   500
buster          brave-browser-apt-dev.s3.brave.com   500 buster
   brave-browser-apt-beta.s3.brave.com
- --- Package information. ---
Depends                                (Version) | Installed
================================================-+-===================
libasound2                           (>= 1.0.16) | 1.1.7-2
libavahi-client3                     (>= 0.6.16) | 0.7-4+b1
libavahi-common3                     (>= 0.6.16) | 0.7-4+b1
libavahi-compat-libdnssd1            (>= 0.6.16) | 0.7-4+b1
libc6                                  (>= 2.27) | libgcc1
                   (>= 1:3.0) | libgl1
           | libglib2.0-0                         (>= 2.12.0) |
libopus0                                (>= 1.1) | libprotobuf17
                              | libpulse0
(>= 0.99.1) | libqt5core5a                     (>= 5.11.0~rc1) |
libqt5dbus5                           (>= 5.0.2) | libqt5gui5
                   (>= 5.3.0) | libqt5network5
(>= 5.4.0) | libqt5sql5                            (>= 5.3.0) |
libqt5svg5                       (>= 5.6.0~beta) | libqt5widgets5
              (>= 5.11.0~rc1) | libqt5xml5
(>= 5.0.2) | libsndfile1                          (>= 1.0.20) |
libspeechd2                           (>= 0.7.1) | libspeex1
             (>= 1.2~beta3-1) | libspeexdsp1                  (>=
1.2~beta3.2-1) | libssl1.1                             (>= 1.1.0) |
libstdc++6                              (>= 5.2) | libx11-6
            (>= 2:1.2.99.901) | libxi6                           (>=
2:1.2.99.4) | libqt5sql5-sqlite                                |
lsb-release                                      |

Package's Recommends field is empty.

Suggests               (Version) | Installed
================================-+-===========
mumble-server                    | speech-dispatcher                |
0.8.8-9
- --
Mikaela Suomalainen
-----BEGIN PGP SIGNATURE-----
Comment: Website: https://mikaela.info/
Comment: Public key: https://mikaela.info/PGP/0xB2F32B67.txt
Comment: gpg --fetch-keys https://mikaela.info/PGP/0xB2F32B67.txt
Comment: Fingerprint = 2910 4A46 C561 5BF9 78A0 83F2 0C20 7F07 B2F3 2B67

iQIzBAEBCgAdFiEEKRBKRsVhW/l4oIPyDCB/B7LzK2cFAlxXSaIACgkQDCB/B7Lz
K2ftng//RC3pJou89UFzw4I/TXnX2JEbFwq8CkR2w7FpLmVxCMC94UVUMMwDx5id
1+E7p9cFQMyh6s8hVxpNj10uAx6f/O3CGNqtqF2pwz3tvpS4UxF5TkXqGoccb3D5
YuySAVZ6zJU3g2JxFAbeEs/E0ViSYXyr56dJvsgxLtAWu0xHVg9A6XQvNPeGMODk
s7IQftbTitLMEQzCSwxepp/4PWukpi/pU5/VM3kEZDJq5GgZop4C1wJk9knc0RH4
JllXfTHk+WgakfML2hSEtY7yjGVegMjpZcXYYArXdRz3A2ggw8ON2tXH6iyfnE6l
FXXFtAQDCwYIFDr2gRxzDIKn6KqnfO8f6Dy4FtLFOc67gv9YNvF0xJdDPryKJyTr
TBtL05LHtzELgDma6g3Dsgc6hoizZrtl2SUjPztFBc/lgpnf8CuHamD0adIlhBMZ
BFQ+o0UqYM9ykfqtOqQXtbh4fFAYGYGCvHnfhTaT51SGoeWdn/PnMdcV9yn7dDJE
nvxT55nS3Gr0AWXCV+6p3gPwjqAjsHhwf8X0Jqmxiv9JO67jU9TszGaaBuLModRw
eGjLpYcqa+xpuWR0wiPkMyPGd+z1b1QBAHu5phTG5GJoB3s9UUQxQywQjkr+G9Ru
djFqPF2gXx0TDGCqo3EStlkh62h4J+ZglOqPzDCRmXSZaTrM2hM=
=iwag
-----END PGP SIGNATURE-----

Reply | Threaded
Open this post in threaded view
|

Bug#921268: [mumble] Mumble's Audio Tuning Wizard doesn't play test samples/sounds, TTS is possibly also broken

Chris Knadle
Hello Mikaela.

Mikaela Suomalainen:

> Package: mumble
> Version: 1.3.0~git20190125.440b173+dfsg-1
> Severity: normal
>
> --- Please enter the report below this line. ---
>
> Hi,
>
> I think this issue was introduced by 1.3.0~git20190114.9fcc588+dfsg-1.
> When I open the audio wizard, the third screen is device tuning which
> says "You should hear a voice sample. Change the slider below to the
> lowest value which gives no interruptions or jitter in the sound", and
> here I don't hear sound at all.
I've tested this and I see the same behavior.

> Later there is "Positional Audio" configuration, where the last phrase
> is "You should hear the audio move between the channels". There is no
> audio here either. I experience this issue on both headset and laptop
> internal speaker/microphone, and also HDMI audio.

I've tested and see the same behavior with this too.

> I am not entirely sure when I should hear TTS, but I think it's also
> broken as I don't hear messages while connecting and disconnecting to
> server, which I think I heard previously.

Text-To-Speech still works in my testing, but didn't at first and I found why.
Check to be sure you have the 'speech-dispatcher' package installed.  If not,
install it.  The Mumble client does not need re-loading to get TTS to work if
speech-dispatcher wasn't installed before.

speech-dispatcher isn't a dependency for Mumble and I think that's purposeful;
there have been some bugs and occasional misbehavior related to
speech-dispatcher such that I find it beneficial not to have it installed when
it's not required.


I'm not sure what's going on with the missing audio samples, but I've seen
discussion about that in the #mumble IRC channel on irc.freenode.net, so there's
a possibility that this might be by design.  I'll ask upstream.

   -- Chris

--
Chris Knadle
[hidden email]


signature.asc (849 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Bug#921268: [mumble] Mumble's Audio Tuning Wizard doesn't play test samples/sounds, TTS is possibly also broken

Chris Knadle
forwarded 921268 https://github.com/mumble-voip/mumble/pull/3611
tags 921268 = fixed-upstream
thanks

This bug was caused by an error in the audio sample path:

https://github.com/mumble-voip/mumble/commit/c49301b0cb2689657953aca0b874f5eecfac4566

As this is something that can be given a targeted fix I'll see if I can get a
package with the fix uploaded before the full freeze.

   -- Chris

--
Chris Knadle
[hidden email]


signature.asc (849 bytes) Download Attachment