Bug#923115: marked as done (cups-client: cupsctl needs to edit `cups-files.conf`)

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Bug#923115: marked as done (cups-client: cupsctl needs to edit `cups-files.conf`)

Debian Bug Tracking System
Your message dated Fri, 17 May 2019 09:18:44 +0000
with message-id <[hidden email]>
and subject line Bug#923115: fixed in cups 2.3~b8-2
has caused the Debian Bug report #923115,
regarding cups-client: cupsctl needs to edit `cups-files.conf`
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact [hidden email]
immediately.)


--
923115: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=923115
Debian Bug Tracking System
Contact [hidden email] with problems

Package: cups-client
Version: 2.2.10-4
Severity: normal

Dear Maintainer,


`/usr/sbin/cupsctl FileDevice=No` edits `/etc/cups/cupsd.conf` instead
of `/etc/cups/cups-files.conf`.

```
/etc$ /usr/sbin/cupsctl FileDevices=No
/etc$ sudo git diff
diff --git a/cups/cupsd.conf b/cups/cupsd.conf
index 02afed2..c347852 100644
--- a/cups/cupsd.conf
+++ b/cups/cupsd.conf
@@ -119,3 +119,4 @@ WebInterface Yes
      Order deny,allow
    </Limit>
  </Policy>
+FileDevice Yes
```


Kind regards,

Paul

-- System Information:
Debian Release: buster/sid
   APT prefers unstable
   APT policy: (500, 'unstable'), (1, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 4.20.0-trunk-amd64 (SMP w/4 CPU cores)
Locale: LANG=de_DE.UTF-8, LC_CTYPE=de_DE.UTF-8 (charmap=UTF-8),
LANGUAGE=de_DE.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /usr/bin/dash
Init: systemd (via /run/systemd/system)
LSM: AppArmor: enabled

Versions of packages cups-client depends on:
ii  adduser        3.118
ii  cups-common    2.2.10-4
ii  libc6          2.28-7
ii  libcups2       2.2.10-4
ii  libcupsimage2  2.2.10-4

cups-client recommends no packages.

Versions of packages cups-client suggests:
ii  cups       2.2.10-4
ii  cups-bsd   2.2.10-4
ii  smbclient  2:4.9.4+dfsg-3

-- no debconf information

Source: cups
Source-Version: 2.3~b8-2

We believe that the bug you reported is fixed in the latest version of
cups, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to [hidden email],
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Didier Raboud <[hidden email]> (supplier of updated cups package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing [hidden email])


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512

Format: 1.8
Date: Fri, 17 May 2019 10:42:54 +0200
Source: cups
Architecture: source
Version: 2.3~b8-2
Distribution: experimental
Urgency: medium
Maintainer: Debian Printing Team <[hidden email]>
Changed-By: Didier Raboud <[hidden email]>
Closes: 923115
Changes:
 cups (2.3~b8-2) experimental; urgency=medium
 .
   * Backport upstream patch:
     - Block cups-files.conf directives (Issue #5530, Closes: #923115)
Checksums-Sha1:
 efcadc6c595143c0dd6a3e501feaaea4329e2267 3254 cups_2.3~b8-2.dsc
 e313d7384f43c182329df4746b437f8dbe395388 351824 cups_2.3~b8-2.debian.tar.xz
Checksums-Sha256:
 3ae0775dfae0f708df43d8ae1c995ffd7df45925c3fcc778fb4d571549dab89a 3254 cups_2.3~b8-2.dsc
 8d8995797dcd1e17f6cf515a335dbaeab1316f7bbe3d76846bce922f5c5a39e1 351824 cups_2.3~b8-2.debian.tar.xz
Files:
 551773c2d0c3696155750900a072225b 3254 net optional cups_2.3~b8-2.dsc
 6607b097538cd2fc74a8d0dad66605bf 351824 net optional cups_2.3~b8-2.debian.tar.xz

-----BEGIN PGP SIGNATURE-----

iQGzBAEBCgAdFiEEe+WPIRpjNw1/GSB7i8+nHsoWNFUFAlzed2EACgkQi8+nHsoW
NFWGYwv/cexQS3DrxV8jNVPENCcUxEByAV52zFIK/zjpAhihu0wzulE9NYJ6wSO4
i+g5AXkUWyymadpgET5J9nOiAZ4LND4iEQLzWGimHL4eXCaKtmmyM9NQlIXv0wp+
YlwFuGeR2JjRQ6vAdsFQWM9DF8bQ4XyOvqLCwWVrQ8GGjZY0xXhJR6TcGo2Qncg0
SUDuQ6uXAyvjZP4UY9rwA0HPTONS9DWDFnYui8lisZRnBJzGNnOllIY49ecYEUKw
CCTc/14v0pHpvjepzocZVslcCmAweESrmkt17OHUUiVAbFRd7btJc+MMH2/TFoLR
CmzjwmFlqCBxwZOib1d8lhQdaSF5ihCSE+ZRh+9wlZvvT6fMMUn1UFWXeVab4VmB
2w97aSH+JwXXD+LGsR6EkyTJwlBAYLfpzCc/g31ZQJhUoaZtUTOBOAhl+GMAiQk0
Paa/OvEoQifq4K20vbUY7ERfk5zJxJN87v6EwCskAvzuQoUef2Xlky+H2IMB4Boi
H/rOQ5Ku
=QZa0
-----END PGP SIGNATURE-----