Bug#923695: libczmq-dev: pkg-config --cflags libczmq.pc fails without uuid-dev and libsystemd-dev installed

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Bug#923695: libczmq-dev: pkg-config --cflags libczmq.pc fails without uuid-dev and libsystemd-dev installed

Luca Boccassi-3
Package: libczmq-dev
Version: 4.2.0-1
Severity: grave
Justification: rdeps FTBFS due to missing dependencies and pkg-config

libczmq.pc lists the dependencies for static linking in
Requires.private, which means pkg-config --cflags libczmq will fail if
these dependencies (uuid-dev and libsystemd-dev [linux-any]) are not
installed.
This will cause reverse dependencies to fail to build in minimal chroot
that pull in only required dependencies.

The fix is very simple, just add uuid-dev and libsystemd-dev [linux-
any] to the list of libczmq-dev's dependencies.

--
Kind regards,
Luca Boccassi

signature.asc (499 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Bug#923695: libczmq-dev: pkg-config --cflags libczmq.pc fails without uuid-dev and libsystemd-dev installed

Luca Boccassi-3
On Wed, 2019-03-13 at 02:00 +0000, John Morris wrote:

> Package: czmq
> Version: 4.2.0-1
> Followup-For: Bug #923695
>
> Dear Maintainer,
>
> The version 4.2.0-2 pushed to Sid fixes this problem, but the problem
> still exists in Buster, still at 4.2.0-1.
>
> Thanks!
It will migrate to buster tomorrow or the day after

--
Kind regards,
Luca Boccassi

signature.asc (499 bytes) Download Attachment