Bug#923951: gsequencer: there are important upstream bug-fixes available

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Bug#923951: gsequencer: there are important upstream bug-fixes available

Joël Krähemann-2
Source: gsequencer
Version: 2.1.53
Severity: important

Dear Maintainer,

There are 3 important patches available with severity important:

* ags_thread-posix-max-precision.patch
* ags_simple_file_read_config.patch
* ags_automation_get_value.patch

The max precision and read config are related somehow to each other.
As applying new configuration the AgsThread:max-precision property
is going to be changed. The parameter specification for this is
wrong.

The read config didn't apply correct configuration causing additional
problems.

The automation patch makes the automation editor usable, without it
is useless.

Note, the fixes were available before the freeze dead-line but came
along with many other changes.

best regards,
Joël


-- System Information:
Debian Release: buster/sid
  APT prefers stable-updates
  APT policy: (500, 'stable-updates'), (500, 'unstable')
Architecture: amd64 (x86_64)

Kernel: Linux 4.19.0-3-amd64 (SMP w/24 CPU cores)
Locale: LANG=C.UTF-8, LC_CTYPE=C.UTF-8 (charmap=UTF-8), LANGUAGE=C.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)
LSM: AppArmor: enabled