Bug#926103: libifd-cyberjack6: driver breaks with pcsc-lite versions >= 1.8.21

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Bug#926103: libifd-cyberjack6: driver breaks with pcsc-lite versions >= 1.8.21

Peter Wienemann-2
Package: libifd-cyberjack6
Version: 3.99.5final.sp09-1.1
Severity: grave
Justification: renders package unusable

Dear Maintainer,

trying to change the PIN of an eID card using a ReinerSCT cyberJack RFID
komfort device, I get the following error:

Mar 31 14:31:54 hostname pcscd[21065]: 00400142
ifdwrapper.c:364:IFDStatusICC() Card not transacted: 612
Mar 31 14:31:54 hostname pcscd[21065]: 00000035
eventhandler.c:336:EHStatusHandlerThread() Error communicating to:
REINER SCT cyberJack RFID komfort

The underlying cause seems to be the issue described on

https://github.com/LudovicRousseau/PCSC/issues/22

and (in German)

https://forum.reiner-sct.com/index.php?/topic/3728-failed_to_transmit_control_command_to_the_terminal

Both references point to a patch for this problem.

Peter

-- System Information:
Debian Release: buster/sid
Architecture: amd64 (x86_64)

Kernel: Linux 4.19.0-4-amd64

Versions of packages libifd-cyberjack6 depends on:
ii  libc6         2.28-8
ii  libgcc1       1:8.3.0-2
ii  libstdc++6    8.3.0-2
ii  libusb-1.0-0  2:1.0.22-2
ii  pcscd         1.8.24-1

libifd-cyberjack6 recommends no packages.

Versions of packages libifd-cyberjack6 suggests:
pn  pcsc-tools  <none>

Reply | Threaded
Open this post in threaded view
|

Bug#926103: libifd-cyberjack6: driver breaks with pcsc-lite versions >= 1.8.21

Frank Neuber-2
Dear Peter,
this bug is fixed in SP13.
The version in the debian repo is SP9 and quite old.

http://support.reiner-sct.de/downloads/LINUX/V3.99.5_SP13/pcsc-cyberjack_3.99.5final.SP13.tar.gz

http://support.reiner-sct.de/downloads/LINUX/V3.99.5_SP13/libifd-cyberjack6_3.99.5final.sp13_amd64_d09.deb

Please let me know if it works for you.

Kind Regards,
 Frank


Am 31.03.19 um 16:32 schrieb Peter Wienemann:

> Package: libifd-cyberjack6
> Version: 3.99.5final.sp09-1.1
> Severity: grave
> Justification: renders package unusable
>
> Dear Maintainer,
>
> trying to change the PIN of an eID card using a ReinerSCT cyberJack RFID
> komfort device, I get the following error:
>
> Mar 31 14:31:54 hostname pcscd[21065]: 00400142
> ifdwrapper.c:364:IFDStatusICC() Card not transacted: 612
> Mar 31 14:31:54 hostname pcscd[21065]: 00000035
> eventhandler.c:336:EHStatusHandlerThread() Error communicating to:
> REINER SCT cyberJack RFID komfort
>
> The underlying cause seems to be the issue described on
>
> https://github.com/LudovicRousseau/PCSC/issues/22
>
> and (in German)
>
> https://forum.reiner-sct.com/index.php?/topic/3728-failed_to_transmit_control_command_to_the_terminal
>
>
> Both references point to a patch for this problem.
>
> Peter
>
> -- System Information:
> Debian Release: buster/sid
> Architecture: amd64 (x86_64)
>
> Kernel: Linux 4.19.0-4-amd64
>
> Versions of packages libifd-cyberjack6 depends on:
> ii  libc6         2.28-8
> ii  libgcc1       1:8.3.0-2
> ii  libstdc++6    8.3.0-2
> ii  libusb-1.0-0  2:1.0.22-2
> ii  pcscd         1.8.24-1
>
> libifd-cyberjack6 recommends no packages.
>
> Versions of packages libifd-cyberjack6 suggests:
> pn  pcsc-tools  <none>

Reply | Threaded
Open this post in threaded view
|

Bug#926103: libifd-cyberjack6: driver breaks with pcsc-lite versions >= 1.8.21

Peter Wienemann-2
Am 01.04.19 um 12:40 schrieb Frank Neuber:
> Dear Peter,
> this bug is fixed in SP13.
> The version in the debian repo is SP9 and quite old.
>
> http://support.reiner-sct.de/downloads/LINUX/V3.99.5_SP13/pcsc-cyberjack_3.99.5final.SP13.tar.gz
>
> http://support.reiner-sct.de/downloads/LINUX/V3.99.5_SP13/libifd-cyberjack6_3.99.5final.sp13_amd64_d09.deb
>
> Please let me know if it works for you.

Dear Frank,

thanks for the link to an up-to-date driver version. It actually fixes
the described problem.

Thanks, Peter

Reply | Threaded
Open this post in threaded view
|

Bug#926103: Freeze-exception for pcsc-cyberjack 3.99.5final.sp09-2

Erik Brangs
In reply to this post by Peter Wienemann-2
Hi,

On 09.04.19 00:14, Reinhard Tartler wrote:
> Frank and I would like to see RC bug #926103 fixed in Debian 10. Please approve the attached debdiff, so that I can upload the fixed package to unstable.

I'm a user of the package and would like to see the fixed version in buster. I think you're supposed to file an unblock request (Section "Applying for an unblock" in the freeze policy at https://release.debian.org/buster/freeze_policy.html ).


Kind regards,

Erik Brangs