Bug#926782: ruby-concurrent: autopkgtest needs update

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Bug#926782: ruby-concurrent: autopkgtest needs update

Graham Inggs-3
Source: ruby-concurrent
Version: 1.0.5-2
X-Debbugs-CC: [hidden email]
User: [hidden email]
Usertags: needs-update

Hi Maintainer

Since 2018-12-15, pdb2pqr's auopkgtests have been failing [1] with the
following error:

autopkgtest [04:53:01]: test command2: gem2deb-test-runner --autopkgtest
--check-dependencies 2>&1
autopkgtest [04:53:01]: test command2: [-----------------------

┌──────────────────────────────────────────────────────────────────────────────┐
│ Checking Rubygems dependency resolution on ruby2.5
       │
└──────────────────────────────────────────────────────────────────────────────┘

/usr/lib/ruby/vendor_ruby/gem2deb/metadata.rb:128:in `load_gemspec':
More than one .gemspec file in this directory: concurrent-ruby.gemspec,
concurrent-ruby-edge.gemspec, concurrent-ruby-ext.gemspec (RuntimeError)
        from /usr/lib/ruby/vendor_ruby/gem2deb/metadata.rb:34:in `block in
initialize'
        from /usr/lib/ruby/vendor_ruby/gem2deb/metadata.rb:33:in `chdir'
        from /usr/lib/ruby/vendor_ruby/gem2deb/metadata.rb:33:in `initialize'
        from /usr/lib/ruby/vendor_ruby/gem2deb/test_runner.rb:78:in `new'
        from /usr/lib/ruby/vendor_ruby/gem2deb/test_runner.rb:78:in
`do_check_dependencies'
        from /usr/lib/ruby/vendor_ruby/gem2deb/test_runner.rb:68:in `run_tests'
        from /usr/bin/gem2deb-test-runner:67:in `<main>'
autopkgtest [04:53:02]: test command2: -----------------------]
autopkgtest [04:53:02]: test command2:  - - - - - - - - - - results - -
- - - - - - - -
command2             FAIL non-zero exit status 1

Regards
Graham


[1] https://ci.debian.net/packages/r/ruby-concurrent/unstable/amd64/