Bug#926875: initramfs-tools backward compatibility removal

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Bug#926875: initramfs-tools backward compatibility removal

Florian Strankowski-3
Package: initramfs-tools
Version: 0.130

When ifdown is invoked, it still checks for IFDOWN beeing supplied
within /conf/initramfs.conf. Due to the nature of evolution, this has
been moved to /etc/dropbear-initramfs/config within the release of stretch.

#######

if grep -q ^DROPBEAR_IFDOWN= /conf/initramfs.conf; then
     # XXX backward compatibility; remove once Stretch is the current stable
     . /conf/initramfs.conf
     IFDOWN="$DROPBEAR_IFDOWN"
fi
if [ -e /etc/dropbear/config ]; then
     . /etc/dropbear/config
fi

#######

I suggest to move the checks to the accordingly right file which is now
/etc/dropbear-initramfs/config. Further a backward-compability check for
upgraded systems should be in place or a warning (like when setting up
cryptotools) to move already set variables like "IFDOWN=" to the
appropriate new configuration-path (see above).


----

Florian Strankowski
uniquoo UG i.G.
Adolph-Schönfelder-Straße 68
22083 Hamburg, Germany

Reply | Threaded
Open this post in threaded view
|

Bug#926875: initramfs-tools backward compatibility removal

Ben Hutchings-3
Control: reassign -1 dropbear-initramfs 2018.76-5
Control: severity -1 minor

On Thu, 2019-04-11 at 19:04 +0200, Florian Strankowski wrote:
> Package: initramfs-tools
> Version: 0.130
>
> When ifdown is invoked, it still checks for IFDOWN beeing supplied
> within /conf/initramfs.conf. Due to the nature of evolution, this has
> been moved to /etc/dropbear-initramfs/config within the release of stretch.
[...]

This is part of dropbear-initramfs and not initramfs-tools itself.

Ben.

--
Ben Hutchings
Never attribute to conspiracy what can adequately be explained
by stupidity.


signature.asc (849 bytes) Download Attachment