Bug#926981: golang-1.12-go: Needs /etc/alternatives/go to be useful

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Bug#926981: golang-1.12-go: Needs /etc/alternatives/go to be useful

Nye Liu
Package: golang-1.12-go
Version: 1.12.1-1
Severity: normal

Without /etc/alternatives/go (and friends), this package is pretty useless.

-- System Information:
Debian Release: buster/sid
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 4.18.16-x86_64-linode118 (SMP w/4 CPU cores; PREEMPT)
Locale: LANG=C, LC_CTYPE=C.UTF-8 (charmap=UTF-8), LANGUAGE=C (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages golang-1.12-go depends on:
ii  golang-1.12-src  1.12.1-1
ii  libc6            2.28-7

Versions of packages golang-1.12-go recommends:
ii  g++         4:8.2.0-2
ii  gcc         4:8.2.0-2
ii  libc6-dev   2.28-7
ii  pkg-config  0.29-6

Versions of packages golang-1.12-go suggests:
pn  bzr | brz        <none>
ii  ca-certificates  20190110
ii  git              1:2.20.1-2
pn  mercurial        <none>
ii  subversion       1.10.4-1

-- no debconf information