Bug#927033: libqt5widgets5: System tray icons do not appear in Xfce4

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Bug#927033: libqt5widgets5: System tray icons do not appear in Xfce4

Dmitry Mikhirev
Package: libqt5widgets5
Version: 5.11.3+dfsg1-1
Severity: important

Dear Maintainer,

I have recently upgraded to Buster, and I found that Qt applications don't show
their system tray icons. I use Xfce4. There's no problem with GTK apps, e. g.
icons of claws-mail, jami and parcellite are shown, but icons of Qt apps, in
particular psi-plus and hp-systray, don't appear. This does not depend on the
time when application was started: I can't see tray icons if it was autostarted
with session or later manually.



-- System Information:
Debian Release: buster/sid
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 4.19.0-4-amd64 (SMP w/2 CPU cores)
Kernel taint flags: TAINT_PROPRIETARY_MODULE, TAINT_OOT_MODULE, TAINT_UNSIGNED_MODULE
Locale: LANG=ru_RU.utf8, LC_CTYPE=ru_RU.utf8 (charmap=UTF-8), LANGUAGE=ru_RU.utf8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages libqt5widgets5 depends on:
ii  libc6                             2.28-8
ii  libqt5core5a [qtbase-abi-5-11-3]  5.11.3+dfsg1-1
ii  libqt5gui5                        5.11.3+dfsg1-1
ii  libstdc++6                        8.3.0-5

libqt5widgets5 recommends no packages.

libqt5widgets5 suggests no packages.

-- no debconf information

Reply | Threaded
Open this post in threaded view
|

Bug#927033: #927033: libqt5widgets5: System tray icons do not appear in Xfce4

Adam Borowski-3
> I have recently upgraded to Buster, and I found that Qt applications don't show
> their system tray icons. I use Xfce4. There's no problem with GTK apps, e. g.
> icons of claws-mail, jami and parcellite are shown, but icons of Qt apps, in
> particular psi-plus and hp-systray, don't appear. This does not depend on the
> time when application was started: I can't see tray icons if it was autostarted
> with session or later manually.

Seems to work for me fine (tried clementine and transmission-qt); a freshly
installed Buster.  So it does on a last-reinstalled-2011 ~home-from-2002 box.

I get systray icons for QT stuff.


Meow!
--
⢀⣴⠾⠻⢶⣦⠀
⣾⠁⢠⠒⠀⣿⡁ Did ya know that typing "test -j8" instead of "ctest -j8"
⢿⡄⠘⠷⠚⠋⠀ will make your testsuite pass much faster, and fix bugs?
⠈⠳⣄⠀⠀⠀⠀