Bug#927753: gnome-maps: segmentation fault at startup

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Bug#927753: gnome-maps: segmentation fault at startup

gpe92
Package: gnome-maps
Version: 3.30.3-1
Severity: grave
Justification: renders package unusable

Dear Maintainer,

   * What led up to the situation?

   starts gnome-maps

   * What exactly did you do (or not do) that was effective (or
     ineffective)?

   run gnome-maps in CLI

   * What was the outcome of this action?
~$ gnome-maps

(org.gnome.Maps:29445): Gjs-WARNING **: 19:54:40.265: Some code called array.toString() on a Uint8Array instance. Previously this would have interpreted the bytes of the array as a string, but that is nonstandard. In the future this will return the bytes as comma-separated digits. For the time being, the old behavior has been preserved, but please fix your code anyway to explicitly call ByteArray.toString(array).
(Note that array.toString() may have been called implicitly.)
0 <TOP LEVEL> ["resource:///org/gnome/Maps/js/osmTypes.js":32]
1 <TOP LEVEL> ["resource:///org/gnome/Maps/js/osmEditDialog.js":35]
2 <TOP LEVEL> ["resource:///org/gnome/Maps/js/osmEdit.js":25]
3 <TOP LEVEL> ["resource:///org/gnome/Maps/js/contextMenu.js":33]
4 <TOP LEVEL> ["resource:///org/gnome/Maps/js/mainWindow.js":33]
5 <TOP LEVEL> ["resource:///org/gnome/Maps/js/application.js":35]
6 <TOP LEVEL> ["resource:///org/gnome/Maps/js/main.js":43]
7 start() ["resource:///org/gnome/gjs/modules/package.js":209]
8 <TOP LEVEL> ["/usr/bin/gnome-maps":2]


(org.gnome.Maps:29445): Gjs-WARNING **: 19:54:41.312: Some code called array.toString() on a Uint8Array instance. Previously this would have interpreted the bytes of the array as a string, but that is nonstandard. In the future this will return the bytes as comma-separated digits. For the time being, the old behavior has been preserved, but please fix your code anyway to explicitly call ByteArray.toString(array).
(Note that array.toString() may have been called implicitly.)
0 load() ["resource:///org/gnome/Maps/js/placeStore.js":168]
1 _initPlaceStore() ["resource:///org/gnome/Maps/js/application.js":186]
2 vfunc_startup() ["resource:///org/gnome/Maps/js/application.js":233]
3 main() ["resource:///org/gnome/Maps/js/main.js":57]
4 run() ["resource:///org/gnome/gjs/modules/package.js":225]
5 start() ["resource:///org/gnome/gjs/modules/package.js":209]
6 <TOP LEVEL> ["/usr/bin/gnome-maps":2]

Erreur de segmentation
   
   * What outcome did you expect instead?

   gnome-maps starts ...

BR

-- System Information:
Debian Release: buster/sid
  APT prefers testing
  APT policy: (990, 'testing'), (500, 'unstable')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 4.19.0-4-amd64 (SMP w/4 CPU cores)
Kernel taint flags: TAINT_PROPRIETARY_MODULE, TAINT_OOT_MODULE, TAINT_UNSIGNED_MODULE
Locale: LANG=fr_FR.utf8, LC_CTYPE=fr_FR.utf8 (charmap=UTF-8), LANGUAGE=fr_FR.utf8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)
LSM: AppArmor: enabled

Versions of packages gnome-maps depends on:
ii  dconf-gsettings-backend [gsettings-backend]  0.30.1-2
ii  geoclue-2.0                                  2.5.2-1
ii  gir1.2-champlain-0.12                        0.12.16-3
ii  gir1.2-clutter-1.0                           1.26.2+dfsg-10
ii  gir1.2-cogl-1.0                              1.22.2-6
ii  gir1.2-gdkpixbuf-2.0                         2.38.1+dfsg-1
ii  gir1.2-geoclue-2.0                           2.5.2-1
ii  gir1.2-geocodeglib-1.0                       3.26.0-2
ii  gir1.2-gfbgraph-0.2                          0.2.3-3
ii  gir1.2-glib-2.0                              1.58.3-2
ii  gir1.2-goa-1.0                               3.30.1-2
ii  gir1.2-gtk-3.0                               3.24.5-1
ii  gir1.2-gtkchamplain-0.12                     0.12.16-3
ii  gir1.2-gtkclutter-1.0                        1.8.4-4
ii  gir1.2-gweather-3.0                          3.28.2-2
ii  gir1.2-rest-0.7                              0.8.1-1
ii  gir1.2-secret-1                              0.18.7-1
ii  gir1.2-soup-2.4                              2.64.2-2
ii  gir1.2-webkit2-4.0                           2.24.1-dmo1
ii  gjs                                          1.54.3-1
ii  libc6                                        2.28-8
ii  libchamplain-0.12-0                          0.12.16-3
ii  libfolks25                                   0.11.4-1+b2
ii  libgee-0.8-2                                 0.20.1-2
ii  libgeocode-glib0                             3.26.0-2
ii  libglib2.0-0                                 2.58.3-1
ii  libglib2.0-bin                               2.58.3-1
ii  librest-0.7-0                                0.8.1-1
ii  libxml2                                      2.9.4+dfsg1-7+b3

gnome-maps recommends no packages.

gnome-maps suggests no packages.

-- no debconf information