Bug#928629: openvas: Certificate error while connecting to greenbone-security-assistant

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Bug#928629: openvas: Certificate error while connecting to greenbone-security-assistant

jors@enchufado.com
Package: openvas
Version: 9.0.3
Severity: important

Dear Maintainer,

   * What led up to the situation?
     Installed openvas and tried to access greenbone-security-assistant web interface (https://<host>:9392/
   * What exactly did you do (or not do) that was effective (or
     ineffective)?
     Open a browser with the mentioned URL.
   * What was the outcome of this action?
     Browser complained with NET::ERR_CERT_AUTHORITY_INVALID. Tried bypassing the error, but returned to same screen (loop).
   * What outcome did you expect instead?
     The greenbone-security-assistant web interface to be loaded.

Also tried regenerating the certificates with one of the provided scripts and restarting openvas services with no luck (same situation):

$ openvas-manage-certs -af

-- System Information:
Debian Release: buster/sid
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: amd64 (x86_64)

Kernel: Linux 4.9.0-8-amd64 (SMP w/1 CPU core)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8), LANGUAGE=en_US:en (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages openvas depends on:
ii  greenbone-security-assistant  7.0.3+dfsg.1-1
ii  openvas-cli                   1.4.5-2
ii  openvas-manager               7.0.3-1
ii  openvas-scanner               5.1.3-2

Versions of packages openvas recommends:
ii  rsync     3.1.3-6
ii  sqlite3   3.27.2-2
ii  xsltproc  1.1.32-2

openvas suggests no packages.

-- no debconf information