Bug#928952: marked as done (Problems after security update 9.26a~dfsg-0+deb9u3)

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Bug#928952: marked as done (Problems after security update 9.26a~dfsg-0+deb9u3)

Debian Bug Tracking System
Your message dated Tue, 14 May 2019 14:32:08 +0000
with message-id <[hidden email]>
and subject line Bug#928936: fixed in cups-filters 1.11.6-3+deb9u1
has caused the Debian Bug report #928936,
regarding Problems after security update 9.26a~dfsg-0+deb9u3
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact [hidden email]
immediately.)


--
928936: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=928936
Debian Bug Tracking System
Contact [hidden email] with problems

Package: ghostscript
Version: 9.26a~dfsg-0+deb9u3


After doing the Ghostscript upgrade from 9.26a~dfsg-0+deb9u2 to
9.26a~dfsg-0+deb9u3 cups did not print anymore at a customer PC.
Downgrading the ghostscript package did help.

My customer is using a Brother HL-L2365DW connected through USB with
"Generic PCL6/PCL XL Printer Foomatic/ljet4d" driver.

My Lexmark x546dtn network printer does work fine using postscript after
the upgrade, but not using PCL6. I get there:
Idle - "Filter failed".

I guess there is something wrong with printing PCL6.

Workarround:

apt install libgs9-common=9.26a~dfsg-0+deb9u2 \
 libgs9=9.26a~dfsg-0+deb9u2 ghostscript=9.26a~dfsg-0+deb9u2
systemctl restart cups
make a file /etc/apt/preferences.d/ghostscript for pinning:
---
Package: libgs9-common
Pin: version 9.26a~dfsg-0+deb9u2
Pin-Priority: 1001

Package: libgs9
Pin: version 9.26a~dfsg-0+deb9u2
Pin-Priority: 1001

Package: ghostscript
Pin: version 9.26a~dfsg-0+deb9u2
Pin-Priority: 1001
---
apt update

With regards,
Paul van der Vlis



--
Paul van der Vlis Linux systeembeheer Groningen
https://www.vandervlis.nl/

Source: cups-filters
Source-Version: 1.11.6-3+deb9u1

We believe that the bug you reported is fixed in the latest version of
cups-filters, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to [hidden email],
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Salvatore Bonaccorso <[hidden email]> (supplier of updated cups-filters package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing [hidden email])


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512

Format: 1.8
Date: Mon, 13 May 2019 17:10:20 +0200
Source: cups-filters
Architecture: source
Version: 1.11.6-3+deb9u1
Distribution: stretch-security
Urgency: high
Maintainer: Debian Printing Team <[hidden email]>
Changed-By: Salvatore Bonaccorso <[hidden email]>
Closes: 926576 928936
Changes:
 cups-filters (1.11.6-3+deb9u1) stretch-security; urgency=high
 .
   * Non-maintainer upload by the Security Team.
   * foomatic-rip: Changed Ghostscript call to count pages in a PDF file to use
     "runpdfbegin" and not the undocumented Ghostscript internal "pdfdict".
     (Closes: #926576, #928936)
Checksums-Sha1:
 17d2979f49aed5ec2987b9c95bc398685da2e66a 3105 cups-filters_1.11.6-3+deb9u1.dsc
 68674af1da5431d4d8ec2ae1a03314ec4bc40d00 1410116 cups-filters_1.11.6.orig.tar.xz
 4fa449ed143486c9cedbfc86b019c89ed7cc1ee4 75164 cups-filters_1.11.6-3+deb9u1.debian.tar.xz
Checksums-Sha256:
 29a154ab3d8d480bc455614426371f69e3c1ec32344b67199faab14e69dd0d0a 3105 cups-filters_1.11.6-3+deb9u1.dsc
 ed33a824cfdc4eba6633a7d491468da8eecdf120cb05557980c47b4cdfad9c7f 1410116 cups-filters_1.11.6.orig.tar.xz
 690cd1f6ab6d6cfd2823d8cea4f2bf91ddbe1fe6c767f2b1299d45ba81926008 75164 cups-filters_1.11.6-3+deb9u1.debian.tar.xz
Files:
 1da0d089411a23368af05d14eed2d460 3105 net optional cups-filters_1.11.6-3+deb9u1.dsc
 1a4939db42cfd1ccc4df99e498c95dd9 1410116 net optional cups-filters_1.11.6.orig.tar.xz
 057a7c0f5fd559699d50ae900e8a9c21 75164 net optional cups-filters_1.11.6-3+deb9u1.debian.tar.xz

-----BEGIN PGP SIGNATURE-----

iQKmBAEBCgCQFiEERkRAmAjBceBVMd3uBUy48xNDz0QFAlzZxThfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDQ2
NDQ0MDk4MDhDMTcxRTA1NTMxRERFRTA1NENCOEYzMTM0M0NGNDQSHGNhcm5pbEBk
ZWJpYW4ub3JnAAoJEAVMuPMTQ89E4CEP/R344tySgVs8g9YgE/FCMUOx3Oqn6s2v
icoTQ5+rTgKI2SYxJ8Px+4cfFgOK9Gox6DYGwj1jgf3i213Vm/IDmzoKWsj+mAQH
YTnbVYj9pJOGdZmyp/LPBZk1biA3+PrUqjbyUpEaf7rkytAX0qheqLGpkzwP4ANt
JK84APKUwMkRgIpP4zySSFFyj4+XZaOPdGWfbW2+L5iBP4TYKQNeMQO3JqJFZvei
KpBZfmVMqMPyvTlutCpDj0R0MhYRKVgdokB2hw63k9dcE+v5IqmTgOxcJosY05NV
PL/3gr6eUalJfqG4FDCkKDp4a/e4iHBioiL7xJ87u4piroF3MlqIbuL/TyXFIsjr
Cqujo06+hoVagKkNg6Y+z8e6yyU1+3w7p7suI2+YDTrFDQJaPGzXHhnFueTfuWN/
XK+xC1u8g2UmRLYf6/KuXzIbPym0XqB5fVGY2yJpmyXo2iFmVA/Hp8s6U2bpixde
Q+lnCvyKI3//vg3XBnoRU3bJM988DZXnu6F7RNOT7x+0Kp8nPfC2AFlAFZWLedGb
kW/Af5Pn9hinkPFYH6pfICfXgU2oFZyM8zmCf2yffNAxftHeA3hVRqylpWYZ3M+G
+ah/3BJI9VSnYjv3b7eh2780a55yUQpW0UNriFGAP6uD54vfs+Xcn4PheOIF+G6u
mVO7FWr20cO0
=aV4z
-----END PGP SIGNATURE-----