Bug#929227: debian stretch kvm-intel errors on 4.9.0-9 kernel

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Bug#929227: debian stretch kvm-intel errors on 4.9.0-9 kernel

John J. Rushford-2

Package: linux-image

Version: 4.9.168-1+deb9u2


I'm running debian 9.9 stretch and after installing the recent security update, https://www.debian.org/security/2019/dsa-4444, my machine now runs the 4.9.0-9 kernel but no-longer runs my kvm guest VM's.  Using modprobe and dmesg, I see the following kvm-intel module errors:


kernel: [    6.234764] kvm_intel: Unknown symbol cpu_tlbstate (err -22)
kernel: [    6.235463] kvm_intel: Unknown symbol mds_user_clear (err 0)
kernel: [    6.330732] kvm_intel: disagrees about version of symbol cpu_tlbstate


I've tried re-installing the kvm modules per the visualization wiki to no avail and I've tried installing the linux-microcode package but that hasn't helped either.  I ended up backing out the linux-microcode package and have booted back to the 4.9.0-8 kernel.  Going back to this previous kernel has solved the issue and my guest VM's are now running fine.