Bug#929709: libgdbm6: file exists in libgdbm-dev as well as gdbm

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Bug#929709: libgdbm6: file exists in libgdbm-dev as well as gdbm

Luke Kenneth Casson Leighton
Package: libgdbm6
Version: 1.18.1-4
Severity: serious
Justification: 2

Unpacking libgdbm-dev:amd64 (1.18.1-4) ...
dpkg: error processing archive /var/cache/apt/archives/libgdbm-dev_1.18.1-4_amd64.deb (--unpack):
 trying to overwrite '/usr/share/info/gdbm.info.gz', which is also in package libgdbm3:amd64 1.8.3-11
Errors were encountered while processing:
 /var/cache/apt/archives/libgdbm-dev_1.18.1-4_amd64.deb


-- System Information:
Debian Release: 8.1
  APT prefers oldoldstable
  APT policy: (500, 'oldoldstable'), (500, 'testing'), (500, 'stable'), (500, 'oldstable')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 4.13.0-1-amd64 (SMP w/8 CPU cores)
Locale: LANG=en_GB.UTF-8, LC_CTYPE=en_GB.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages libgdbm6 depends on:
ii  libc6  2.28-2

libgdbm6 recommends no packages.

Versions of packages libgdbm6 suggests:
pn  gdbm-l10n  <none>

-- no debconf information

Reply | Threaded
Open this post in threaded view
|

Bug#929709: libgdbm6: file exists in libgdbm-dev as well as gdbm

Dmitry Bogatov-3

control: severity -1 minor

[2019-05-29 13:31] lkcl <[hidden email]>

> Package: libgdbm6
> Version: 1.18.1-4
> Severity: serious
> Justification: 2
>
> Unpacking libgdbm-dev:amd64 (1.18.1-4) ...
> dpkg: error processing archive /var/cache/apt/archives/libgdbm-dev_1.18.1-4_amd64.deb (--unpack):
>  trying to overwrite '/usr/share/info/gdbm.info.gz', which is also in package libgdbm3:amd64 1.8.3-11
> Errors were encountered while processing:
>  /var/cache/apt/archives/libgdbm-dev_1.18.1-4_amd64.deb

Issue, yes. But you are upgrading from rather old version of libgdbm3.
According to https://tracker.debian.org/gdbm, it predates even
old-stable.

Since Debian does not support skip upgrades, this issue is not
release-critical. Downgrading severity.

I just checked in virtual machine, upgrade stable (1.8.3-14) -> testing
(1.18.1-4) seems fine. Please, consider upgrading gradually.

I doubt that release team would approve unblock for issue of upsupported
upgrade, sorry.
--
        Note, that I send and fetch email in batch, once every 24 hours.
                 If matter is urgent, try https://t.me/kaction
                                                                             --

Reply | Threaded
Open this post in threaded view
|

Bug#929709: libgdbm6: file exists in libgdbm-dev as well as gdbm

Dmitry Bogatov-3
In reply to this post by Luke Kenneth Casson Leighton

control: severity -1 minor

[2019-05-29 13:31] lkcl <[hidden email]>

> Package: libgdbm6
> Version: 1.18.1-4
> Severity: serious
> Justification: 2
>
> Unpacking libgdbm-dev:amd64 (1.18.1-4) ...
> dpkg: error processing archive /var/cache/apt/archives/libgdbm-dev_1.18.1-4_amd64.deb (--unpack):
>  trying to overwrite '/usr/share/info/gdbm.info.gz', which is also in package libgdbm3:amd64 1.8.3-11
> Errors were encountered while processing:
>  /var/cache/apt/archives/libgdbm-dev_1.18.1-4_amd64.deb

Issue, yes. But you are upgrading from rather old version of libgdbm3.
According to https://tracker.debian.org/gdbm, it predates even
old-stable.

Since Debian does not support skip upgrades, this issue is not
release-critical. Downgrading severity.

I just checked in virtual machine, upgrade stable (1.8.3-14) -> testing
(1.18.1-4) seems fine. Please, consider upgrading gradually.

I doubt that release team would approve unblock for issue of upsupported
upgrade, sorry.
--
        Note, that I send and fetch email in batch, once every 24 hours.
                 If matter is urgent, try https://t.me/kaction
                                                                             --

Reply | Threaded
Open this post in threaded view
|

Bug#929709: libgdbm6: file exists in libgdbm-dev as well as gdbm

Luke Kenneth Casson Leighton
In reply to this post by Luke Kenneth Casson Leighton
On Fri, May 31, 2019 at 5:09 AM Dmitry Bogatov <[hidden email]> wrote:

> > Unpacking libgdbm-dev:amd64 (1.18.1-4) ...
> > dpkg: error processing archive /var/cache/apt/archives/libgdbm-dev_1.18.1-4_amd64.deb (--unpack):
> >  trying to overwrite '/usr/share/info/gdbm.info.gz', which is also in package libgdbm3:amd64 1.8.3-11
> > Errors were encountered while processing:
> >  /var/cache/apt/archives/libgdbm-dev_1.18.1-4_amd64.deb
>
> Issue, yes. But you are upgrading from rather old version of libgdbm3.
> According to https://tracker.debian.org/gdbm, it predates even
> old-stable.

 ah ok, not a problem then - i thought the existing version was more
recent than that, missed that it was 1.8 rather than 1.18.

l.