Bug#929841: crda: Failed to set regulatory domain: -7

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Bug#929841: crda: Failed to set regulatory domain: -7

Thorsten Glaser
Package: crda
Version: 3.18-1
Severity: serious
Justification: fails

tglase@tglase-nb:~ $ fgrep -i -e crda -e regdom /var/log/syslog
Jun  1 17:06:26 tglase-nb vmunix: [   32.679951] systemd-udevd[2262]: Process '/sbin/crda' failed with exit code 255.
tglase@tglase-nb:~ $ sudo cleanenv / COUNTRY=DE /sbin/crda
Failed to set regulatory domain: -7

When called manually, its errorlevel is 249 though, not 255.

Note: “cleanenv /” does
 cd /; /usr/bin/env -i PATH=/bin:/usr/bin:/sbin:/usr/sbin HOME=/ "$@"

-- System Information:
Debian Release: 10.0
  APT prefers buildd-unstable
  APT policy: (500, 'buildd-unstable'), (500, 'unstable'), (1, 'experimental')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 4.19.0-5-amd64 (SMP w/2 CPU cores)
Locale: LANG=C, LC_CTYPE=C.UTF-8 (charmap=UTF-8), LANGUAGE=C (charmap=UTF-8)
Shell: /bin/sh linked to /bin/lksh
Init: sysvinit (via /sbin/init)

Versions of packages crda depends on:
ii  iw                5.0.1-1
ii  libc6             2.28-10
ii  libnl-3-200       3.4.0-1
ii  libnl-genl-3-200  3.4.0-1
ii  libssl1.1         1.1.1b-2
ii  wireless-regdb    2016.06.10-1

crda recommends no packages.

crda suggests no packages.

-- Configuration Files:
/etc/default/crda changed:
REGDOMAIN=DE


-- no debconf information
Reply | Threaded
Open this post in threaded view
|

Bug#929841: crda: Failed to set regulatory domain: -7

Ben Hutchings-3
Control: tag -1 unreproducible moreinfo
Control: severity -1 normal

On Sat, 2019-06-01 at 17:11 +0200, Thorsten Glaser wrote:
> Package: crda
> Version: 3.18-1
> Severity: serious
> Justification: fails
>
> tglase@tglase-nb:~ $ fgrep -i -e crda -e regdom /var/log/syslog
> Jun  1 17:06:26 tglase-nb vmunix: [   32.679951] systemd-udevd[2262]: Process '/sbin/crda' failed with exit code 255.

Well, it works for me.  What does "iw reg get" report?

> tglase@tglase-nb:~ $ sudo cleanenv / COUNTRY=DE /sbin/crda
> Failed to set regulatory domain: -7
>
> When called manually, its errorlevel is 249 though, not 255.
>
> Note: “cleanenv /” does
>  cd /; /usr/bin/env -i PATH=/bin:/usr/bin:/sbin:/usr/sbin HOME=/ "$@"

The kernel rejects unsolicited regulatory information, and that's not a
bug.

Ben.

--
Ben Hutchings
Experience is what causes a person to make new mistakes
instead of old ones.


signature.asc (849 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Processed: Re: Bug#929841: crda: Failed to set regulatory domain: -7

Debian Bug Tracking System
In reply to this post by Thorsten Glaser
Processing control commands:

> tag -1 unreproducible moreinfo
Bug #929841 [crda] crda: Failed to set regulatory domain: -7
Added tag(s) moreinfo and unreproducible.
> severity -1 normal
Bug #929841 [crda] crda: Failed to set regulatory domain: -7
Severity set to 'normal' from 'serious'

--
929841: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=929841
Debian Bug Tracking System
Contact [hidden email] with problems