Bug#930343: libgcr410 FTCBFS: uses the wrong compiler

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Bug#930343: libgcr410 FTCBFS: uses the wrong compiler

Helmut Grohne
Source: libgcr410
Version: 2.4.0-9.2
Tags: patch
User: [hidden email]
Usertags: ftcbfs

libgcr410 fails to cross build from source, because it does not pass
cross tools to make. The easiest way of doing so - using dh_auto_build -
makes libgcr410 cross buildable. Please consider applying the attached
patch.

Helmut

libgcr410_2.4.0-9.3.debdiff (749 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Bug#930343: libgcr410 FTCBFS: uses the wrong compiler

p2-2

Go ahead.

Peter.

On 2019-06-11 06:13:16 (+0200), Helmut Grohne <[hidden email]> wrote:

> Source: libgcr410
> Version: 2.4.0-9.2
> Tags: patch
> User: [hidden email]
> Usertags: ftcbfs
>
> libgcr410 fails to cross build from source, because it does not pass
> cross tools to make. The easiest way of doing so - using dh_auto_build -
> makes libgcr410 cross buildable. Please consider applying the attached
> patch.
>
> Helmut

> diff -u libgcr410-2.4.0/debian/changelog libgcr410-2.4.0/debian/changelog
> --- libgcr410-2.4.0/debian/changelog
> +++ libgcr410-2.4.0/debian/changelog
> @@ -1,3 +1,10 @@
> +libgcr410 (2.4.0-9.3) UNRELEASED; urgency=medium
> +
> +  * Non-maintainer upload.
> +  * Fix FTCBFS: Let dh_auto_build pass cross tools to make. (Closes: #-1)
> +
> + -- Helmut Grohne <[hidden email]>  Tue, 11 Jun 2019 06:10:48 +0200
> +
>  libgcr410 (2.4.0-9.2) unstable; urgency=low
>  
>    * Non-maintainer upload.
> diff -u libgcr410-2.4.0/debian/rules libgcr410-2.4.0/debian/rules
> --- libgcr410-2.4.0/debian/rules
> +++ libgcr410-2.4.0/debian/rules
> @@ -3,7 +3,7 @@
>  build: build-stamp
>  build-stamp:
>   dh_testdir
> - $(MAKE)
> + dh_auto_build
>   touch build-stamp
>  
>  clean: