Bug#930421: /etc/courier/shared/index: Permission denied

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Bug#930421: /etc/courier/shared/index: Permission denied

Paul Menzel-5
Package: courier-imap
Version: 4.17.2+0.76.3-5+deb9u1
Severity: normal

Dear Debian folks,


The permissions of the file `/etc/courier/shared/index` do not seem
to be updated when upgrading from Debian 8 (Jessie) to 9 (Stretch).
During the update it was announced that the new user and group are
supposed to be `courier`.

    $ ls -ld /etc/courier/shared/
    drwxr-x---. 2 root courier 4096 Feb  7  2016 /etc/courier/shared/
    $ sudo ls -l /etc/courier/shared/
    total 0
    -rw-r--r--. 1 root root 0 Sep  7  2008 index

What are the correct permissions? I only executed the command below.

    sudo chown courier: /etc/courier/shared/index

Should the directly user also be changed?


Kind regards,

Paul

-- System Information:
Debian Release: 9.9
  APT prefers stable
  APT policy: (500, 'stable')
Architecture: amd64 (x86_64)

Kernel: Linux 4.19.0-4-amd64 (SMP w/2 CPU cores)
Locale: LANG=en_AU.UTF-8, LC_CTYPE=en_AU.UTF-8 (charmap=UTF-8), LANGUAGE=en_AU.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages courier-imap depends on:
ii  courier-authlib                            0.66.4-9
ii  courier-base                               0.76.3-5+deb9u1
ii  debconf [debconf-2.0]                      1.5.61
ii  exim4-daemon-light [mail-transport-agent]  4.89-2+deb9u4
ii  init-system-helpers                        1.48
ii  libc6                                      2.24-11+deb9u4
ii  libcourier-unicode1                        1.4-3+b1
ii  libfam0                                    2.7.0-17.2+b1
ii  libgdbm3                                   1.8.3-14
ii  libidn11                                   1.33-1
ii  sysvinit-utils                             2.88dsf-59.9

courier-imap recommends no packages.

Versions of packages courier-imap suggests:
pn  courier-doc         <none>
ii  mutt [imap-client]  1.7.2-1+deb9u1

-- Configuration Files:
/etc/courier/imapd-ssl changed:
SSLPORT=993
SSLADDRESS=0
SSLPIDFILE=/run/courier/imapd-ssl.pid
SSLLOGGEROPTS="-name=imapd-ssl"
IMAPDSSLSTART=YES
IMAPDSTARTTLS=YES
IMAP_TLS_REQUIRED=1
COURIERTLS=/usr/bin/couriertls
TLS_CERTFILE=/etc/courier/imapd.pem
TLS_DHPARAMS=/etc/courier/dhparams.pem
TLS_TRUSTCERTS=/etc/ssl/certs
TLS_VERIFYPEER=NONE
TLS_CACHEFILE=/var/lib/courier/couriersslcache
TLS_CACHESIZE=524288
MAILDIRPATH=Maildir

/etc/courier/imapd.cnf [Errno 13] Permission denied: '/etc/courier/imapd.cnf'

-- no debconf information


smime.p7s (6K) Download Attachment