Bug#931024: kthresher: Uses Package.section, incompatible with python-apt 1.9

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Bug#931024: kthresher: Uses Package.section, incompatible with python-apt 1.9

Julian Andres Klode-4
Package: kthresher
Severity: normal
User: [hidden email]
Usertags: apt-1.9.0

According to codesearch.d.n, kthresher contains trhe line:

            "kernel" in pkg.section and re.match(kernel_image_regex, pkg_name)

The use of the section on packages has been deprecated ages ago, as
it can vary between versions.

This causes kthresher to stop working with apt 1.9, so please migrate to
using a version's section after the buster release.

--
debian developer - deb.li/jak | jak-linux.org - free software dev
ubuntu core developer                              i speak de, en

Reply | Threaded
Open this post in threaded view
|

Bug#931024: kthresher: Uses Package.section, incompatible with python-apt 1.9

Darshaka Pathirana-2
forwarded 931024 https://github.com/rackerlabs/kthresher/issues/80
thanks

Hi Julian,

On 6/24/19 7:11 PM, Julian Andres Klode wrote:

> Package: kthresher
> Severity: normal
> User: [hidden email]
> Usertags: apt-1.9.0
>
> According to codesearch.d.n, kthresher contains trhe line:
>
>             "kernel" in pkg.section and re.match(kernel_image_regex, pkg_name)
>
> The use of the section on packages has been deprecated ages ago, as
> it can vary between versions.
>
> This causes kthresher to stop working with apt 1.9, so please migrate to
> using a version's section after the buster release.
Thanks for the bug report.

I've opened an upstream issue[1] to handle this bug.

 [1] https://github.com/rackerlabs/kthresher/issues/80

Regards,
 - Darsha


signature.asc (849 bytes) Download Attachment