Bug#931498: gmpc-plugins: Some plugins are disabled

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Bug#931498: gmpc-plugins: Some plugins are disabled

Martin Tharby Jones
Package: gmpc-plugins
Version: 11.8.16-3
Severity: important

Dear Maintainer,

I want to use the gmpc-albumview plugin but it is not built as part of the
stable release. I checked at https://gmpclient.org/plugins and it is still
listed.

I downloaded the source from the link
(http://download.sarine.nl/Programs/gmpc/0.20.0/gmpc-albumview-0.20.0.tar.gz)
on https://gmpc.fandom.com/wiki/GMPC_PLUGIN_ALBUMVIEW.

This fails to build due to following error:

[...]
libtool: compile:  gcc -DHAVE_CONFIG_H -I. -I.. -pthread -I/usr/include/gmpc
-I/usr/include/gtk-2.0 -I/usr/lib/x86_64-linux-gnu/gtk-2.0/include
-I/usr/include/gio-unix-2.0/ -I/usr/include/cairo -I/usr/include/pango-1.0
-I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pixman-1
-I/usr/include/libpng16 -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/libpng16
-I/usr/include/pango-1.0 -I/usr/include/harfbuzz -I/usr/include/pango-1.0
-I/usr/include/glib-2.0 -I/usr/lib/x86_64-linux-gnu/glib-2.0/include
-I/usr/include/freetype2 -I/usr/include/libmpd-1.0/
-DPIXMAP_DATA_DIR=\"/usr/share/gmpc-albumview/icons\" -g -O2 -MT
albumviewplugin_la-plugin.lo -MD -MP -MF .deps/albumviewplugin_la-plugin.Tpo -c
plugin.c  -fPIC -DPIC -o .libs/albumviewplugin_la-plugin.o
In file included from /usr/include/string.h:630:0,
                 from /usr/include/glib-2.0/glib/gi18n-lib.h:24,
                 from plugin.c:3:
/usr/include/libmpd-1.0/libmpd/libmpd-internal.h:210:10: error: expected
identifier or ‘(’ before ‘__extension__’
 char *   strndup     (const char *s, size_t n);
          ^
plugin.c: In function ‘load_list_itterate’:
[...]

This unhelpful message is caused by the redeclaration of strndup(), it is also
declared in string.h.

The declaration in libmpd-internal.h is protected by #ifndef but HAVE_STRNDUP
is not defined in config.h

#ifndef HAVE_STRNDUP
char *          strndup                                 (const char *s, size_t
n);
#endif

Adding #define HAVE_STRNDUP to config.h gives me a useable build but I don't
know enough about autotools so I had to make the addition manually. The problem
seems to be associated with older versions of the C library not providing
strndup().

Several other plugins were disabled as a workaround to fix Debian Bug report
#807735 so a proper fix for this should work for them also. A workaround like
this should have reduced the severity of this bug not closed it!

Yours

Martin



-- System Information:
Debian Release: 9.9
  APT prefers stable-updates
  APT policy: (500, 'stable-updates'), (500, 'stable')
Architecture: amd64 (x86_64)

Kernel: Linux 4.9.0-9-amd64 (SMP w/4 CPU cores)
Locale: LANG=en_GB.UTF-8, LC_CTYPE=en_GB.UTF-8 (charmap=UTF-8), LANGUAGE=en_GB.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages gmpc-plugins depends on:
ii  gmpc                 11.8.16-10
ii  libatk1.0-0          2.22.0-1
ii  libavahi-client3     0.6.32-2
ii  libavahi-common3     0.6.32-2
ii  libavahi-glib1       0.6.32-2
ii  libc6                2.24-11+deb9u4
ii  libcairo2            1.14.8-1
ii  libdbus-1-3          1.10.28-0+deb9u1
ii  libdbus-glib-1-2     0.108-2
ii  libfontconfig1       2.11.0-6.7+b1
ii  libfreetype6         2.6.3-3.2
ii  libgdk-pixbuf2.0-0   2.36.5-2+deb9u2
ii  libglib2.0-0         2.50.3-2
ii  libgtk2.0-0          2.24.31-2
ii  libmpd1              0.20.0-2~deb9u1
ii  libpango-1.0-0       1.40.5-1
ii  libpangocairo-1.0-0  1.40.5-1
ii  libpangoft2-1.0-0    1.40.5-1
ii  libxml2              2.9.4+dfsg1-2.2+deb9u2

gmpc-plugins recommends no packages.

gmpc-plugins suggests no packages.

-- no debconf information
Reply | Threaded
Open this post in threaded view
|

Bug#931498: Bug present in Debian GNU/Linux 10 (buster)

Martin Tharby Jones
Dear Maintainer,

I've just upgrade to buster and the bug is still the same.

Yours

Martin