Bug#931612: python3-autobahn: wrong dependency should be python3-pyqrcode instead python-qrcode

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Bug#931612: python3-autobahn: wrong dependency should be python3-pyqrcode instead python-qrcode

Goetz, Philippe
Package: python3-autobahn
Version: 17.10.1+dfsg1-3
Severity: normal

Dear Maintainer,

   * What led up to the situation?
     Open Source Clearing - python-qrcode imports GPL libraries
     checking shows that pyqrcode is imported and not qrcode
   * What exactly did you do (or not do) that was effective (or
     ineffective)?
     import pyqrcode could not work within autobahn.wamp library
   * What was the outcome of this action?
     nothing for me
   * What outcome did you expect instead?
     N/A

  Same problem apply to python-autobahn

-- System Information:
Debian Release: 10.0
  APT prefers stable
  APT policy: (500, 'stable')
Architecture: amd64 (x86_64)

Kernel: Linux 4.19.0-5-amd64 (SMP w/1 CPU core)
Kernel taint flags: TAINT_OOT_MODULE, TAINT_UNSIGNED_MODULE
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8), LANGUAGE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /usr/bin/dash
Init: systemd (via /run/systemd/system)
LSM: AppArmor: enabled

Versions of packages python3-autobahn depends on:
ii  python3                   3.7.3-1
ii  python3-cbor              1.0.0-1+b1
ii  python3-lz4               1.1.0+dfsg-1
ii  python3-nacl              1.3.0-2
ii  python3-openssl           19.0.0-1
ii  python3-qrcode            6.1-1
ii  python3-service-identity  16.0.0-2
ii  python3-six               1.12.0-1
ii  python3-snappy            0.5.3-1
ii  python3-trie              0.2+ds-1
ii  python3-twisted           18.9.0-3
ii  python3-txaio             2.10.0-1
ii  python3-u-msgpack         2.1-1
ii  python3-ubjson            0.12.0-1
ii  python3-wsaccel           0.6.2-1+b1
ii  python3-zope.interface    4.3.2-1+b2

python3-autobahn recommends no packages.

python3-autobahn suggests no packages.

-- no debconf information