Bug#931903: node-acorn: fails to upgrade from 'sid' - trying to overwrite /usr/lib/nodejs/acorn-dynamic-import/lib/index.js

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Bug#931903: node-acorn: fails to upgrade from 'sid' - trying to overwrite /usr/lib/nodejs/acorn-dynamic-import/lib/index.js

Andreas Beckmann-4
Package: node-acorn
Version: 6.0.2+20181021git007b08d01eff070+ds+~0.3.1+~4.0.0+~0.3.0+~5.0.0+ds+~1.6.1+ds-1
Severity: serious
User: [hidden email]
Usertags: piuparts

Hi,

during a test with piuparts I noticed your package fails to upgrade from
'sid' to 'experimental'.
It installed fine in 'sid', then the upgrade to 'experimental' fails
because it tries to overwrite other packages files without declaring a
Breaks+Replaces relation.

See policy 7.6 at
https://www.debian.org/doc/debian-policy/ch-relationships.html#overwriting-files-and-replacing-packages-replaces

From the attached log (scroll to the bottom...):

  Preparing to unpack .../node-acorn_6.0.2+20181021git007b08d01eff070+ds+~0.3.1+~4.0.0+~0.3.0+~5.0.0+ds+~1.6.1+ds-1_all.deb ...
  Unpacking node-acorn (6.0.2+20181021git007b08d01eff070+ds+~0.3.1+~4.0.0+~0.3.0+~5.0.0+ds+~1.6.1+ds-1) over (5.5.3+ds3-3) ...
  dpkg: error processing archive /var/cache/apt/archives/node-acorn_6.0.2+20181021git007b08d01eff070+ds+~0.3.1+~4.0.0+~0.3.0+~5.0.0+ds+~1.6.1+ds-1_all.deb (--unpack):
   trying to overwrite '/usr/lib/nodejs/acorn-dynamic-import/lib/index.js', which is also in package node-acorn-dynamic-import 4.0.0-1
  Errors were encountered while processing:
   /var/cache/apt/archives/node-acorn_6.0.2+20181021git007b08d01eff070+ds+~0.3.1+~4.0.0+~0.3.0+~5.0.0+ds+~1.6.1+ds-1_all.deb


cheers,

Andreas

node-acorn-dynamic-import=4.0.0-1_node-acorn=6.0.2+20181021git007b08d01eff070+ds+~0.3.1+~4.0.0+~0.3.0+~5.0.0+ds+~1.6.1+ds-1.log.gz (10K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Bug#931903: marked as done (node-acorn: fails to upgrade from 'sid' - trying to overwrite /usr/lib/nodejs/acorn-dynamic-import/lib/index.js)

Debian Bug Tracking System
Your message dated Fri, 12 Jul 2019 10:37:14 +0200
with message-id <[hidden email]>
and subject line Fixed after recent node-acorn-dynamic-import downgrade
has caused the Debian Bug report #931903,
regarding node-acorn: fails to upgrade from 'sid' - trying to overwrite /usr/lib/nodejs/acorn-dynamic-import/lib/index.js
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact [hidden email]
immediately.)


--
931903: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=931903
Debian Bug Tracking System
Contact [hidden email] with problems

Package: node-acorn
Version: 6.0.2+20181021git007b08d01eff070+ds+~0.3.1+~4.0.0+~0.3.0+~5.0.0+ds+~1.6.1+ds-1
Severity: serious
User: [hidden email]
Usertags: piuparts

Hi,

during a test with piuparts I noticed your package fails to upgrade from
'sid' to 'experimental'.
It installed fine in 'sid', then the upgrade to 'experimental' fails
because it tries to overwrite other packages files without declaring a
Breaks+Replaces relation.

See policy 7.6 at
https://www.debian.org/doc/debian-policy/ch-relationships.html#overwriting-files-and-replacing-packages-replaces

From the attached log (scroll to the bottom...):

  Preparing to unpack .../node-acorn_6.0.2+20181021git007b08d01eff070+ds+~0.3.1+~4.0.0+~0.3.0+~5.0.0+ds+~1.6.1+ds-1_all.deb ...
  Unpacking node-acorn (6.0.2+20181021git007b08d01eff070+ds+~0.3.1+~4.0.0+~0.3.0+~5.0.0+ds+~1.6.1+ds-1) over (5.5.3+ds3-3) ...
  dpkg: error processing archive /var/cache/apt/archives/node-acorn_6.0.2+20181021git007b08d01eff070+ds+~0.3.1+~4.0.0+~0.3.0+~5.0.0+ds+~1.6.1+ds-1_all.deb (--unpack):
   trying to overwrite '/usr/lib/nodejs/acorn-dynamic-import/lib/index.js', which is also in package node-acorn-dynamic-import 4.0.0-1
  Errors were encountered while processing:
   /var/cache/apt/archives/node-acorn_6.0.2+20181021git007b08d01eff070+ds+~0.3.1+~4.0.0+~0.3.0+~5.0.0+ds+~1.6.1+ds-1_all.deb


cheers,

Andreas


node-acorn-dynamic-import=4.0.0-1_node-acorn=6.0.2+20181021git007b08d01eff070+ds+~0.3.1+~4.0.0+~0.3.0+~5.0.0+ds+~1.6.1+ds-1.log.gz (10K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Processed: Re: Bug#931903 closed by Xavier <yadd@debian.org> (Fixed after recent node-acorn-dynamic-import downgrade)

Debian Bug Tracking System
In reply to this post by Andreas Beckmann-4
Processing control commands:

> reopen -1
Bug #931903 {Done: Xavier <[hidden email]>} [node-acorn] node-acorn: fails to upgrade from 'sid' - trying to overwrite /usr/lib/nodejs/acorn-dynamic-import/lib/index.js
Bug reopened
Ignoring request to alter fixed versions of bug #931903 to the same values previously set

--
931903: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=931903
Debian Bug Tracking System
Contact [hidden email] with problems