Bug#932731: zfsutils-linux 0.7.12-2+deb10u1~bpo9+1 conflicts insserv on stretch-backports

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Bug#932731: zfsutils-linux 0.7.12-2+deb10u1~bpo9+1 conflicts insserv on stretch-backports

Richard Stanway-3
Package: zfsutils-linux
Version: 0.7.12-1~bpo9+1
Severity: normal

Dear Maintainer,

I recently tried to upgrade ZFS from stretch-backports 0.7.12-1~bpo9+1 to
0.7.12-2+deb10u1~bpo9+1 and apt refused the install, suggesting a bad
plan of removing most packages and using ZFS via fuse. After looking
which packages were not installing, zfsutils-linux seems responsible.

This seems to be a result of the fix for #915831:

[ Aron Xu ]
     * Add XS-Autobuild: yes to d/control
     * Conflicts with insserv << 1.18 (Closes: #915831)

# apt -V install zfsutils-linux
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 zfsutils-linux : Conflicts: insserv (< 1.18) but 1.14.0-5.4+b1 is to be
 installed

This version of insserv is only available in buster, which doesn't seem
right for the stretch-backports package.


-- System Information:
Debian Release: 9.9
  APT prefers oldstable-updates
  APT policy: (990, 'oldstable-updates'), (500, 'oldstable'), (100, 'unstable')
Architecture: amd64 (x86_64)

Kernel: Linux 4.9.0-9-amd64 (SMP w/48 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8), LANGUAGE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages zfsutils-linux depends on:
ii  init-system-helpers  1.48
ii  libblkid1            2.29.2-1+deb9u1
ii  libc6                2.24-11+deb9u4
ii  libnvpair1linux      0.7.12-1~bpo9+1
ii  libuuid1             2.29.2-1+deb9u1
ii  libuutil1linux       0.7.12-1~bpo9+1
ii  libzfs2linux         0.7.12-1~bpo9+1
ii  libzpool2linux       0.7.12-1~bpo9+1
ii  python3              3.5.3-1
ii  zlib1g               1:1.2.8.dfsg-5

Versions of packages zfsutils-linux recommends:
ii  lsb-base                9.20161125
ii  zfs-dkms [zfs-modules]  0.7.12-1~bpo9+1
ii  zfs-zed                 0.7.12-1~bpo9+1

Versions of packages zfsutils-linux suggests:
pn  nfs-kernel-server  <none>
pn  samba-common-bin   <none>
ii  zfs-initramfs      0.6.5.9-5

-- Configuration Files:
/etc/sudoers.d/zfs [Errno 13] Permission denied: '/etc/sudoers.d/zfs'

-- no debconf information