Bug#933835: libreoffice not start with fatal exception signal 11

classic Classic list List threaded Threaded
19 messages Options
Reply | Threaded
Open this post in threaded view
|

Bug#933835: libreoffice not start with fatal exception signal 11

Zdzislaw Kaleta
Package: libreoffice
Version: 1:6.3.0~rc2-1
Severity: grave
Tags: a11y
Justification: renders package unusable

After normal upgradin a system from apt libre office wont start any more.
Program not start and when put libreoffoce at console there is info:

sanskryt@sauron:~$ libreoffice


Fatal exception: Signal 11
Stack:
/usr/lib/libreoffice/program/libuno_sal.so.3(+0x3bf83)[0x7fc06a40af83]
/usr/lib/libreoffice/program/libuno_sal.so.3(+0x3c193)[0x7fc06a40b193]
/lib/x86_64-linux-gnu/libc.so.6(+0x37840)[0x7fc06a1e9840]
/usr/lib/libreoffice/program/libuno_cppu.so.3(+0x14322)[0x7fc06740b322]
/usr/lib/libreoffice/program/libuno_cppu.so.3(uno_type_any_assign+0x97)[0x7fc06740a717]
/usr/lib/libreoffice/program/libmergedlo.so(+0x299f047)[0x7fc06cdcb047]
/usr/lib/libreoffice/program/libmergedlo.so(+0x299fe85)[0x7fc06cdcbe85]
/usr/lib/libreoffice/program/libmergedlo.so(_ZN3utl10ConfigItemC2ERKN3rtl8OUStringE14ConfigItemMode+0x7b)[0x7fc06cdc104b]
/usr/lib/libreoffice/program/libmergedlo.so(+0x29f0725)[0x7fc06ce1c725]
/usr/lib/libreoffice/program/libmergedlo.so(_ZN19SvtSysLocaleOptionsC1Ev+0x11f)[0x7fc06ce1dc1f]
/usr/lib/libreoffice/program/libmergedlo.so(_Z7InitVCLv+0x1a2)[0x7fc06d1ddab2]
/usr/lib/libreoffice/program/libmergedlo.so(_Z10ImplSVMainv+0x105)[0x7fc06d1df395]
/usr/lib/libreoffice/program/libmergedlo.so(soffice_main+0x91)[0x7fc06c28db41]
/usr/lib/libreoffice/program/soffice.bin(+0x107b)[0x555ea9ad007b]
/lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xeb)[0x7fc06a1d609b]
/usr/lib/libreoffice/program/soffice.bin(+0x10ba)[0x555ea9ad00ba]


Dear Maintainer,

*** Reporter, please consider answering these questions, where appropriate ***

   * What led up to the situation?
   * What exactly did you do (or not do) that was effective (or
     ineffective)?
   * What was the outcome of this action?
   * What outcome did you expect instead?

*** End of the template - remove these template lines ***


-- System Information:
Debian Release: bullseye/sid
  APT prefers testing
  APT policy: (990, 'testing'), (500, 'unstable'), (500, 'stable'), (500, 'oldstable')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 4.19.0-5-amd64 (SMP w/4 CPU cores)
Kernel taint flags: TAINT_OOT_MODULE, TAINT_UNSIGNED_MODULE
Locale: LANG=pl_PL.UTF-8, LC_CTYPE=pl_PL.UTF-8 (charmap=UTF-8) (ignored: LC_ALL set to pl_PL.UTF-8), LANGUAGE=pl_PL.UTF-8 (charmap=UTF-8) (ignored: LC_ALL set to pl_PL.UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)
LSM: AppArmor: enabled

Versions of packages libreoffice depends on:
ii  libreoffice-base                1:6.3.0~rc2-1
ii  libreoffice-calc                1:6.3.0~rc2-1
ii  libreoffice-core                1:6.3.0~rc2-1
ii  libreoffice-draw                1:6.3.0~rc2-1
ii  libreoffice-impress             1:6.3.0~rc2-1
ii  libreoffice-math                1:6.3.0~rc2-1
ii  libreoffice-report-builder-bin  1:6.3.0~rc2-1
ii  libreoffice-writer              1:6.3.0~rc2-1
ii  python3-uno                     1:6.3.0~rc2-1

Versions of packages libreoffice recommends:
ii  fonts-crosextra-caladea             20130214-2
ii  fonts-crosextra-carlito             20130920-1
ii  fonts-dejavu                        2.37-1
ii  fonts-liberation                    1:1.07.4-10
ii  fonts-liberation2                   2.00.5-2
ii  fonts-linuxlibertine                5.3.0-4
ii  fonts-noto-core                     20181227-1
ii  fonts-noto-mono                     20181227-1
ii  fonts-noto-ui-core                  20181227-1
ii  fonts-sil-gentium-basic             1.102-1
ii  libreoffice-java-common             1:6.3.0~rc2-1
ii  libreoffice-nlpsolver               0.9+LibO6.3.0~rc2-1
ii  libreoffice-report-builder          1:6.3.0~rc2-1
ii  libreoffice-script-provider-bsh     1:6.3.0~rc2-1
ii  libreoffice-script-provider-js      1:6.3.0~rc2-1
ii  libreoffice-script-provider-python  1:6.3.0~rc2-1
ii  libreoffice-sdbc-mysql              1:6.3.0~rc2-1
ii  libreoffice-sdbc-postgresql         1:6.3.0~rc2-1
ii  libreoffice-wiki-publisher          1.2.0+LibO6.3.0~rc2-1

Versions of packages libreoffice suggests:
ii  cups-bsd                                           2.2.10-6
ii  default-jre [java6-runtime]                        2:1.11-72
pn  firefox-esr | thunderbird | firefox                <none>
ii  ghostscript                                        9.27~dfsg-3
ii  gnupg                                              2.2.17-3
pn  gpa                                                <none>
ii  gstreamer1.0-libav                                 1:1.14.4-dmo3
ii  gstreamer1.0-plugins-bad                           1:1.14.4-dmo7
ii  gstreamer1.0-plugins-base                          1.14.4-dmo2
ii  gstreamer1.0-plugins-good                          1.14.4-dmo2
ii  gstreamer1.0-plugins-ugly                          1:1.14.4-dmo2
ii  hunspell-en-us [hunspell-dictionary]               1:2018.04.16-1
ii  hunspell-pl [hunspell-dictionary]                  1:6.3.0~rc1-1
ii  hunspell-ru [hunspell-dictionary]                  1:6.3.0~rc1-1
ii  hyphen-de [hyphen-hyphenation-patterns]            1:6.3.0~rc1-1
ii  hyphen-en-us [hyphen-hyphenation-patterns]         2.8.8-7
ii  hyphen-pl [hyphen-hyphenation-patterns]            1:3.0a-4
ii  imagemagick                                        8:6.9.10.23+dfsg-2.1
ii  imagemagick-6.q16 [imagemagick]                    8:6.9.10.23+dfsg-2.1
ii  libgl1                                             1.1.0-1
ii  libreoffice-gnome                                  1:6.3.0~rc2-1
pn  libreoffice-help                                   <none>
pn  libreoffice-l10n                                   <none>
ii  libreoffice-librelogo                              1:6.3.0~rc2-1
ii  libreoffice-lightproof-ru-ru [libreoffice-grammar  0.3.4+1.6-1
ii  libreoffice-officebean                             1:6.3.0~rc2-1
ii  libsane                                            1.0.27-3.2
ii  libxrender1                                        1:0.9.10-1
pn  myspell-dictionary                                 <none>
ii  mythes-en-us [mythes-thesaurus]                    1:6.3.0~rc1-1
ii  mythes-pl [mythes-thesaurus]                       1.5-4
pn  openclipart2-libreoffice | openclipart-libreoffic  <none>
ii  openjdk-10-jre [java6-runtime]                     10.0.2+13-2
ii  openjdk-11-jre [java6-runtime]                     11.0.4+11-1
ii  openjdk-8-jre [java6-runtime]                      8u222-b10-1
ii  oracle-java6-installer [java6-runtime]             6u45-0~webupd8~8
ii  oracle-java7-installer [java6-runtime]             7u80+7u60arm-0~webupd8~1
ii  oracle-java8-installer [java6-runtime]             8u201-1~webupd8~1
ii  oracle-java9-installer [java6-runtime]             9.0.4-1~webupd8~0
ii  pstoedit                                           3.73-1+b1
ii  unixodbc                                           2.3.6-0.1+b1

Versions of packages libreoffice-core depends on:
ii  fontconfig                      2.13.1-2
ii  fonts-opensymbol                2:102.11+LibO6.3.0~rc2-1
ii  libboost-date-time1.67.0        1.67.0-13
ii  libboost-locale1.67.0           1.67.0-13
ii  libc6                           2.28-10
ii  libcairo2                       1.16.0-4
ii  libclucene-contribs1v5          2.3.3.4+dfsg-1
ii  libclucene-core1v5              2.3.3.4+dfsg-1
ii  libcmis-0.5-5v5                 0.5.2-1
ii  libcups2                        2.2.10-6
ii  libcurl3-gnutls                 7.65.1-1
ii  libdbus-1-3                     1.12.16-1
ii  libdconf1                       0.30.1-2
ii  libeot0                         0.01-5
ii  libepoxy0                       1.5.3-0.1
ii  libexpat1                       2.2.7-1
ii  libexttextcat-2.0-0             3.4.5-1
ii  libfontconfig1                  2.13.1-2
ii  libfreetype6                    2.9.1-4
ii  libgcc1                         1:9.1.0-10
ii  libglib2.0-0                    2.60.6-1
ii  libgpgmepp6                     1.12.0-6
ii  libgraphite2-3                  1.3.13-7
ii  libgstreamer-plugins-base1.0-0  1.14.4-dmo2
ii  libgstreamer1.0-0               1.14.4-1
ii  libharfbuzz-icu0                2.5.3-1
ii  libharfbuzz0b                   2.5.3-1
ii  libhunspell-1.7-0               1.7.0-2+b1
ii  libhyphen0                      2.8.8-7
ii  libice6                         2:1.0.9-2
ii  libicu63                        63.2-2
ii  libjpeg62-turbo                 1:1.5.2-2+b1
ii  liblcms2-2                      2.9-3
ii  libldap-2.4-2                   2.4.48+dfsg-1
ii  libmythes-1.2-0                 2:1.2.4-3+b1
ii  libneon27-gnutls                0.30.2-3
ii  libnspr4                        2:4.21-1
ii  libnss3                         2:3.45-1
ii  libnumbertext-1.0-0             1.0.5-1
ii  libodfgen-0.1-1                 0.1.7-1
ii  liborcus-0.14-0                 0.14.1-6
ii  libpng16-16                     1.6.37-1
ii  libpoppler82                    0.71.0-5
ii  librdf0                         1.0.17-1.1+b1
ii  libreoffice-common              1:6.3.0~rc2-1
ii  librevenge-0.0-0                0.0.4-6+b1
ii  libsm6                          2:1.2.3-1
ii  libstdc++6                      9.1.0-10
ii  libx11-6                        2:1.6.7-1
ii  libxext6                        2:1.3.3-1+b2
ii  libxinerama1                    2:1.1.4-2
ii  libxml2                         2.9.4+dfsg1-7+b3
ii  libxmlsec1                      1.2.28-2
ii  libxmlsec1-nss                  1.2.28-2
ii  libxrandr2                      2:1.5.1-1
ii  libxrender1                     1:0.9.10-1
ii  libxslt1.1                      1.1.32-2
ii  uno-libs3                       6.3.0~rc2-1
ii  ure                             6.3.0~rc2-1
ii  zlib1g                          1:1.2.11.dfsg-1

Versions of packages libreoffice-core recommends:
ii  gstreamer1.0-libav         1:1.14.4-dmo3
ii  gstreamer1.0-plugins-bad   1:1.14.4-dmo7
ii  gstreamer1.0-plugins-base  1.14.4-dmo2
ii  gstreamer1.0-plugins-good  1.14.4-dmo2
ii  gstreamer1.0-plugins-ugly  1:1.14.4-dmo2
ii  libpaper-utils             1.1.28

Versions of packages libreoffice-writer depends on:
ii  libabw-0.1-1           0.1.2-1
ii  libc6                  2.28-10
ii  libe-book-0.1-1        0.1.3-1+b2
ii  libepubgen-0.1-1       0.1.1-1
ii  libetonyek-0.1-1       0.1.9-1
ii  libgcc1                1:9.1.0-10
ii  libicu63               63.2-2
ii  liblangtag1            0.6.2-1
ii  libmwaw-0.3-3          0.3.15-2
ii  libodfgen-0.1-1        0.1.7-1
ii  libreoffice-base-core  1:6.3.0~rc2-1
ii  libreoffice-core       1:6.3.0~rc2-1
ii  librevenge-0.0-0       0.0.4-6+b1
ii  libstaroffice-0.0-0    0.0.6-1
ii  libstdc++6             9.1.0-10
ii  libwpd-0.10-10         0.10.3-1
ii  libwpg-0.3-3           0.3.3-1
ii  libwps-0.4-4           0.4.10-1
ii  libxml2                2.9.4+dfsg1-7+b3
ii  uno-libs3              6.3.0~rc2-1
ii  ure                    6.3.0~rc2-1
ii  zlib1g                 1:1.2.11.dfsg-1

Versions of packages libreoffice-writer recommends:
ii  libreoffice-math  1:6.3.0~rc2-1

Versions of packages libreoffice-writer suggests:
ii  default-jre [java6-runtime]             2:1.11-72
ii  fonts-crosextra-caladea                 20130214-2
ii  fonts-crosextra-carlito                 20130920-1
ii  libreoffice-base                        1:6.3.0~rc2-1
ii  libreoffice-java-common                 1:6.3.0~rc2-1
ii  openjdk-10-jre [java6-runtime]          10.0.2+13-2
ii  openjdk-11-jre [java6-runtime]          11.0.4+11-1
ii  openjdk-8-jre [java6-runtime]           8u222-b10-1
ii  oracle-java6-installer [java6-runtime]  6u45-0~webupd8~8
ii  oracle-java7-installer [java6-runtime]  7u80+7u60arm-0~webupd8~1
ii  oracle-java8-installer [java6-runtime]  8u201-1~webupd8~1
ii  oracle-java9-installer [java6-runtime]  9.0.4-1~webupd8~0

Versions of packages libreoffice-calc depends on:
ii  coinor-libcbc3                   2.9.9+repack1-1
ii  coinor-libcoinmp1v5              1.8.3-2+b11
ii  coinor-libcoinutils3v5           2.10.14+repack1-1
ii  libatlas3-base [liblapack.so.3]  3.10.3-8
ii  libblas3 [libblas.so.3]          3.8.0-2
ii  libboost-filesystem1.67.0        1.67.0-13
ii  libboost-iostreams1.67.0         1.67.0-13
ii  libbz2-1.0                       1.0.6-9.2
ii  libc6                            2.28-10
ii  libetonyek-0.1-1                 0.1.9-1
ii  libgcc1                          1:9.1.0-10
ii  libicu63                         63.2-2
ii  liblapack3 [liblapack.so.3]      3.8.0-2
ii  liblcms2-2                       2.9-3
ii  libmwaw-0.3-3                    0.3.15-2
ii  libodfgen-0.1-1                  0.1.7-1
ii  liborcus-0.14-0                  0.14.1-6
ii  libreoffice-base-core            1:6.3.0~rc2-1
ii  libreoffice-core                 1:6.3.0~rc2-1
ii  librevenge-0.0-0                 0.0.4-6+b1
ii  libstaroffice-0.0-0              0.0.6-1
ii  libstdc++6                       9.1.0-10
ii  libwps-0.4-4                     0.4.10-1
ii  libxml2                          2.9.4+dfsg1-7+b3
ii  lp-solve                         5.5.0.15-4+b1
ii  uno-libs3                        6.3.0~rc2-1
ii  ure                              6.3.0~rc2-1
ii  zlib1g                           1:1.2.11.dfsg-1

Versions of packages libreoffice-calc suggests:
ii  ocl-icd-libopencl1  2.2.12-2

Versions of packages libreoffice-base depends on:
ii  libc6                     2.28-10
ii  libgcc1                   1:9.1.0-10
ii  libreoffice-base-core     1:6.3.0~rc2-1
ii  libreoffice-base-drivers  1:6.3.0~rc2-1
ii  libreoffice-core          1:6.3.0~rc2-1
ii  libstdc++6                9.1.0-10
ii  uno-libs3                 6.3.0~rc2-1
ii  ure                       6.3.0~rc2-1

Versions of packages libreoffice-base recommends:
ii  default-jre [java6-runtime]             2:1.11-72
ii  libreoffice-java-common                 1:6.3.0~rc2-1
ii  libreoffice-writer                      1:6.3.0~rc2-1
ii  openjdk-10-jre [java6-runtime]          10.0.2+13-2
ii  openjdk-11-jre [java6-runtime]          11.0.4+11-1
ii  openjdk-8-jre [java6-runtime]           8u222-b10-1
ii  oracle-java6-installer [java6-runtime]  6u45-0~webupd8~8
ii  oracle-java7-installer [java6-runtime]  7u80+7u60arm-0~webupd8~1
ii  oracle-java8-installer [java6-runtime]  8u201-1~webupd8~1
ii  oracle-java9-installer [java6-runtime]  9.0.4-1~webupd8~0

Versions of packages libreoffice-base suggests:
ii  libreoffice-report-builder  1:6.3.0~rc2-1
ii  unixodbc                    2.3.6-0.1+b1

Versions of packages libreoffice-draw depends on:
ii  libavahi-client3     0.7-4+b1
ii  libavahi-common3     0.7-4+b1
ii  libc6                2.28-10
ii  libcdr-0.1-1         0.1.5-1
ii  libdbus-1-3          1.12.16-1
ii  libfreehand-0.1-1    0.1.2-2
ii  libgcc1              1:9.1.0-10
ii  libglib2.0-0         2.60.6-1
ii  libicu63             63.2-2
ii  liblcms2-2           2.9-3
ii  libmspub-0.1-1       0.1.4-1+b2
ii  libmwaw-0.3-3        0.3.15-2
ii  libodfgen-0.1-1      0.1.7-1
ii  libpagemaker-0.0-0   0.0.4-1
ii  libpng16-16          1.6.37-1
ii  libqxp-0.0-0         0.0.2-1
ii  libreoffice-core     1:6.3.0~rc2-1
ii  librevenge-0.0-0     0.0.4-6+b1
ii  libstaroffice-0.0-0  0.0.6-1
ii  libstdc++6           9.1.0-10
ii  libvisio-0.1-1       0.1.6-1+b2
ii  libwpd-0.10-10       0.10.3-1
ii  libwpg-0.3-3         0.3.3-1
ii  libxml2              2.9.4+dfsg1-7+b3
ii  libzmf-0.0-0         0.0.2-1+b2
ii  uno-libs3            6.3.0~rc2-1
ii  ure                  6.3.0~rc2-1
ii  zlib1g               1:1.2.11.dfsg-1

Versions of packages libreoffice-impress depends on:
ii  libc6                2.28-10
ii  libepoxy0            1.5.3-0.1
ii  libetonyek-0.1-1     0.1.9-1
ii  libgcc1              1:9.1.0-10
ii  libmwaw-0.3-3        0.3.15-2
ii  libodfgen-0.1-1      0.1.7-1
ii  libreoffice-core     1:6.3.0~rc2-1
ii  libreoffice-draw     1:6.3.0~rc2-1
ii  librevenge-0.0-0     0.0.4-6+b1
ii  libstaroffice-0.0-0  0.0.6-1
ii  libstdc++6           9.1.0-10
ii  libxml2              2.9.4+dfsg1-7+b3
ii  uno-libs3            6.3.0~rc2-1
ii  ure                  6.3.0~rc2-1
ii  zlib1g               1:1.2.11.dfsg-1

Versions of packages libreoffice-impress suggests:
ii  bluez  5.50-1

Versions of packages libreoffice-math depends on:
ii  fonts-opensymbol  2:102.11+LibO6.3.0~rc2-1
ii  libc6             2.28-10
ii  libgcc1           1:9.1.0-10
ii  libreoffice-core  1:6.3.0~rc2-1
ii  libstdc++6        9.1.0-10
ii  uno-libs3         6.3.0~rc2-1
ii  ure               6.3.0~rc2-1

-- no debconf information

Reply | Threaded
Open this post in threaded view
|

Bug#933835: libreoffice not start with fatal exception signal 11

Rene Engelhard
tag 933835 + moreinfo
tag 933835 + unreproducible
tag 933835 - a11y
severity 933835 important
thanks

Hi,

On Sun, Aug 04, 2019 at 09:59:51AM +0200, sanskryt wrote:
> Package: libreoffice
> Version: 1:6.3.0~rc2-1
> Severity: grave
> Tags: a11y
> Justification: renders package unusable

No. It isn't a generic problem, and it isn't a11y per se.

> After normal upgradin a system from apt libre office wont start any more.
> Program not start and when put libreoffoce at console there is info:
>
> sanskryt@sauron:~$ libreoffice
>
>
> Fatal exception: Signal 11
> Stack:
> /usr/lib/libreoffice/program/libuno_sal.so.3(+0x3bf83)[0x7fc06a40af83]
> /usr/lib/libreoffice/program/libuno_sal.so.3(+0x3c193)[0x7fc06a40b193]
> /lib/x86_64-linux-gnu/libc.so.6(+0x37840)[0x7fc06a1e9840]
> /usr/lib/libreoffice/program/libuno_cppu.so.3(+0x14322)[0x7fc06740b322]
> /usr/lib/libreoffice/program/libuno_cppu.so.3(uno_type_any_assign+0x97)[0x7fc06740a717]
> /usr/lib/libreoffice/program/libmergedlo.so(+0x299f047)[0x7fc06cdcb047]
> /usr/lib/libreoffice/program/libmergedlo.so(+0x299fe85)[0x7fc06cdcbe85]
> /usr/lib/libreoffice/program/libmergedlo.so(_ZN3utl10ConfigItemC2ERKN3rtl8OUStringE14ConfigItemMode+0x7b)[0x7fc06cdc104b]
> /usr/lib/libreoffice/program/libmergedlo.so(+0x29f0725)[0x7fc06ce1c725]
> /usr/lib/libreoffice/program/libmergedlo.so(_ZN19SvtSysLocaleOptionsC1Ev+0x11f)[0x7fc06ce1dc1f]
> /usr/lib/libreoffice/program/libmergedlo.so(_Z7InitVCLv+0x1a2)[0x7fc06d1ddab2]
> /usr/lib/libreoffice/program/libmergedlo.so(_Z10ImplSVMainv+0x105)[0x7fc06d1df395]
> /usr/lib/libreoffice/program/libmergedlo.so(soffice_main+0x91)[0x7fc06c28db41]
> /usr/lib/libreoffice/program/soffice.bin(+0x107b)[0x555ea9ad007b]
> /lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xeb)[0x7fc06a1d609b]
> /usr/lib/libreoffice/program/soffice.bin(+0x10ba)[0x555ea9ad00ba]

I think I saw this more or less exact backgtrace once when someone using siduction reported
it to me via IRC.

The cause here was siductions live system using overlayfs (and apparmor)

It just works in "normal" systems - verified in clean VM of mine.

Don't use questionable configurations.

Regards,

Rene

Reply | Threaded
Open this post in threaded view
|

Bug#933835: libreoffice not start with fatal exception signal 11

Rene Engelhard
On Sun, Aug 04, 2019 at 11:11:13AM +0200, Rene Engelhard wrote:
> I think I saw this more or less exact backgtrace once when someone using siduction reported
> it to me via IRC.
>
> The cause here was siductions live system using overlayfs (and apparmor)

(Or on a not-updated Debian Live)

See
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=922378 and
https://salsa.debian.org/apparmor-team/apparmor/commit/675a4d80a9147c7278577d8043f885099db403a9

Regards,
 
Rene

Reply | Threaded
Open this post in threaded view
|

Bug#933835: libreoffice not start with fatal exception signal 11

Zdzislaw Kaleta
In reply to this post by Rene Engelhard
Sorry I must say that Your remarks are high above my computer
knowledge.
I assure that my Debian is normal installation without any live or
virtual tricks. Open Office and later Libre Office always work on it
without problems. Now it stop which is crucial form me.

I can check that apparmor is instilled. After sudo apparmor_status I
get:

apparmor module is loaded.
68 profiles are loaded.
49 profiles are in enforce mode.
   /snap/core/5145/usr/lib/snapd/snap-confine
   /snap/core/5145/usr/lib/snapd/snap-confine//mount-namespace-capture-
helper
   /snap/core/7270/usr/lib/snapd/snap-confine
   /snap/core/7270/usr/lib/snapd/snap-confine//mount-namespace-capture-
helper
   /usr/bin/evince
   /usr/bin/evince-previewer
   /usr/bin/evince-previewer//sanitized_helper
   /usr/bin/evince-thumbnailer
   /usr/bin/evince//sanitized_helper
   /usr/bin/freshclam
   /usr/bin/man
   /usr/bin/pidgin
   /usr/bin/pidgin//sanitized_helper
   /usr/bin/surf
   /usr/bin/totem
   /usr/bin/totem-audio-preview
   /usr/bin/totem-video-thumbnailer
   /usr/bin/totem//sanitized_helper
   /usr/lib/cups/backend/cups-pdf
   /usr/lib/snapd/snap-confine
   /usr/lib/snapd/snap-confine//mount-namespace-capture-helper
   /usr/lib/telepathy/mission-control-5
   /usr/lib/telepathy/telepathy-*
   /usr/lib/telepathy/telepathy-*//pxgsettings
   /usr/lib/telepathy/telepathy-*//sanitized_helper
   /usr/lib/telepathy/telepathy-ofono
   /usr/lib/x86_64-linux-gnu/lightdm/lightdm-guest-session
   /usr/lib/x86_64-linux-gnu/lightdm/lightdm-guest-session//chromium
   /usr/sbin/apt-cacher-ng
   /usr/sbin/clamd
   /usr/sbin/cups-browsed
   /usr/sbin/cupsd
   /usr/sbin/cupsd//third_party
   /usr/sbin/haveged
   /usr/sbin/mysqld-akonadi
   /usr/sbin/mysqld-akonadi///usr/sbin/mysqld
   /usr/sbin/ntpd
   /usr/sbin/tcpdump
   libreoffice-senddoc
   libreoffice-soffice//gpg
   libreoffice-xpdfimport
   lsb_release
   man_filter
   man_groff
   nvidia_modprobe
   nvidia_modprobe//kmod
   snap-update-ns.anbox-installer
   snap-update-ns.core
   snap.core.hook.configure
19 profiles are in complain mode.
   /usr/bin/irssi
   /usr/sbin/dnsmasq
   /usr/sbin/dnsmasq//libvirt_leaseshelper
   avahi-daemon
   identd
   klogd
   libreoffice-oopslash
   libreoffice-soffice
   mdnsd
   nmbd
   nscd
   ping
   smbd
   smbldap-useradd
   smbldap-useradd///etc/init.d/nscd
   snap.anbox-installer.anbox-installer
   syslog-ng
   syslogd
   traceroute
9 processes have profiles defined.
7 processes are in enforce mode.
   /usr/bin/freshclam (27231)
   /usr/sbin/clamd (28685)
   /usr/sbin/cups-browsed (27651)
   /usr/sbin/cupsd (27650)
   /usr/lib/cups/notifier/dbus (27689) /usr/sbin/cupsd
   /usr/lib/cups/notifier/dbus (28335) /usr/sbin/cupsd
   /usr/sbin/haveged (1798)
2 processes are in complain mode.
   /usr/sbin/avahi-daemon (1872) avahi-daemon
   /usr/sbin/avahi-daemon (1917) avahi-daemon
0 processes are unconfined but have a profile defined.

This is new to me and I find two lines connected with LibreOffice but I
don't know what this means.

I assure You that using LibreOffice is crutial to me so I will be
thankfull for any sugestions.

[hidden email]

On Sun, 2019-08-04 at 11:11 +0200, Rene Engelhard wrote:

> tag 933835 + moreinfo
> tag 933835 + unreproducible
> tag 933835 - a11y
> severity 933835 important
> thanks
>
> Hi,
>
> On Sun, Aug 04, 2019 at 09:59:51AM +0200, sanskryt wrote:
> > Package: libreoffice
> > Version: 1:6.3.0~rc2-1
> > Severity: grave
> > Tags: a11y
> > Justification: renders package unusable
>
> No. It isn't a generic problem, and it isn't a11y per se.
>
> > After normal upgradin a system from apt libre office wont start any
> more.
> > Program not start and when put libreoffoce at console there is
> info:
> >
> > sanskryt@sauron:~$ libreoffice
> >
> >
> > Fatal exception: Signal 11
> > Stack:
> >
> /usr/lib/libreoffice/program/libuno_sal.so.3(+0x3bf83)[0x7fc06a40af83
> ]
> >
> /usr/lib/libreoffice/program/libuno_sal.so.3(+0x3c193)[0x7fc06a40b193
> ]
> > /lib/x86_64-linux-gnu/libc.so.6(+0x37840)[0x7fc06a1e9840]
> >
> /usr/lib/libreoffice/program/libuno_cppu.so.3(+0x14322)[0x7fc06740b32
> 2]
> >
> /usr/lib/libreoffice/program/libuno_cppu.so.3(uno_type_any_assign+0x9
> 7)[0x7fc06740a717]
> >
> /usr/lib/libreoffice/program/libmergedlo.so(+0x299f047)[0x7fc06cdcb04
> 7]
> >
> /usr/lib/libreoffice/program/libmergedlo.so(+0x299fe85)[0x7fc06cdcbe8
> 5]
> >
> /usr/lib/libreoffice/program/libmergedlo.so(_ZN3utl10ConfigItemC2ERKN
> 3rtl8OUStringE14ConfigItemMode+0x7b)[0x7fc06cdc104b]
> >
> /usr/lib/libreoffice/program/libmergedlo.so(+0x29f0725)[0x7fc06ce1c72
> 5]
> >
> /usr/lib/libreoffice/program/libmergedlo.so(_ZN19SvtSysLocaleOptionsC
> 1Ev+0x11f)[0x7fc06ce1dc1f]
> >
> /usr/lib/libreoffice/program/libmergedlo.so(_Z7InitVCLv+0x1a2)[0x7fc0
> 6d1ddab2]
> >
> /usr/lib/libreoffice/program/libmergedlo.so(_Z10ImplSVMainv+0x105)[0x
> 7fc06d1df395]
> >
> /usr/lib/libreoffice/program/libmergedlo.so(soffice_main+0x91)[0x7fc0
> 6c28db41]
> > /usr/lib/libreoffice/program/soffice.bin(+0x107b)[0x555ea9ad007b]
> > /lib/x86_64-linux-
> gnu/libc.so.6(__libc_start_main+0xeb)[0x7fc06a1d609b]
> > /usr/lib/libreoffice/program/soffice.bin(+0x10ba)[0x555ea9ad00ba]
>
> I think I saw this more or less exact backgtrace once when someone
> using siduction reported
> it to me via IRC.
>
> The cause here was siductions live system using overlayfs (and
> apparmor)
>
> It just works in "normal" systems - verified in clean VM of mine.
>
> Don't use questionable configurations.
>
> Regards,
>
> Rene

Reply | Threaded
Open this post in threaded view
|

Bug#933835: Info received (Bug#933835: libreoffice not start with fatal exception signal 11)

Zdzislaw Kaleta
In reply to this post by Zdzislaw Kaleta
OK the problem was solved by today's upgrade.
In it were upgraded cpid gir1.2-atk-1.0 gpicview libarmadillo9
libatk1.0-0 libatk1.0-0:i386 libatk1.0-data libatk1.0-dev libatk1.0-doc
liblockfile-bin liblockfile1 libreoffice-mysql-connector wget.

In effect libreoffice starts again in new version so the bug can be
closed in my humble oppinion.

sanskryt

On Sun, 2019-08-04 at 16:39 +0000, Debian Bug Tracking System wrote:

> Thank you for the additional information you have supplied regarding
> this Bug report.
>
> This is an automatically generated reply to let you know your message
> has been received.
>
> Your message is being forwarded to the package maintainers and other
> interested parties for their attention; they will reply in due
> course.
>
> Your message has been sent to the package maintainer(s):
>  Debian LibreOffice Maintainers <[hidden email]>
>
> If you wish to submit further information on this problem, please
> send it to [hidden email].
>
> Please do not send mail to [hidden email] unless you wish
> to report a problem with the Bug-tracking system.
>

Reply | Threaded
Open this post in threaded view
|

Bug#933835: Info received (Bug#933835: libreoffice not start with fatal exception signal 11)

Timur Irikovich Davletshin
In reply to this post by Zdzislaw Kaleta
I believe this bug should be reopened. Right version of atk library is
not in the dependencies of this build. Regular installation via apt-get
-t buster-backports install libreoffice leads to non working state.

Regards,

Timur.

P.S. Official builds work fine btw...

On Sun, 4 Aug 2019 21:41:26 +0200 Rene Engelhard <[hidden email]>
wrote:
> Hi,
>
> On Sun, Aug 04, 2019 at 07:44:35PM +0200, sanskryt wrote:
> > OK the problem was solved by today's upgrade.
> > In it were upgraded cpid gir1.2-atk-1.0 gpicview libarmadillo9
> > libatk1.0-0 libatk1.0-0:i386 libatk1.0-data libatk1.0-dev
libatk1.0-doc
> > liblockfile-bin liblockfile1 libreoffice-mysql-connector wget.
>                                ^^^^^^^^^^^^^^^^^^^^^^^^^^^
>       Besides the fact that this is a empty
>       dummy package this again shows your
>       system was not clean - as that package
>       got updated in the repos with exactly
the
>       same version you reported against.
>
> > In effect libreoffice starts again in new version so the bug can be
> > closed in my humble oppinion.
>
> In my humble opinion you should have not reported it in the first
place.
>
> But thanks, closing.
>
> Regards,
>
> Rene
>
>

Reply | Threaded
Open this post in threaded view
|

Bug#933835: Info received (Bug#933835: libreoffice not start with fatal exception signal 11)

Rene Engelhard
Hi,

On Fri, Aug 09, 2019 at 07:51:55AM +0300, Timur Irikovich Davletshin wrote:
> I believe this bug should be reopened.

Not sure.

> Right version of atk library is not in the dependencies of this build.

OK, but that would be a bug in atk that they are not giving us correct
dependency information.. I could force a newer dependency, but... The
code is the same as in "official builds" so it has to be something with
atk itself.

But see below.

> Regular installation via apt-get
> -t buster-backports install libreoffice leads to non working state.

Just did this on my buster.

LO starts after that.

atk from bster. Maybe the problem exhibits itself only if you enable some "special"
accessibility? (My only accessibility-related option I enabled is
"Big fonts" and "Visual warnings" in gnome-shells "panel".
 
> P.S. Official builds work fine btw...

Because they build with an old atk? (CentOS 7 TTBOMK)

Regards,

Rene

Reply | Threaded
Open this post in threaded view
|

Bug#933835: Info received (Bug#933835: libreoffice not start with fatal exception signal 11)

Timur Irikovich Davletshin
On Fri, 9 Aug 2019 10:30:50 +0200 Rene Engelhard <[hidden email]>
wrote:
> dependency information.. I could force a newer dependency, but...
>
>

If some version dependencies are wrong (it seems to be the case)...
they ought to be checked and fixed. But that means bug is to be
reopened.

Cheers,

Timur.

Reply | Threaded
Open this post in threaded view
|

Bug#933835: Info received (Bug#933835: libreoffice not start with fatal exception signal 11)

Rene Engelhard
reopen 933835
retitle 933835 too lax atk dependency? - libreoffice not start with fatal exception signal 11
thanks

Hi,

On Fri, Aug 09, 2019 at 06:49:42PM +0300, Timur Irikovich Davletshin wrote:
> On Fri, 9 Aug 2019 10:30:50 +0200 Rene Engelhard <[hidden email]>
> wrote:
> > dependency information.. I could force a newer dependency, but...
> >
> >
>
> If some version dependencies are wrong (it seems to be the case)...

That's what you say. But why does it start on my laptop with busters atk
then?
And buster-backports' build is - of course - built against busters atk.
So that can't be it.

> they ought to be checked and fixed. But that means bug is to be
> reopened.

If it was a atk thing when built against sids atk you might be right,
but I see no confirmation here yet.

*shrugs*, reopening this bug does not really help very much in this case,
it'll still be + moreinfo, + unreproducible, so people (you?) need to give
more information to this bug anyway.

But we can do that anyway...

But don't inflate the severity. I'll immediately downgrade it again.

Regards,

Rene

Reply | Threaded
Open this post in threaded view
|

Bug#933835: Info received (Bug#933835: libreoffice not start with fatal exception signal 11)

Timur Irikovich Davletshin
In reply to this post by Timur Irikovich Davletshin
IMHO, all deps should be checked.

On Fri, 09 Aug 2019 18:49:42 +0300 Timur Irikovich Davletshin <
[hidden email]> wrote:

> On Fri, 9 Aug 2019 10:30:50 +0200 Rene Engelhard <[hidden email]>
> wrote:
> > dependency information.. I could force a newer dependency, but...
> >
> >
>
> If some version dependencies are wrong (it seems to be the case)...
> they ought to be checked and fixed. But that means bug is to be
> reopened.
>
> Cheers,
>
> Timur.
>
>
>

Reply | Threaded
Open this post in threaded view
|

Bug#933835: Info received (Bug#933835: libreoffice not start with fatal exception signal 11)

Timur Irikovich Davletshin
In reply to this post by Rene Engelhard
This is why I was insisting on checking all dependencies. I have two
machines (laptop and desktop) with only darktable installed from 3rd
party repos on one of them and result is the same — LO doesn't start.

Timur.

On Fri, 9 Aug 2019 18:03:09 +0200 Rene Engelhard <[hidden email]>
wrote:
> reopen 933835
> retitle 933835 too lax atk dependency? - libreoffice not start with
fatal exception signal 11
> thanks
>
> Hi,
>
> On Fri, Aug 09, 2019 at 06:49:42PM +0300, Timur Irikovich Davletshin
wrote:
> > On Fri, 9 Aug 2019 10:30:50 +0200 Rene Engelhard <[hidden email]>
> > wrote:
> > > dependency information.. I could force a newer dependency, but...
> > >
> > >
> >
> > If some version dependencies are wrong (it seems to be the case)...
>
> That's what you say. But why does it start on my laptop with busters
atk
> then?
> And buster-backports' build is - of course - built against busters
atk.
> So that can't be it.
>

Reply | Threaded
Open this post in threaded view
|

Bug#933835: Info received (Bug#933835: libreoffice not start with fatal exception signal 11)

Rene Engelhard
In reply to this post by Rene Engelhard
On Fri, Aug 09, 2019 at 06:03:09PM +0200, Rene Engelhard wrote:

> > If some version dependencies are wrong (it seems to be the case)...
>
> That's what you say. But why does it start on my laptop with busters atk
> then?
> And buster-backports' build is - of course - built against busters atk.
> So that can't be it.
>
> > they ought to be checked and fixed. But that means bug is to be
> > reopened.
>
> If it was a atk thing when built against sids atk you might be right,
> but I see no confirmation here yet.

So, what I did just now:

- uptodate Debian testing VM. LO starts

https://tracker.debian.org/pkg/atk1.0 said the version before was
2.30.0-2 and said when it migrated.

- added that (http://snapshot.debian.org/package/atk1.0/2.30.0-2/ and
thus
http://snapshot.debian.org/archive/debian/20180908T223035Z/pool/main/a/atk1.0/
and
thus http://snapshot.debian.org/archive/debian/20180908T223035Z to
sources.list)

- downgraded libatk using

apt install libatk...=2.30.2 for atk packages installed.

Still starts.

So still unreproducible.

Regards,
 
Rene

Reply | Threaded
Open this post in threaded view
|

Bug#933835: Info received (Bug#933835: libreoffice not start with fatal exception signal 11)

Timur Irikovich Davletshin
My complain was not about LO 6.3 in Debian Testing but about LO 6.3
from Buster backports. Well except me we have original reporter of this
bug. Let's wait for him.

On Fri, 9 Aug 2019 18:30:12 +0200 Rene Engelhard <[hidden email]>
wrote:
> On Fri, Aug 09, 2019 at 06:03:09PM +0200, Rene Engelhard wrote:
> > > If some version dependencies are wrong (it seems to be the
case)...
> >
> > That's what you say. But why does it start on my laptop with
busters atk
> > then?
> > And buster-backports' build is - of course - built against busters
atk.
> > So that can't be it.
> >
> > > they ought to be checked and fixed. But that means bug is to be
> > > reopened.
> >
> > If it was a atk thing when built against sids atk you might be
right,

> > but I see no confirmation here yet.
>
> So, what I did just now:
>
> - uptodate Debian testing VM. LO starts
>
> https://tracker.debian.org/pkg/atk1.0 said the version before was
> 2.30.0-2 and said when it migrated.
>
> - added that (http://snapshot.debian.org/package/atk1.0/2.30.0-2/ and
> thus
>
http://snapshot.debian.org/archive/debian/20180908T223035Z/pool/main/a/atk1.0/

> and
> thus http://snapshot.debian.org/archive/debian/20180908T223035Z to
> sources.list)
>
> - downgraded libatk using
>
> apt install libatk...=2.30.2 for atk packages installed.
>
> Still starts.
>
> So still unreproducible.
>
> Regards,
>  
> Rene
>
>

Reply | Threaded
Open this post in threaded view
|

Bug#933835: Info received (Bug#933835: libreoffice not start with fatal exception signal 11)

Timur Irikovich Davletshin
I was wrong, problem is not in atk*. I rolled back snapshot of buster
to it's original state and tried to reproduce behaviour. Problem is in
libreoffice-mysql-connector which is not upgraded automatically. So
dependencies...

Timur.

On Fri, 09 Aug 2019 19:36:59 +0300 Timur Irikovich Davletshin <
[hidden email]> wrote:
> My complain was not about LO 6.3 in Debian Testing but about LO 6.3
> from Buster backports. Well except me we have original reporter of
this

> bug. Let's wait for him.
>
> On Fri, 9 Aug 2019 18:30:12 +0200 Rene Engelhard <[hidden email]>
> wrote:
> > On Fri, Aug 09, 2019 at 06:03:09PM +0200, Rene Engelhard wrote:
> > > > If some version dependencies are wrong (it seems to be the
> case)...
> > >
> > > That's what you say. But why does it start on my laptop with
> busters atk
> > > then?
> > > And buster-backports' build is - of course - built against
busters

> atk.
> > > So that can't be it.
> > >
> > > > they ought to be checked and fixed. But that means bug is to be
> > > > reopened.
> > >
> > > If it was a atk thing when built against sids atk you might be
> right,
> > > but I see no confirmation here yet.
> >
> > So, what I did just now:
> >
> > - uptodate Debian testing VM. LO starts
> >
> > https://tracker.debian.org/pkg/atk1.0 said the version before was
> > 2.30.0-2 and said when it migrated.
> >
> > - added that (http://snapshot.debian.org/package/atk1.0/2.30.0-2/
and
> > thus
> >
>
http://snapshot.debian.org/archive/debian/20180908T223035Z/pool/main/a/atk1.0/

> > and
> > thus http://snapshot.debian.org/archive/debian/20180908T223035Z to
> > sources.list)
> >
> > - downgraded libatk using
> >
> > apt install libatk...=2.30.2 for atk packages installed.
> >
> > Still starts.
> >
> > So still unreproducible.
> >
> > Regards,
> >  
> > Rene
> >
> >
>
>
>

Reply | Threaded
Open this post in threaded view
|

Bug#933835: Info received (Bug#933835: libreoffice not start with fatal exception signal 11)

Rene Engelhard
In reply to this post by Timur Irikovich Davletshin
close 933835
thanks

On Fri, Aug 09, 2019 at 07:36:59PM +0300, Timur Irikovich Davletshin wrote:
> My complain was not about LO 6.3 in Debian Testing but about LO 6.3

Aha.

> from Buster backports. Well except me we have original reporter of this
> bug. Let's wait for him.

Which is - as I said - built against busters atk (and on my system)
works with busters atk. (I cross-checked just now in the .buildinfo
file, just in the unlikely case I used the wrong chroot.)
What dependency would you suggest to something newer? As said, LO
doesn't use features of newer atks directly, ttbomk.

And note that buster-backports is not part of this BTS at all. The
version tracking doesn't know bpo versions.
So even if this was a problem there this place would be wrong and
[hidden email] would be the place to discuss it.
See backports.debian.org - Report Bugs:
https://backports.debian.org/Instructions/#index6h2:
"Report Bugs
Please report bugs that you found in the packages to the backports
mailing list and NOT to the Debian BTS!"

Closing again.

Regards,
 
Rene

Reply | Threaded
Open this post in threaded view
|

Bug#933835: Info received (Bug#933835: libreoffice not start with fatal exception signal 11)

Rene Engelhard
In reply to this post by Timur Irikovich Davletshin
reopen 933835
retitle 933835 libreoffice not start with fatal exception signal 11 with old libreoffice-mysql-connector installed
thanks

On Fri, Aug 09, 2019 at 07:54:21PM +0300, Timur Irikovich Davletshin wrote:
> I was wrong, problem is not in atk*. I rolled back snapshot of buster
> to it's original state and tried to reproduce behaviour. Problem is in
> libreoffice-mysql-connector which is not upgraded automatically. So

OK, that makes it testing/unstable, too.

> dependencies...

Or Conflicts. libreoffice-mysql-connector was an optional extension
until 6.2

So new LO needs to conflict against old libreoffice-mysql-connector when
it was still an extension it seems...

Regards,

Rene

Reply | Threaded
Open this post in threaded view
|

Bug#933835: Info received (Bug#933835: libreoffice not start with fatal exception signal 11)

Rene Engelhard
In reply to this post by Timur Irikovich Davletshin
reopen 933835
retitle 933835 libreoffice not start with fatal exception signal 11 when old libreoffice-mysql-connector is installed
severity 933835 serious
thanks

Hi,

On Fri, Aug 09, 2019 at 07:54:21PM +0300, Timur Irikovich Davletshin wrote:
> I was wrong, problem is not in atk*. I rolled back snapshot of buster
> to it's original state and tried to reproduce behaviour. Problem is in
> libreoffice-mysql-connector which is not upgraded automatically. So

OK, indeed. Reopening and adapting.

Will be fixed.

> dependencies...

No, Conflicts:, libreoffice-mysql-connector is now a dummy and it seems
that the old ibreoffice-mysql-connector plays bad with the new LO :/
And no, LibreOffice shouldn't depend on it :) (LO works without
libreoffice-sdbc-mysql installed, you just need it for a MySQL
connection.)

We can't change the old package, but we can make -core Conflicts:
against the old libreoffice-mysql-connector..

Regards,

Rene

Reply | Threaded
Open this post in threaded view
|

Bug#933835: Info received (Bug#933835: libreoffice not start with fatal exception signal 11)

Timur Irikovich Davletshin
In reply to this post by Rene Engelhard
I believe bug is to be reopened again to fix dependencies. Package
libreoffice-mysql-connector does exist for LO 6.3 and to be upgraded
automatically or it will cause problem upgrading from Buster to
Testing.

Timur.

On Fri, 9 Aug 2019 19:05:36 +0200 Rene Engelhard <[hidden email]>
wrote:
> close 933835
> thanks
>
> On Fri, Aug 09, 2019 at 07:36:59PM +0300, Timur Irikovich Davletshin
wrote:
> > My complain was not about LO 6.3 in Debian Testing but about LO 6.3
>
> Aha.
>
> > from Buster backports. Well except me we have original reporter of
this

> > bug. Let's wait for him.
>
> Which is - as I said - built against busters atk (and on my system)
> works with busters atk. (I cross-checked just now in the .buildinfo
> file, just in the unlikely case I used the wrong chroot.)
> What dependency would you suggest to something newer? As said, LO
> doesn't use features of newer atks directly, ttbomk.
>
> And note that buster-backports is not part of this BTS at all. The
> version tracking doesn't know bpo versions.
> So even if this was a problem there this place would be wrong and
> [hidden email] would be the place to discuss
it.

> See backports.debian.org - Report Bugs:
> https://backports.debian.org/Instructions/#index6h2:
> "Report Bugs
> Please report bugs that you found in the packages to the backports
> mailing list and NOT to the Debian BTS!"
>
> Closing again.
>
> Regards,
>  
> Rene
>
>

Reply | Threaded
Open this post in threaded view
|

Bug#933835: Info received (Bug#933835: libreoffice not start with fatal exception signal 11)

Rene Engelhard
On Fri, Aug 09, 2019 at 08:18:53PM +0300, Timur Irikovich Davletshin wrote:
> I believe bug is to be reopened again to fix dependencies. Package

Did so (and fixed it in git)

> libreoffice-mysql-connector does exist for LO 6.3 and to be upgraded
> automatically or it will cause problem upgrading from Buster to
> Testing.

Not really if you did a complete "apt upgrade" etc since apt will upgrade
libreoffice-mysql-connector, too and it will work.

But you are right, if you do partial upgrades (like with -t buster-backports
install libreoffice) it breaks.

That's why I added the Conflicts: now.

Regards,
   
Rene