Bug#934340: Please remove the dependency on obus and camlp4

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Bug#934340: Please remove the dependency on obus and camlp4

Stéphane Glondu-3
Source: zeroinstall-injector
Version: 2.12.3-2
Severity: serious

Dear Maintainer,

zeroinstall-injector build depends on obus, which is affected by
[1]. According to [2], it is an optional dependency. Please provide a
version of zeroinstall-injector without the dependency on obus.

It also seems that the latest upstream version of zeroinstall-injector
is buildable without camlp4. Please drop the dependency in the Debian
package as well.

[1] https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=933992
[2] https://opam.ocaml.org/packages/0install/


Cheers,

--
Stéphane

-- System Information:
Debian Release: bullseye/sid
  APT prefers testing
  APT policy: (990, 'testing'), (500, 'unstable'), (1, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 4.19.0-5-amd64 (SMP w/4 CPU cores)
Locale: LANG=fr_FR.UTF-8, LC_CTYPE=fr_FR.UTF-8 (charmap=UTF-8), LANGUAGE=fr_FR.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /usr/bin/dash
Init: systemd (via /run/systemd/system)
LSM: AppArmor: enabled