Bug#934340: Please remove the dependency on obus and camlp4

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Bug#934340: Please remove the dependency on obus and camlp4

Thomas Leonard-3
On Sat, 10 Aug 2019 at 01:54, Stéphane Glondu <[hidden email]> wrote:

>
> Source: zeroinstall-injector
> Version: 2.12.3-2
> Severity: serious
>
> Dear Maintainer,
>
> zeroinstall-injector build depends on obus, which is affected by
> [1]. According to [2], it is an optional dependency. Please provide a
> version of zeroinstall-injector without the dependency on obus.

obus is only optional on systems that don't use D-BUS. It is needed on Debian.

https://github.com/ocaml-community/obus/blob/master/CHANGES.md says:

1.2.0 (2019-07-04)
- remove all Camlp4 dependencies

So I think Debian can just update to that.

> It also seems that the latest upstream version of zeroinstall-injector
> is buildable without camlp4. Please drop the dependency in the Debian
> package as well.

I don't believe there is a dependency in the Debian package at the
moment (except indirectly via Debian's old version of obus).
According to https://github.com/0install/0install-debian/commit/dbea82da611eb9091cf36cbf8668dd40b8915057
the direct dependency was removed on Sun, 19 Nov 2017.

> [1] https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=933992
> [2] https://opam.ocaml.org/packages/0install/


--
talex5 (GitHub/Twitter)        http://roscidus.com/blog/
GPG: 5DD5 8D70 899C 454A 966D  6A51 7513 3C8F 94F6 E0CC

Reply | Threaded
Open this post in threaded view
|

Bug#933992: Bug#934340: Please remove the dependency on obus and camlp4

Stéphane Glondu-3
Le 10/08/2019 à 16:59, Thomas Leonard a écrit :
> obus is only optional on systems that don't use D-BUS. It is needed on Debian.
>
> https://github.com/ocaml-community/obus/blob/master/CHANGES.md says:
>
> 1.2.0 (2019-07-04)
> - remove all Camlp4 dependencies
>
> So I think Debian can just update to that.

Not at the moment. The new version depends on (at least) two NEW
packages (lwt_log and ppxlib), and the NEW queue backlog is pretty big now.

Moreover, lwt_log depends on lwt >= 4.0.0, but Debian has 2.7.1.
Updating lwt in Debian cannot be done IMHO without updating
ocaml-ctypes, which requires (at least) another NEW package (integers).

So I guess we'll have to remove obus and its reverse dependencies from
testing for a while.


Cheers,

--
Stéphane

Reply | Threaded
Open this post in threaded view
|

Bug#934340: Please remove the dependency on obus and camlp4

Thomas Leonard-3
In reply to this post by Thomas Leonard-3
Why have you (I assume) removed 0install and obus from the repository?
A camlp4 release for 4.08 came out on Aug 7th:

https://github.com/ocaml/camlp4/releases/tag/4.08%2B1

And even if not, surely waiting for the NEW queue to clear so that
obus can be upgraded is better than removing working packages?


--
talex5 (GitHub/Twitter)        http://roscidus.com/blog/
GPG: 5DD5 8D70 899C 454A 966D  6A51 7513 3C8F 94F6 E0CC