Bug#934883: wyrd FTBFS with OCaml 4.08.0 (safe strings)

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Bug#934883: wyrd FTBFS with OCaml 4.08.0 (safe strings)

Stéphane Glondu-3
Package: wyrd
Version: 1.4.6-4
Severity: important

Dear Maintainer,

Your package wyrd FTBFS with OCaml 4.08.0 because -safe-string is now
the default.

https://ocaml.debian.net/transitions/ocaml-4.08.0/pool/wyrd.log

Please provide a version of wyrd that works with -safe-string. Note:
this can be done before OCaml is updated because the current version in
unstable (4.05.0) already supports -safe-string.

Cheers,

--
Stéphane

-- System Information:
Debian Release: bullseye/sid
  APT prefers testing
  APT policy: (990, 'testing'), (500, 'unstable'), (1, 'experimental')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 4.19.0-5-amd64 (SMP w/4 CPU cores)
Locale: LANG=fr_FR.UTF-8, LC_CTYPE=fr_FR.UTF-8 (charmap=UTF-8), LANGUAGE=fr_FR.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /usr/bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages wyrd depends on:
ii  less          487-0.1+b1
ii  libc6         2.28-10
ii  libncursesw6  6.1+20190713-2
ii  libtinfo6     6.1+20190713-2
pn  remind        <none>

wyrd recommends no packages.

wyrd suggests no packages.