Bug#934896: ITP: janest-ocaml-compiler-libs -- OCaml compiler libraries repackaged

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Bug#934896: ITP: janest-ocaml-compiler-libs -- OCaml compiler libraries repackaged

Stéphane Glondu-3
Package: wnpp
Severity: wishlist
Owner: Stéphane Glondu <[hidden email]>

* Package name    : janest-ocaml-compiler-libs
  Version         : 0.12.0
  Upstream Author : Jane Street Group, LLC
* URL             : https://github.com/janestreet/ocaml-compiler-libs
* License         : Apache-2.0
  Programming Lang: OCaml
  Description     : OCaml compiler libraries repackaged

This package simply repackages the OCaml compiler libraries so they
don’t expose everything at toplevel. For instance Ast_helper is now
Ocaml_common.Ast_helper.

The special library ocaml_shadow adds a deprecation warning on all
modules from the compiler libraries, to force the user to use the
prefixed names.

This is a dependency of ppxlib.

It will be maintained inside ocaml-team.