Bug#935173: audacity graphical windows fail to update properly

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Bug#935173: audacity graphical windows fail to update properly

Anthony DeRobertis
Package: audacity
Version: 2.3.2-2
Followup-For: Bug #935173

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Same problem here with Audacity, and same workaround (unset
GTK_IM_MODULE) appears to fix it here. I'm not using any "special" input
method, I just use xim so gtk doesn't ignore custom XCompose rules.

- -- System Information:
Debian Release: bullseye/sid
  APT prefers testing-debug
  APT policy: (500, 'testing-debug'), (500, 'stable-updates'), (500, 'testing'), (500, 'stable'), (130, 'unstable-debug'), (130, 'unstable'), (120, 'experimental-debug'), (120, 'experimental')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 4.19.0-5-amd64 (SMP w/8 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8), LANGUAGE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash
Init: systemd (via /run/systemd/system)
LSM: AppArmor: enabled

Versions of packages audacity depends on:
ii  audacity-data         2.3.2-2
ii  libasound2            1.1.8-2
ii  libavcodec58          10:4.2.1-dmo6
ii  libavformat58         10:4.2.1-dmo6
ii  libavutil56           10:4.2.1-dmo6
ii  libc6                 2.29-2
ii  libexpat1             2.2.9-1
ii  libflac++6v5          1.3.3-1
ii  libflac8              1.3.3-1
ii  libgcc1               1:9.2.1-8
ii  libgdk-pixbuf2.0-0    2.40.0+dfsg-1
ii  libglib2.0-0          2.62.1-1
ii  libgtk-3-0            3.24.12-1
ii  libid3tag0            0.15.1b-14
ii  liblilv-0-0           0.24.4~dfsg0-1
ii  libmad0               0.15.1b-10
ii  libmp3lame0           1:3.100-dmo1
ii  libogg0               1.3.2-1+b1
ii  libportaudio2         19.6.0-1
ii  libportsmf0           0.1~svn20101010-5
ii  libsndfile1           1.0.28-6
ii  libsoundtouch1        2.1.2+ds1-1
ii  libsoxr0              0.1.3-1
ii  libstdc++6            9.2.1-8
ii  libsuil-0-0           1:0.10.4-dmo3
ii  libtwolame0           1:0.4.0-dmo1
ii  libvamp-hostsdk3v5    1:2.8.0-dmo1
ii  libvorbis0a           1.3.6-2
ii  libvorbisenc2         1.3.6-2
ii  libvorbisfile3        1.3.6-2
ii  libwxbase3.0-0v5      3.0.4+dfsg-14
ii  libwxgtk3.0-gtk3-0v5  3.0.4+dfsg-14

audacity recommends no packages.

Versions of packages audacity suggests:
ii  amb-plugins [ladspa-plugin]  0.8.1-7+b1
ii  blepvco [ladspa-plugin]      0.1.0-3+b3
ii  bs2b-ladspa [ladspa-plugin]  0.9.1-3+b1
ii  caps [ladspa-plugin]         0.9.26-1
ii  cmt [ladspa-plugin]          1.16-2+b1
ii  ladspa-sdk [ladspa-plugin]   1.15-2
ii  mcp-plugins [ladspa-plugin]  0.4.0-6
ii  omins [ladspa-plugin]        0.2.0-8
ii  rev-plugins [ladspa-plugin]  0.7.1-3+b1
ii  swh-plugins [ladspa-plugin]  0.4.17-2
ii  tap-plugins [ladspa-plugin]  1.0.0-1
ii  vco-plugins [ladspa-plugin]  0.3.0-5+b1

- -- no debconf information

-----BEGIN PGP SIGNATURE-----

iHMEARECADMWIQTlAc7j4DAtSNRJJ0z7P4jCVepZ/gUCXcKVLRUcYW50aG9ueUBk
ZXJvYmVydC5uZXQACgkQ+z+IwlXqWf5mpQCggKwR7MEm8fAEu0JwFN5g4+lmjzQA
nRGa99xXOvlVmjcgq7VQgWZmCgXN
=JgNt
-----END PGP SIGNATURE-----

Reply | Threaded
Open this post in threaded view
|

Bug#935173: audacity graphical windows fail to update properly

Daniel Kahn Gillmor
Control: retitle 935173 audacity graphical windows fail to update properly when GTK_IM_MODULE=xim
Control: forwarded 935173 https://developer.gnome.org/gtk3/stable/gtk-running.html

On Wed 2019-11-06 04:41:06 -0500, Anthony DeRobertis wrote:
> Same problem here with Audacity, and same workaround (unset
> GTK_IM_MODULE) appears to fix it here. I'm not using any "special" input
> method, I just use xim so gtk doesn't ignore custom XCompose rules.

Wow, i'm just getting back to reading up on this thread, and i can
confirm that unsetting GTK_IM_MODULE also fixes the problem for me.

Yuri, thanks for uncovering that!  I've forwarded the bug report to
upstream as noted above.

Regards,

        --dkg

signature.asc (233 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Bug#935173: audacity graphical windows fail to update properly

Anthony DeRobertis
On 3/13/20 1:16 AM, Daniel Kahn Gillmor wrote:
> Control: retitle 935173 audacity graphical windows fail to update properly when GTK_IM_MODULE=xim
> Control: forwarded 935173 https://developer.gnome.org/gtk3/stable/gtk-running.html

Err, are you sure that's the right URL? I tried to find the forwarded
bug at both https://bugzilla.audacityteam.org/ and
https://gitlab.gnome.org/GNOME/gtk/issues/ but I couldn't find it on
either. So alas I can't just fix the URL myself.

Reply | Threaded
Open this post in threaded view
|

Bug#935173: audacity graphical windows fail to update properly

Daniel Kahn Gillmor
Control: forwarded 935173 https://github.com/audacity/audacity/issues/454

On Sun 2020-03-15 00:23:52 -0400, Anthony DeRobertis wrote:
> On 3/13/20 1:16 AM, Daniel Kahn Gillmor wrote:
>> Control: retitle 935173 audacity graphical windows fail to update properly when GTK_IM_MODULE=xim
>> Control: forwarded 935173 https://developer.gnome.org/gtk3/stable/gtk-running.html
>
> Err, are you sure that's the right URL? I tried to find the forwarded
> bug at both https://bugzilla.audacityteam.org/ and
> https://gitlab.gnome.org/GNOME/gtk/issues/ but I couldn't find it on
> either. So alas I can't just fix the URL myself.

Whoops, sorry, i pasted the wrong URL.  Thanks for catching that
Anthony!

        --dkg

signature.asc (233 bytes) Download Attachment