Bug#936798: Please port KisSplice to Python3 (Was: Bug#936798: kissplice: Python2 removal in sid/bullseye)

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Bug#936798: Please port KisSplice to Python3 (Was: Bug#936798: kissplice: Python2 removal in sid/bullseye)

Andreas Tille-5
Control: forwarded -1 David Parsons <[hidden email]>, [hidden email]
Control: tags -1 upstream

Hi,

as you might probably know Python2 is End Of Live[1] and Debian is
actively working on removing Python2 code from the distribution.  So
Debian 11 will come without Python2.  This means we will either be
able to port all software packages to Python3 or the package will be
removed.

Do you think it is feasible for you to port KisSplice to Python3?  May be
by using 2to3 which does quite some work automatically?  If you need any
help please do not hesitate to ask.

Kind regards

      Andreas.


[1] https://pythonclock.org/

--
http://fam-tille.de

Reply | Threaded
Open this post in threaded view
|

Bug#936798: Please port KisSplice to Python3 (Was: Bug#936798: kissplice: Python2 removal in sid/bullseye)

Vincent Lacroix
Dear Andreas,
Yes, we have a python 3 version of KisSplice working now. This should correspond to version 2.5.0 of KisSplice, which we plan to release in the coming months.
When would be the deadline for updating our debian KisSplice package before removal ?
Best,
Vincent
________________________________________
De : Andreas Tille <[hidden email]>
Envoyé : mardi 8 octobre 2019 17:23
À : [hidden email]; David Parsons; LACROIX VINCENT
Objet : Please port KisSplice to Python3 (Was: Bug#936798: kissplice: Python2 removal in sid/bullseye)

Control: forwarded -1 David Parsons <[hidden email]>, [hidden email]
Control: tags -1 upstream

Hi,

as you might probably know Python2 is End Of Live[1] and Debian is
actively working on removing Python2 code from the distribution.  So
Debian 11 will come without Python2.  This means we will either be
able to port all software packages to Python3 or the package will be
removed.

Do you think it is feasible for you to port KisSplice to Python3?  May be
by using 2to3 which does quite some work automatically?  If you need any
help please do not hesitate to ask.

Kind regards

      Andreas.


[1] https://pythonclock.org/

--
http://fam-tille.de

Reply | Threaded
Open this post in threaded view
|

Bug#936798: Please port KisSplice to Python3 (Was: Bug#936798: kissplice: Python2 removal in sid/bullseye)

Andreas Tille-6
Dear Vincent,

thanks a lot for your quick and helpful reply.

On Wed, Oct 09, 2019 at 03:59:08AM +0000, LACROIX VINCENT wrote:
> Dear Andreas,
> Yes, we have a python 3 version of KisSplice working now. This should correspond to version 2.5.0 of KisSplice, which we plan to release in the coming months.

This sounds good!

> When would be the deadline for updating our debian KisSplice package before removal ?

There is no actual date.  Debian 11 will be released in 2021 so the
current bug is not yet release critical.  You will be on the safe side
if you get out KisSplice at the end of this year not only from a
Debian point of view but also in general for other users who do not
might want to run unsupported software like Python2.

Kind regards

      Andreas.

--
http://fam-tille.de