Bug#948117: extrepo: fails to start on fresh installation

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Bug#948117: extrepo: fails to start on fresh installation

Raju Devidas
Package: extrepo
Version: 0.6
Severity: important

Dear Maintainer,

 I did a  fresh installation of extrepo on Debian Unstable machine.
 When I tried starting it for the first time, it gave be the output as given in the paste here https://paste.debian.net/1124442/

-- System Information:
Debian Release: bullseye/sid
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: amd64 (x86_64)

Kernel: Linux 5.4.0-1-amd64 (SMP w/4 CPU cores)
Locale: LANG=en_IN.utf8, LC_CTYPE=en_IN.utf8 (charmap=UTF-8), LANGUAGE=en_IN.utf8 (charmap=UTF-8)
Shell: /bin/sh linked to /usr/bin/dash
Init: systemd (via /run/systemd/system)
LSM: AppArmor: enabled

Versions of packages extrepo depends on:
ii  gpgv                  2.2.17-3
ii  libcryptx-perl        0.066-1
ii  libdpkg-perl          1.19.7
ii  libwww-perl           6.43-1
ii  libyaml-libyaml-perl  0.80+repack-2+b1
ii  perl                  5.30.0-9

extrepo recommends no packages.

extrepo suggests no packages.

-- no debconf information

Reply | Threaded
Open this post in threaded view
|

Bug#948117: extrepo: fails to start on fresh installation

Wouter Verhelst
Control: forcemerge 947067 -1
thanks

Hi Raju,

On Sat, Jan 04, 2020 at 01:48:06PM +0530, Raju Devidas wrote:
> Package: extrepo
> Version: 0.6
> Severity: important
>
> Dear Maintainer,
>
>  I did a  fresh installation of extrepo on Debian Unstable machine.
>  When I tried starting it for the first time, it gave be the output as
>  given in the paste here https://paste.debian.net/1124442/

For future reference: please don't pastebin information that you link to
from a bug report; pastebins don't usually store the information for a
very long time, making the bug report unusable when the data is removed
after a week or so. Instead, just copy-and-paste the output into the
email that you send to the bts initially.

In this particular case, your pastebin contains:

$ extrepo --help
syntax error at (eval 16) line 1, near "Debian::ExtRepo::Commands::--"
        ...propagated at /usr/bin/extrepo line 102.
$ aptitude search extrepo
i   extrepo                                                                                         - External repository manager                                                                              
$ extrepo
Use of uninitialized value $cmdlower in ucfirst at /usr/bin/extrepo line 98.
Undefined subroutine &Debian::ExtRepo::Commands::::run called at (eval 16) line 1.
        ...propagated at /usr/bin/extrepo line 102.

...which was also mentioned in #947067 as well.

Note that it doesn't actually fail to start; it starts just fine.
However, the --help argument is not supported, is attempted to be
interpreted as a command, and that fails, which produces that error
message.

That's indeed not very helpful, but it works just fine.

Until this bug is fixed, for help on how to use it, please read the output of
"man extrepo".

Regards,

--
To the thief who stole my anti-depressants: I hope you're happy

  -- seen somewhere on the Internet on a photo of a billboard