Bug#948206: mitmproxy incompatible with python3-wsproto=0.15.0-2

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Bug#948206: mitmproxy incompatible with python3-wsproto=0.15.0-2

Andrej Shadura-3
On Sun, 05 Jan 2020 11:27:14 +0100 Adrian Vollmer
<[hidden email]> wrote:

> Package: mitmproxy
> Version: 4.0.4-6
> Severity: grave
> Tags: newcomer
> Justification: renders package unusable
>
> After upgrading python3-wsproto to version 0.15.0-2, mitmproxy fails
> immediately with this error message:
>
>     ImportError: cannot import name 'WSConnection' from 'wsproto.connection'
>     (/usr/lib/python3/dist-packages/wsproto/connection.py)
>
> As stated in the setup.py of mitmproxy, it requires the Python
> module wsproto to be at least 0.14.0 and < 0.15.0 [1]:
>
>     "wsproto>=0.14.0,<0.15.0",
>
> Downgrading the package with `apt install python3-wsproto=0.11.0-3` solves
> this issue temporarily (this version is shown below).
>
> [1] https://github.com/mitmproxy/mitmproxy/blob/7b638f1b6b543ec5e23170217a42ca0e5c421992/setup.py#L85
Uploading an NMU to DELAYED/0, including the upstream fix and two
clean-up commits from the Janitor.

--
Cheers,
   Andrej

mitmproxy_4.0.4-6.1.debdiff (16K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Bug#948206: mitmproxy incompatible with python3-wsproto=0.15.0-2

Andrej Shadura-3
On 08/04/2020 16:58, Andrej Shadura wrote:
> Uploading an NMU to DELAYED/0, including the upstream fix and two
> clean-up commits from the Janitor.

Sorry, I intended to upload it to DELAYED/1 but was hit by an off-by-one
error.

--
Cheers,
   Andrej