Bug#950354: dose-builddebcheck: Filter out Architecture: all sources with --deb-drop-b-d-indep

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Bug#950354: dose-builddebcheck: Filter out Architecture: all sources with --deb-drop-b-d-indep

Daniel Schepler-6
Package: dose-builddebcheck
Version: 5.0.1-14
Severity: wishlist

Brief background: I'm currently working on a "local buildd" script,
which I envisioned as being useful for something like the KDE team
using it to test prerelease builds of a set of interdependent
packages.  Previously I had it ignoring Build-Depends and trying to
build everything that came in, assuming that users would order their
uploads appropriately.  But it does seem that in the KDE example, for
instance each new release of Frameworks will all come out at the same
time, and it could be useful to have a script that initially just
upgrades all source packages (and regenerates each debian/control's
Build-Depends to the new version for internal interdependencies) and
dumps them into the micro-buildd to see what breaks.

So, I was considering using dose-builddebcheck to replicate that part
of buildd's functionality.  I was hoping I could also, as a side
effect, implement architecture filtering by dose-builddebcheck's
filtering.  So far, when I do the full run on
debian_main_source_Sources with --deb-native-arch=amd64, I do see for
example that iprutils (Architecture: powerpc ppc64 ppc64el) gets
filtered out.

The problem happens when I want to split out the binary-arch and
binary-indep builds.  If I run with --deb-native-arch=amd64
--deb-drop-b-d-indep, for example, I'm still seeing zzzeeksphinx in
the output even though zzzeeksphinx is purely Architecture: all.
Similarly, if I run with --deb-native-arch=amd64 --deb-drop-b-d-arch,
I still see zziplib in the output even though zziplib is purely
Architecture: any and has no arch=all packages.
--
Daniel Schepler