Bug#954311: libgl1-mesa-dri: Makes KDE konsole unusable

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Bug#954311: libgl1-mesa-dri: Makes KDE konsole unusable

Timo Aaltonen-4
On 20.3.2020 10.18, Stefan Fritsch wrote:

> Package: libgl1-mesa-dri
> Version: 20.0.2-1
> Followup-For: Bug #954311
>
>
> With this mesa version, there are severe drawing artifacts with the kde
> konsole terminal emulator that makes it unusable. I also see problems
> when marking text in thunderbird.
>
> Downgrading the following packages to 19.3.3-1 fixes the problem:
>
>  libegl-mesa0
>  libglapi-mesa
>  libgbm1
>  libgl1-mesa-dri
>  libosmesa6
>  libgbm-dev
>  libglx-mesa0
>
> Cheers,
> Stefan

Please file it upstream, this is caused by the new 'iris' driver. In the
meantime, you can force the previous driver with this in a ~/.drirc:

<driconf>
  <device driver="loader" kernel_driver="i915">
    <option name="dri_driver" value="i965" />
  </device>
</driconf>


Or run the app with the driver to verify it actually helps:

    dri_driver=i965 ./app




--
t

Reply | Threaded
Open this post in threaded view
|

Bug#954311: libgl1-mesa-dri: Makes KDE konsole unusable

Stefan Fritsch
Hi Timo,

Am 20.03.20 um 09:55 schrieb Timo Aaltonen:

> Please file it upstream, this is caused by the new 'iris' driver. In the
> meantime, you can force the previous driver with this in a ~/.drirc:
>
> <driconf>
>   <device driver="loader" kernel_driver="i915">
>     <option name="dri_driver" value="i965" />
>   </device>
> </driconf>
>
>
> Or run the app with the driver to verify it actually helps:
>
>     dri_driver=i965 ./app

That did not help. It seems Xorg itself also loads the iris driver and
that causes the drawing errors. But putting the config into /etc/drirc
did help.

Cheers,
Stefan