Bug#954381: python3-kubernetes: New upstream version available

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Bug#954381: python3-kubernetes: New upstream version available

David Weinehall
Package: python3-kubernetes
Version: 7.0.0~a1-2
Severity: wishlist

The Debian package of python3-kubernetes is 7.0.0, while the latest upstream
release is 11.0.

Since newer versions of Kubernetes migrate APIs from beta to the main API it's
important to keep the bindings up to date, to avoid using deprecated APIs.
Notably Kubernetes 1.18 which is due to be released soon will no longer support
the old Ingress Api, and the Lease API has been promoted to v1.



-- System Information:
Debian Release: bullseye/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (1, 'experimental')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 5.4.0-4-amd64 (SMP w/8 CPU cores)
Locale: LANG=en_GB.UTF-8, LC_CTYPE=en_GB.UTF-8 (charmap=UTF-8), LANGUAGE=en_GB:en (charmap=UTF-8)
Shell: /bin/sh linked to /usr/bin/dash
Init: systemd (via /run/systemd/system)
LSM: AppArmor: enabled

Versions of packages python3-kubernetes depends on:
ii  python3                    3.8.2-1
ii  python3-certifi            2019.11.28-1
ii  python3-dateutil           2.7.3-3
ii  python3-google-auth        1.5.1-2
ii  python3-pkg-resources      44.0.0-1
ii  python3-requests           2.22.0-2
ii  python3-requests-oauthlib  1.0.0-1.1
ii  python3-setuptools         44.0.0-1
ii  python3-six                1.14.0-2
ii  python3-urllib3            1.25.8-1
ii  python3-websocket          0.53.0-2
ii  python3-yaml               5.3.1-1

python3-kubernetes recommends no packages.

python3-kubernetes suggests no packages.

-- no debconf information