Bug#956633: libpango-1.0-0: After upgrading from 1.42.4-8 to 1.44.7-3: Wrong font rendering in geany

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Bug#956633: libpango-1.0-0: After upgrading from 1.42.4-8 to 1.44.7-3: Wrong font rendering in geany

Lukas Straub
Package: libpango-1.0-0
Version: 1.44.7-3
Severity: normal

Dear Maintainer,

After upgrading libpangocairo-1.0-0 and libpango-1.0-0 from 1.44.7-3 to
1.42.4-8, fonts are rendered wrong in geany. It seems the cahracters are
too low, so for example underscores are invisible. I'll send some
screenshots by mail.


-- System Information:
Debian Release: bullseye/sid
  APT prefers testing
  APT policy: (990, 'testing')
Architecture: amd64 (x86_64)

Kernel: Linux 5.5.0-1-amd64 (SMP w/4 CPU cores)
Locale: LANG=en_US.utf8, LC_CTYPE=en_US.utf8 (charmap=UTF-8), LANGUAGE=en_US:en (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)
LSM: AppArmor: enabled

Versions of packages libpango-1.0-0 depends on:
ii  fontconfig     2.13.1-2+b1
ii  libc6          2.30-4
ii  libfribidi0    1.0.8-2
ii  libglib2.0-0   2.64.1-1
ii  libharfbuzz0b  2.6.4-1
ii  libthai0       0.1.28-3

libpango-1.0-0 recommends no packages.

libpango-1.0-0 suggests no packages.

-- no debconf information

Reply | Threaded
Open this post in threaded view
|

Bug#956633: Screenshots

Lukas Straub
Here are the screenshots, the first is with 1.44.7-3 and the second with 1.42.4-8

Screenshot_2020-04-13_21-06-05.png (243K) Download Attachment
Screenshot_2020-04-13_21-25-12.png (261K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Bug#956633: libpango-1.0-0: After upgrading from 1.42.4-8 to 1.44.7-3: Wrong font rendering in geany

Jeremy Bicha
In reply to this post by Lukas Straub
On Mon, Apr 13, 2020, 3:27 PM Lukas Straub <[hidden email]> wrote:
Package: libpango-1.0-0
Version: 1.44.7-3
Severity: normal

Dear Maintainer,

After upgrading libpangocairo-1.0-0 and libpango-1.0-0 from 1.44.7-3 to
1.42.4-8, fonts are rendered wrong in geany. It seems the cahracters are
too low, so for example underscores are invisible. I'll send some
screenshots by mail.

The second screenshot is wrong. Those function names are supposed to have underscores.

Thanks,
Jeremy Bicha
Reply | Threaded
Open this post in threaded view
|

Bug#956633: libpango-1.0-0: After upgrading from 1.42.4-8 to 1.44.7-3: Wrong font rendering in geany

Paul Wise via nm
In reply to this post by Lukas Straub
On Mon, 13 Apr 2020 21:24:25 +0200 Lukas Straub wrote:

> After upgrading libpangocairo-1.0-0 and libpango-1.0-0 from 1.44.7-3 to
> 1.42.4-8, fonts are rendered wrong in geany. It seems the cahracters are
> too low, so for example underscores are invisible. I'll send some
> screenshots by mail.

I have a similar issue in hexchat and I get the invisible underscores.
I noticed that not all fonts are affected, in particular DejaVu Sans
Mono and Bitstream Vera Sans Mono are affected but Liberation Mono is
not affected. I noticed that it doesn't affect the pango-view tool.

--
bye,
pabs

https://wiki.debian.org/PaulWise

signature.asc (849 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Bug#956633: libpango-1.0-0: After upgrading from 1.42.4-8 to 1.44.7-3: Wrong font rendering in geany

Paul Wise via nm
Control: retitle -1 libpango-1.0-0: 1.44.7-3 regression: wrong font rendering in geany/hexchat: invisible underscores

On Tue, 14 Apr 2020 08:20:29 +0800 Paul Wise: wrote:

> I have a similar issue in hexchat and I get the invisible underscores.
> I noticed that not all fonts are affected, in particular DejaVu Sans
> Mono and Bitstream Vera Sans Mono are affected but Liberation Mono is
> not affected. I noticed that it doesn't affect the pango-view tool.

I also noticed that this is size dependent, 10pt works, 11pt doesn't.

--
bye,
pabs

https://wiki.debian.org/PaulWise

signature.asc (849 bytes) Download Attachment