Bug#960976: libguava-java: Generates unsatisfiable dependencies on libguava-java (>= 29.0-jre)

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Bug#960976: libguava-java: Generates unsatisfiable dependencies on libguava-java (>= 29.0-jre)

Daniel Schepler-6
Package: libguava-java
Version: 29.0-2
Severity: important

For example, if I build guice_4.2.1-1 (using sbuild) then the
resulting libguice-java package gets dependencies of:

libguice-java_4.2.1-1_all.deb
-----------------------------

 new Debian package, version 2.0.
 size 963020 bytes: control archive=1896 bytes.
    1100 bytes,    23 lines      control
    3818 bytes,    35 lines      md5sums
 Package: libguice-java
 Source: guice
 Version: 4.2.1-1
 Architecture: all
 Maintainer: Debian Java Maintainers
<[hidden email]>
 Installed-Size: 1184
 Depends: libaopalliance-java, libatinject-jsr330-api-java,
libguava-java (>= 29.0-jre), libjsr305-java
 Suggests: libasm-java (>= 7.2), libcglib-java (>= 3.2.12)
 Built-Using: asm (= 7.2-1), cglib (= 3.2.12-1)
 Section: java
 Priority: optional
 Homepage: https://github.com/google/guice
 Description: lightweight dependency injection framework for Java 5 and above
  Guice provides support for dependency injection using annotations to
  configure Java objects. Dependency injection is a design pattern whose
  core principle is to separate behavior from dependency resolution.
  .
  Guice allows implementation classes to be programmatically bound to
  an interface, then injected into constructors, methods or fields
  using an @Inject annotation. When more than one implementation of
  the same interface is needed, the user can create custom annotations
  that identify an implementation, then use that annotation when
  injecting it.

Which then obviously makes the resulting package uninstallable:

daniel@frobnitz:~/rebuild$ apt-get -s install ./libguice-java_4.2.1-1_all.deb
NOTE: This is only a simulation!
      apt-get needs root privileges for real execution.
      Keep also in mind that locking is deactivated,
      so don't depend on the relevance to the real current situation!
Reading package lists... Done
Building dependency tree
Reading state information... Done
Note, selecting 'libguice-java' instead of './libguice-java_4.2.1-1_all.deb'
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libguice-java : Depends: libguava-java (>= 29.0-jre) but 29.0-2 is to
be installed
E: Unable to correct problems, you have held broken packages.
--
Daniel Schepler