Buster - poweroff schaltet Rechner nicht aus

classic Classic list List threaded Threaded
16 messages Options
Reply | Threaded
Open this post in threaded view
|

Buster - poweroff schaltet Rechner nicht aus

Steffen Weichert
Moin,

ich habe hier einen etwas älteren Rechner, der sich mit 'poweroff' nicht
mehr ausschaltet, sondern nur noch herunterfährt. Früher™ hat das noch
funktioniert, wobei ich nicht sicher bin ob nur bis Jessie oder auch
noch mit Stretch.

Hier mal die Eckdaten von dem Rechner

EPIA-CN10000EG Mini-ITX Board

CPU     - VIA C7 V4 Bus NanoBGA2 Processor
Chipset - VIA CN700 North Bridge
          VIA VT8237R-series South Bridge

cat /proc/cpuinfo
processor       : 0
vendor_id       : CentaurHauls
cpu family      : 6
model           : 10
model name      : VIA Esther processor 1000MHz
stepping        : 9
cpu MHz         : 800.000
cache size      : 128 KB
physical id     : 0
siblings        : 1
core id         : 0
cpu cores       : 1
apicid          : 0
initial apicid  : 0
fdiv_bug        : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 1
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 sep mtrr pge cmov pat clflush acpi mmx fxsr sse sse2 tm nx cpuid pni est tm2 rng rng_en ace ace_en ace2 ace2_en phe phe_en pmm pmm_en pti
bugs            : cpu_meltdown spectre_v1 spectre_v2 spec_store_bypass l1tf mds swapgs
bogomips        : 1595.99
clflush size    : 64
cache_alignment : 64
address sizes   : 36 bits physical, 32 bits virtual
power management:

uname -a
Linux via 4.19.0-5-686-pae #1 SMP Debian 4.19.37-5+deb10u2 (2019-08-08) i686 GNU/Linux

cat /proc/cmdline
BOOT_IMAGE=/boot/vmlinuz-4.19.0-5-686-pae root=UUID=d05398f0-2a3f-4d74-891b-0687d3be7b99 ro console=tty0 console=ttyS0,19200 quiet

Ein Test mit Knoppix 8.2 schaltet den Rechner auch nicht aus.

*ABER*
Wenn ich mit debian-10.0.0-i386-netinst.iso im 'Rescue mode' starte,
dann "Eine Shell in der Installer-Umgebung ausführen" wähle und dort
'poweroff' eingebe, schaltet sich der Rechner aus.

Für ein paar Ideen oder Vorschläge, wie sich der Rechner im normalen
Betrieb bei 'poweroff' wieder ausschaltet wäre ich dankbar.

Steffen

signature.asc (201 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Buster - poweroff schaltet Rechner nicht aus

Hans-Georg Bork
Moin,

das könnte was mit ACPI zu tun haben.

On 8/28/19 6:53 PM, Steffen Weichert wrote:

> cat /proc/cmdline
> BOOT_IMAGE=/boot/vmlinuz-4.19.0-5-686-pae root=UUID=d05398f0-2a3f-4d74-891b-0687d3be7b99 ro console=tty0 console=ttyS0,19200 quiet
>
> Ein Test mit Knoppix 8.2 schaltet den Rechner auch nicht aus.
>
> *ABER*
> Wenn ich mit debian-10.0.0-i386-netinst.iso im 'Rescue mode' starte,
> dann "Eine Shell in der Installer-Umgebung ausführen" wähle und dort
> 'poweroff' eingebe, schaltet sich der Rechner aus.
>
> Für ein paar Ideen oder Vorschläge, wie sich der Rechner im normalen
> Betrieb bei 'poweroff' wieder ausschaltet wäre ich dankbar.

check doch mal /proc/cmdline beim boot von der netinst, ob da irgendwas
andreas gesetzt wird

Gruß
        -- hgb

Reply | Threaded
Open this post in threaded view
|

Re: Buster - poweroff schaltet Rechner nicht aus

Elimar Riesebieter
In reply to this post by Steffen Weichert
* Steffen Weichert <[hidden email]> [2019-08-28 18:53 +0200]:

> Moin,
>
> ich habe hier einen etwas älteren Rechner, der sich mit 'poweroff' nicht
> mehr ausschaltet, sondern nur noch herunterfährt. Früher™ hat das noch
> funktioniert, wobei ich nicht sicher bin ob nur bis Jessie oder auch
> noch mit Stretch.

Schonmal

# systemctl poweroff

probiert?

Elimar
--
  Numeric stability is probably not all that
  important when you're guessing;-)

Reply | Threaded
Open this post in threaded view
|

Re: Buster - poweroff schaltet Rechner nicht aus

Marc F. Neininger
In reply to this post by Steffen Weichert
Hi,

poweroff hab ich noch nicht probiert. Bei mir hat aber /sbin/halt schon
unter stretch den Rechner nicht ausgeschaltet, sondern nur das
Betriebssystem runtergefahren.

Mit " $> /sbin/shutdown -h now" als root geht mein Rechner sauber aus.

Gruß

Marc

Am 28.08.2019 um 18:53 schrieb Steffen Weichert:

> Moin,
>
> ich habe hier einen etwas älteren Rechner, der sich mit 'poweroff' nicht
> mehr ausschaltet, sondern nur noch herunterfährt. Früher™ hat das noch
> funktioniert, wobei ich nicht sicher bin ob nur bis Jessie oder auch
> noch mit Stretch.
>
> Hier mal die Eckdaten von dem Rechner
>
> EPIA-CN10000EG Mini-ITX Board
>
> CPU     - VIA C7 V4 Bus NanoBGA2 Processor
> Chipset - VIA CN700 North Bridge
>            VIA VT8237R-series South Bridge
>
> cat /proc/cpuinfo
> processor       : 0
> vendor_id       : CentaurHauls
> cpu family      : 6
> model           : 10
> model name      : VIA Esther processor 1000MHz
> stepping        : 9
> cpu MHz         : 800.000
> cache size      : 128 KB
> physical id     : 0
> siblings        : 1
> core id         : 0
> cpu cores       : 1
> apicid          : 0
> initial apicid  : 0
> fdiv_bug        : no
> f00f_bug        : no
> coma_bug        : no
> fpu             : yes
> fpu_exception   : yes
> cpuid level     : 1
> wp              : yes
> flags           : fpu vme de pse tsc msr pae mce cx8 sep mtrr pge cmov pat clflush acpi mmx fxsr sse sse2 tm nx cpuid pni est tm2 rng rng_en ace ace_en ace2 ace2_en phe phe_en pmm pmm_en pti
> bugs            : cpu_meltdown spectre_v1 spectre_v2 spec_store_bypass l1tf mds swapgs
> bogomips        : 1595.99
> clflush size    : 64
> cache_alignment : 64
> address sizes   : 36 bits physical, 32 bits virtual
> power management:
>
> uname -a
> Linux via 4.19.0-5-686-pae #1 SMP Debian 4.19.37-5+deb10u2 (2019-08-08) i686 GNU/Linux
>
> cat /proc/cmdline
> BOOT_IMAGE=/boot/vmlinuz-4.19.0-5-686-pae root=UUID=d05398f0-2a3f-4d74-891b-0687d3be7b99 ro console=tty0 console=ttyS0,19200 quiet
>
> Ein Test mit Knoppix 8.2 schaltet den Rechner auch nicht aus.
>
> *ABER*
> Wenn ich mit debian-10.0.0-i386-netinst.iso im 'Rescue mode' starte,
> dann "Eine Shell in der Installer-Umgebung ausführen" wähle und dort
> 'poweroff' eingebe, schaltet sich der Rechner aus.
>
> Für ein paar Ideen oder Vorschläge, wie sich der Rechner im normalen
> Betrieb bei 'poweroff' wieder ausschaltet wäre ich dankbar.
>
> Steffen

--
==
Marc F. Neininger
Staufenstrasse 19
78224 Singen

Reply | Threaded
Open this post in threaded view
|

Re: Buster - poweroff schaltet Rechner nicht aus

Ulf Volmer
On Thu, Aug 29, 2019 at 10:56:14AM +0200, Marc F. Neininger wrote:

> poweroff hab ich noch nicht probiert. Bei mir hat aber /sbin/halt schon
> unter stretch den Rechner nicht ausgeschaltet, sondern nur das
> Betriebssystem runtergefahren.

Ein halt erfordert seit einiger Zeit die Option -p um den Rechner wirklich
herunterzubringen.
Das vom OP verwendete poweroff sollte aber eigentlich auch so funktionieren.

Viele Grüße
Ulf

Reply | Threaded
Open this post in threaded view
|

Re: Buster - poweroff schaltet Rechner nicht aus

Steffen Weichert
In reply to this post by Hans-Georg Bork
Am Mi, den 28. Aug 2019 um 22:02 +0200 schrieb Hans-Georg Bork:

> check doch mal /proc/cmdline beim boot von der netinst, ob da irgendwas
> andreas gesetzt wird

also beim boot von netinst habe ich

uname -a
Linux via 4.19.0-5-686 #1 SMP Debian 4.19.37-5 (2019-06-19) i686 GNU/Linux

cat /proc/cmdline
BOOT_IMAGE=/install.386/vmlinuz vga=788 initrd=/install.386/initrd.gz rescue/enable=true --- quiet

Ein install und boot von 'linux-image-4.19.0-5-686' brachte keine
Änderung.


signature.asc (201 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Buster - poweroff schaltet Rechner nicht aus

Steffen Weichert
In reply to this post by Elimar Riesebieter
Am Do, den 29. Aug 2019 um 10:36 +0200 schrieb Elimar Riesebieter:

> Schonmal
>
> # systemctl poweroff
>
> probiert?

Gerade ebend. Es bleibt dabei - der Rechner fährt herunter aber schaltet
sich nicht aus.

signature.asc (201 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Buster - poweroff schaltet Rechner nicht aus

Steffen Weichert
In reply to this post by Steffen Weichert
Am Mi, den 28. Aug 2019 um 18:53 +0200 schrieb Steffen Weichert:

> ich habe hier einen etwas älteren Rechner, der sich mit 'poweroff' nicht
> mehr ausschaltet, sondern nur noch herunterfährt. Früher™ hat das noch
> funktioniert, wobei ich nicht sicher bin ob nur bis Jessie oder auch
> noch mit Stretch.

Ich habe nochmal getestet. Mit Jessie funktioniert poweroff wie erwartet
und schaltet den Rechner aus.

uname -a
Linux jessie 3.16.0-10-686-pae #1 SMP Debian 3.16.72-1 (2019-08-13) i686 GNU/Linux

cat /proc/cmdline
BOOT_IMAGE=/boot/vmlinuz-3.16.0-10-686-pae root=UUID=7321f72c-3175-4df3-82c3-eedeb7976045 ro quiet

Ab Stretch und Kernel 4.x funktioniert das ausschalten nicht mehr. Aus
meiner (Anwender)Sicht macht also Kernel 4.x etwas anders als 3.x oder
in der Kernelconfiguration wurde etwas geändert. Es verwirrt mich aber,
das von einem Installer-Medium gebootet ich den Rechner trotz 4.x Kernel
mit poweroff auschalten kann.

Die nächsten Versuche mit acpi boot-optionen

acpi=force      schaltet nicht aus
acpi=noirq      fährt nicht hoch, Bootvorgang bricht ab
acpi=off        schaltet nicht aus

Hat jemand andere Vorschläge oder Ideen?

Steffen

signature.asc (201 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Buster - poweroff schaltet Rechner nicht aus

Stefan-9
Am Freitag, den 30.08.2019 um 20:29:34 +0200 schrieb [hidden email]:

> Am Mi, den 28. Aug 2019 um 18:53 +0200 schrieb Steffen Weichert:
>
> > ich habe hier einen etwas älteren Rechner, der sich mit 'poweroff' nicht
> > mehr ausschaltet, sondern nur noch herunterfährt. Früher™ hat das noch
> > funktioniert, wobei ich nicht sicher bin ob nur bis Jessie oder auch
> > noch mit Stretch.
>
> Ich habe nochmal getestet. Mit Jessie funktioniert poweroff wie erwartet
> und schaltet den Rechner aus.
>
> uname -a
> Linux jessie 3.16.0-10-686-pae #1 SMP Debian 3.16.72-1 (2019-08-13) i686 GNU/Linux
>
> cat /proc/cmdline
> BOOT_IMAGE=/boot/vmlinuz-3.16.0-10-686-pae root=UUID=7321f72c-3175-4df3-82c3-eedeb7976045 ro quiet
>
> Ab Stretch und Kernel 4.x funktioniert das ausschalten nicht mehr. Aus
> meiner (Anwender)Sicht macht also Kernel 4.x etwas anders als 3.x oder
> in der Kernelconfiguration wurde etwas geändert. Es verwirrt mich aber,
> das von einem Installer-Medium gebootet ich den Rechner trotz 4.x Kernel
> mit poweroff auschalten kann.
>
> Die nächsten Versuche mit acpi boot-optionen
>
> acpi=force      schaltet nicht aus
> acpi=noirq      fährt nicht hoch, Bootvorgang bricht ab
> acpi=off        schaltet nicht aus
>
> Hat jemand andere Vorschläge oder Ideen?
Ich habe im Internet Artikel gefunden, in denen ein Problem mit APIC
beschrieben wurde.

https://www.kernel.org/doc/html/latest/x86/x86_64/boot-options.html?highlight=apic#apics

Wenn ich es richtig verstehe, dann kann es sein, dass APIC nicht
richtig funktioniert sondern nur PIC:

https://www.kernel.org/doc/html/latest/x86/i386/IO-APIC.html?highlight=apic

Aber damit kenne ich mich auch nicht aus,... nur eine Idee.

--
Mit freundlichen Grüßen,
Stefan
Virtuelle Linux User Group
http://www.devlug.de
OpenPGP: A602 F768 93F1 38B4 A8EF  DDD5 C2DC 916F 3575 1C24
Instant Messaging mit XMPP


signature.asc (849 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Buster - poweroff schaltet Rechner nicht aus

Khatrun

shutdown -h now

müsste immer gehen

Am 30.08.19 um 21:25 schrieb Stefan:
Am Freitag, den 30.08.2019 um 20:29:34 +0200 schrieb [hidden email]:
Am Mi, den 28. Aug 2019 um 18:53 +0200 schrieb Steffen Weichert:

ich habe hier einen etwas älteren Rechner, der sich mit 'poweroff' nicht
mehr ausschaltet, sondern nur noch herunterfährt. Früher™ hat das noch
funktioniert, wobei ich nicht sicher bin ob nur bis Jessie oder auch
noch mit Stretch.
Ich habe nochmal getestet. Mit Jessie funktioniert poweroff wie erwartet
und schaltet den Rechner aus.

uname -a
Linux jessie 3.16.0-10-686-pae #1 SMP Debian 3.16.72-1 (2019-08-13) i686 GNU/Linux

cat /proc/cmdline
BOOT_IMAGE=/boot/vmlinuz-3.16.0-10-686-pae root=UUID=7321f72c-3175-4df3-82c3-eedeb7976045 ro quiet

Ab Stretch und Kernel 4.x funktioniert das ausschalten nicht mehr. Aus
meiner (Anwender)Sicht macht also Kernel 4.x etwas anders als 3.x oder
in der Kernelconfiguration wurde etwas geändert. Es verwirrt mich aber,
das von einem Installer-Medium gebootet ich den Rechner trotz 4.x Kernel
mit poweroff auschalten kann.

Die nächsten Versuche mit acpi boot-optionen

acpi=force      schaltet nicht aus
acpi=noirq      fährt nicht hoch, Bootvorgang bricht ab
acpi=off        schaltet nicht aus

Hat jemand andere Vorschläge oder Ideen?
Ich habe im Internet Artikel gefunden, in denen ein Problem mit APIC
beschrieben wurde.

https://www.kernel.org/doc/html/latest/x86/x86_64/boot-options.html?highlight=apic#apics

Wenn ich es richtig verstehe, dann kann es sein, dass APIC nicht
richtig funktioniert sondern nur PIC:

https://www.kernel.org/doc/html/latest/x86/i386/IO-APIC.html?highlight=apic

Aber damit kenne ich mich auch nicht aus,... nur eine Idee.

Reply | Threaded
Open this post in threaded view
|

Re: Buster - poweroff schaltet Rechner nicht aus

Steffen Weichert
In reply to this post by Stefan-9
Am Fr, den 30. Aug 2019 um 21:25 +0200 schrieb Stefan:

> Ich habe im Internet Artikel gefunden, in denen ein Problem mit APIC
> beschrieben wurde.
>
> https://www.kernel.org/doc/html/latest/x86/x86_64/boot-options.html?highlight=apic#apics

Auf den ersten Blick geht es da um amd64, der Rechner hier kann aber nur
32 Bit.

> Wenn ich es richtig verstehe, dann kann es sein, dass APIC nicht
> richtig funktioniert sondern nur PIC:
>
> https://www.kernel.org/doc/html/latest/x86/i386/IO-APIC.html?highlight=apic
>
> Aber damit kenne ich mich auch nicht aus,... nur eine Idee.

Ich schaue es mir mal an, vielleicht hilft es ja.

Steffen

signature.asc (201 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Buster - poweroff schaltet Rechner nicht aus

Steffen Weichert
Am Sa, den 31. Aug 2019 um 09:39 +0200 schrieb Steffen Weichert:

> > Wenn ich es richtig verstehe, dann kann es sein, dass APIC nicht
> > richtig funktioniert sondern nur PIC:
> >
> > https://www.kernel.org/doc/html/latest/x86/i386/IO-APIC.html?highlight=apic
> >
> > Aber damit kenne ich mich auch nicht aus,... nur eine Idee.
>
> Ich schaue es mir mal an, vielleicht hilft es ja.

So, angeschaut und wenig verstanden. Also vergleiche ich einfach mal
jessie, wo poweroff den Rechner ausschaltet, mit buster.

*jessie*
root@jessie:~# cat /proc/interrupts
           CPU0
  0:       4223    XT-PIC-XT-PIC    timer
  1:          2    XT-PIC-XT-PIC    i8042
  2:          0    XT-PIC-XT-PIC    cascade
  4:        117    XT-PIC-XT-PIC    serial
  7:          3    XT-PIC-XT-PIC    parport0
  8:          0    XT-PIC-XT-PIC    rtc0
  9:          0    XT-PIC-XT-PIC    acpi
 10:          2    XT-PIC-XT-PIC    ehci_hcd:usb1, snd_via82xx
 11:         97    XT-PIC-XT-PIC    uhci_hcd:usb2, uhci_hcd:usb3, uhci_hcd:usb4, uhci_hcd:usb5, eth0
 14:       1956    XT-PIC-XT-PIC    pata_via
 15:          0    XT-PIC-XT-PIC    pata_via
 16:          0   PCI-MSI-edge      radeon
 17:          0   PCI-MSI-edge      snd_hda_intel
NMI:          0   Non-maskable interrupts
LOC:          0   Local timer interrupts
SPU:          0   Spurious interrupts
PMI:          0   Performance monitoring interrupts
IWI:          0   IRQ work interrupts
RTR:          0   APIC ICR read retries
RES:          0   Rescheduling interrupts
CAL:          0   Function call interrupts
TLB:          0   TLB shootdowns
TRM:          0   Thermal event interrupts
THR:          0   Threshold APIC interrupts
MCE:          0   Machine check exceptions
MCP:          0   Machine check polls
HYP:          0   Hypervisor callback interrupts
ERR:          1
MIS:          0

*buster*
root@via:~# cat /proc/interrupts
           CPU0
  0:       9331    XT-PIC      timer
  1:          2    XT-PIC      i8042
  2:          0    XT-PIC      cascade
  4:        124    XT-PIC      ttyS0
  7:          1    XT-PIC      parport0
  8:          0    XT-PIC      rtc0
  9:          0    XT-PIC      acpi
 10:         32    XT-PIC      ehci_hcd:usb1, snd_hda_intel:card0, snd_via82xx
 11:         85    XT-PIC      uhci_hcd:usb2, uhci_hcd:usb3, uhci_hcd:usb4, uhci_hcd:usb5, radeon, enp0s18
 14:       1958    XT-PIC      pata_via
 15:          0    XT-PIC      pata_via
NMI:          0   Non-maskable interrupts
LOC:          0   Local timer interrupts
SPU:          0   Spurious interrupts
PMI:          0   Performance monitoring interrupts
IWI:          0   IRQ work interrupts
RTR:          0   APIC ICR read retries
RES:          0   Rescheduling interrupts
CAL:          0   Function call interrupts
TLB:          0   TLB shootdowns
TRM:          0   Thermal event interrupts
THR:          0   Threshold APIC interrupts
DFR:          0   Deferred Error APIC interrupts
MCE:          0   Machine check exceptions
MCP:          0   Machine check polls
HYP:          0   Hypervisor callback interrupts
HRE:          0   Hyper-V reenlightenment interrupts
HVS:          0   Hyper-V stimer0 interrupts
ERR:          1
MIS:          0
PIN:          0   Posted-interrupt notification event
NPI:          0   Nested posted-interrupt event
PIW:          0   Posted-interrupt wakeup event

Das sieht für mich (fast) gleich aus.

Steffen

signature.asc (201 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Buster - poweroff schaltet Rechner nicht aus

Steffen Weichert
In reply to this post by Steffen Weichert
Hallo,

inzwischen habe ich weiter herumprobiert, aber bin nicht schlauer
sondern nur verwirrter als vorher. Zuerst habe ich verschiedenen
acpi-Kerneloptionen getestet mit folgenden Ergebnis:

acpi=force      schaltet nicht aus
acpi=noirq      fährt nicht hoch, Bootvorgang bricht ab
acpi=off        schaltet nicht aus
acpi=strict     schaltet nicht aus
acpi=ht         schaltet nicht aus
acpi_osi=linux  schaltet nicht aus

Weiter geht es mit 'apic':

noapic          schaltet nicht aus
nolapic         Rachner schaltet sich nach 'poweroff' aus

Toll, Lösung gefunden? Leider nein. Nachdem sich der Rechner also
ausgeschaltet hat, das ganze wiederholt. Diesmal schaltet Rechner nicht
ab!?! Noch zwei drei mal probiert - doch jedesmal fährt der Rechner nur
herunter und schaltet nicht ab.

Zwischendurch habe ich auch mal Windows XP und Jessie gestartet, wo das
selbsständige abschalten funktioniert. Dann auf einmal unter Buster und
der Kerneloption 'nolapic' hat sich der Rechner nach 'poweroff'
ausgeschaltet. Es hat *einmal* funktioniert und danach nicht mehr.

Bisher kann ich einen erfolgreichen Versuch nicht wiederholen.
Mitlerweile habe ich die Kerneloption 'quiet' entfernt und habe jetzt
deutlich mehr Informationen - nur leider nichts was mich weiterbringt.

Bei Bedarf kann ich ja so einen Mitschnitt der Kernel- und
Boot-Meldungen hier posten (das sind rund 750 Zeilen) aber eines kann
ich schon jetzt verraten. Wenn der Rechner nur herunterfährt ist die
letzte Meldung

[ ] ACPI: Preparing to enter system sleep state S5

und wenn er sich wie gewünscht ausschaltet kommt danach noch

[ ] reboot: Power down

Auch wenn bisher hier noch niemand mir eine Lösung nennen konnte, so
könnt ihr mir vielleicht bei der Suche weiterhelfen:

Wo finde ich die Kernelconfig der offiziellen Debian-Kernel?
Wo finde ich die Kernelconfig vom Installer-Kernel?
Gibt es grundlegende Änderungen im ACPI-System von Kernel 4.x im
Vergleich zu Kernel 3.x ?

Ich hoffe jemand bringt mich auf die richtige Spur.

Steffen

signature.asc (201 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Buster - poweroff schaltet Rechner nicht aus

Steffen Weichert
Am So, den 01. Sep 2019 um 16:44 +0200 schrieb Steffen Weichert:
 
> Wo finde ich die Kernelconfig der offiziellen Debian-Kernel?

Die habe ich gefunden, sie ist im Verzeichniss /boot

> Wo finde ich die Kernelconfig vom Installer-Kernel?

Die habe ich noch nicht gefunden. Ich glaube nicht, das das ein
Geheimniss ist - nur wo muß ich suchen?

Steffen

signature.asc (201 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Buster - poweroff schaltet Rechner nicht aus

Uwe Kleine-König-7
On 9/2/19 6:58 PM, Steffen Weichert wrote:

> Am So, den 01. Sep 2019 um 16:44 +0200 schrieb Steffen Weichert:
>  
>> Wo finde ich die Kernelconfig der offiziellen Debian-Kernel?
>
> Die habe ich gefunden, sie ist im Verzeichniss /boot
>
>> Wo finde ich die Kernelconfig vom Installer-Kernel?
>
> Die habe ich noch nicht gefunden. Ich glaube nicht, das das ein
> Geheimniss ist - nur wo muß ich suchen?
Der Installer-Kernel verwendet die gleiche Konfiguration, es wird glaube
ich nicht mal neu kompiliert. Das Ergebnis ist nur etwas anders paketiert.

Liebe Grüße
Uwe


signature.asc (499 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Buster - poweroff schaltet Rechner nicht aus

Steffen Weichert
Am Di, den 03. Sep 2019 um 22:26 +0200 schrieb Uwe Kleine-König:

> >> Wo finde ich die Kernelconfig vom Installer-Kernel?
> >
> > Die habe ich noch nicht gefunden. Ich glaube nicht, das das ein
> > Geheimniss ist - nur wo muß ich suchen?
>
> Der Installer-Kernel verwendet die gleiche Konfiguration, es wird glaube
> ich nicht mal neu kompiliert. Das Ergebnis ist nur etwas anders paketiert.

Ob der Installer-Kernel und der "normale" Kernel die gleiche
Konfiguration verwenden weiß ich nicht, aber die Kernel sind
unterschiedlich groß

Installer-Kernel        vmlinuz                 4140688 Byte
"normaler" Kernel       vmlinuz-4.19.0-5-686    4140336 Byte

Die Kernel-Konfiguration habe ich inzwischen aber nicht mehr vorrangig
im Verdacht. Der Rechner verhält sich einfach merkwürdig, so das ich
nicht mehr wirklich glaube ein Lösung zu finden. Hier mal
zusammengefasst, was ich bisher ausprobiert/herausgefunden habe:

Windows XP                                      Rechner schaltet immer ab
Jessie mit 3.16.0-10-686-pae                    Rechner schaltet immer ab
Buster mit 4.19.0-5-686-pae                     Rechner schaltet fast immer nicht ab
Buster mit Installer-Kernel                     Rechner schaltet fast immer nicht ab
Installer-Kernel mit Installer-initrd (Buster)  Rechner schaltet immer ab

Also vereinzelt schaltet sich der Rechner auch mit Buster und Kernel
4.19.0-5-686-pae ab - aber nicht wiederholbar und ich habe keine Ahnung
warum es manchmal klappt.

Richtig nutzen tue ich den Rechner nicht, weil viel zu langsam, so das
ich entweder bei Jessie bleibe oder mal Mint probiere. Ein Test mit
linuxmint-19.2-xfce-32bit.iso im live-Modus hat den Rechner
ausgeschaltet.

Steffen

signature.asc (201 bytes) Download Attachment