CI for mrbayes

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

CI for mrbayes

Nadiya Sitdykova
Hello Andreas, 

I finished and pushed test-suite for mrbayes package, but autopkgtest in chroot fails with errors:

E: Failed to fetch http://cdn-fastly.deb.debian.org/debian/pool/main/g/gcc-6/libgfortran3_6.3.0-21_amd64.deb  404  Not Found [IP: 151.101.52.204 80]
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?
autopkgtest [23:34:59]: ERROR: testbed failure: apt repeatedly failed to download packages

I looked in this address and libgfortran with such name is really missing. Also I tried apt-get update and upgrade and it didn't help. Any ideas?

Regards, Nadiya
Reply | Threaded
Open this post in threaded view
|

Re: CI for mrbayes

Andreas Tille-5
Hi Nadiya,

On Wed, Jul 19, 2017 at 08:42:43PM -0700, Nadiya Sitdykova wrote:

> I finished and pushed test-suite for mrbayes package, but autopkgtest in
> chroot fails with errors:
>
> E: Failed to fetch
> http://cdn-fastly.deb.debian.org/debian/pool/main/g/gcc-6/libgfortran3_6.3.0-21_amd64.deb
>  404  Not Found [IP: 151.101.52.204 80]
> E: Unable to fetch some archives, maybe run apt-get update or try with
> --fix-missing?
> autopkgtest [23:34:59]: ERROR: testbed failure: apt repeatedly failed to
> download packages

apt-get works on your local machine but not in the pbuilder chroot.
Assuming you are using cowbuilder please try:

    sudo cowbuilder --update

The package builds for me.
 
> I looked in this address and libgfortran with such name is really missing.
> Also I tried apt-get update and upgrade and it didn't help. Any ideas?

I'll check the test and will upload if its OK.

Kind regards

       Andreas.

--
http://fam-tille.de

Reply | Threaded
Open this post in threaded view
|

Re: CI for mrbayes

Andreas Tille-5
Hi again Nadiya,

I hope you were able to solve the build issue.

On Thu, Jul 20, 2017 at 09:58:27AM +0200, Andreas Tille wrote:
>
> I'll check the test and will upload if its OK.

The test ist OK for the non-MPI version.  I wonder whether you could add
a test for mr-mpi.

Kind regards

      Andreas.

--
http://fam-tille.de

Reply | Threaded
Open this post in threaded view
|

Re: CI for mrbayes

Nadiya Sitdykova
Hello Andreas, 

Thanks, it solved build issue. I added tests for mb-mpi and at first I encountered this error:

--------------------------------------------------------------------------
The value of the MCA parameter "plm_rsh_agent" was set to a path
that could not be found:

  plm_rsh_agent: ssh : rsh

Please either unset the parameter, or check that the path is correct
--------------------------------------------------------------------------

I googled this message and figured that this message suggests that ssh client is not installed. 
So I added ssh to Depends in debian/control for mb-mpi and then it worked.

Regards, Nadiya

On Thu, Jul 20, 2017 at 2:46 AM, Andreas Tille <[hidden email]> wrote:
Hi again Nadiya,

I hope you were able to solve the build issue.

On Thu, Jul 20, 2017 at 09:58:27AM +0200, Andreas Tille wrote:
>
> I'll check the test and will upload if its OK.

The test ist OK for the non-MPI version.  I wonder whether you could add
a test for mr-mpi.

Kind regards

      Andreas.

--
http://fam-tille.de


Reply | Threaded
Open this post in threaded view
|

Re: CI for mrbayes

Andreas Tille-5
Hello Nadiya,

On Thu, Jul 20, 2017 at 04:04:51PM -0700, Nadiya Sitdykova wrote:
> I googled this message and figured that this message suggests that ssh
> client is not installed.
> So I added ssh to Depends in debian/control for mb-mpi and then it worked.

This dependency sounds a bit unexpected but is another sign that our
CI effort makes perfectly sense to enhance the package quality.

Just uploaded - thanks for your work on this

      Andreas.

--
http://fam-tille.de