CMS Joomla auf Buster

classic Classic list List threaded Threaded
16 messages Options
Reply | Threaded
Open this post in threaded view
|

CMS Joomla auf Buster

Lademann, Klaus-2
Hallo,

nach dem ich erfolgreich mir das aktuelle Joomla besorgt habe,
MySQL/MariaDB installiert, php-mysql installiert habe,

beschwert sich die Installationsroutine von Joomla, das es sich nicht
mit dem Server verbinden kann.

Hat jemand vielleicht ähnliche Probleme oder weiß wo ich erstmals
nachschauen sollte?

Gruß Klaus

Reply | Threaded
Open this post in threaded view
|

Re: CMS Joomla auf Buster

Boris-27
Hallo Klaus,

schildere doch erstmal, was Du vor hast.

Dann separiere die Aufgaben.
Läuft Dein WebServer? Welcher?
Läuft Dein PHP? Was sagt phpinfo()?

Dann sehen wir weiter....
Wie lautet die Fehlermeldung?

Boris

Am 16.02.20 um 08:19 schrieb Lademann, Klaus:

> Hallo,
>
> nach dem ich erfolgreich mir das aktuelle Joomla besorgt habe,
> MySQL/MariaDB installiert, php-mysql installiert habe,
>
> beschwert sich die Installationsroutine von Joomla, das es sich nicht
> mit dem Server verbinden kann.
>
> Hat jemand vielleicht ähnliche Probleme oder weiß wo ich erstmals
> nachschauen sollte?
>
> Gruß Klaus
>

Reply | Threaded
Open this post in threaded view
|

Re: CMS Joomla auf Buster

Lademann, Klaus-2
Am 16.02.20 um 09:26 schrieb Boris:
> Hallo Klaus,
>
> schildere doch erstmal, was Du vor hast.
>
> Dann separiere die Aufgaben.
> Läuft Dein WebServer? Welcher?
> Läuft Dein PHP? Was sagt phpinfo()?
Das läuft alles. Apache2 und php7.3.

Wie komme ich denn ran, um zu schauen ob der Datenbankserver überhaupt
funktiniert?

>
> Dann sehen wir weiter....
> Wie lautet die Fehlermeldung?
>
> Boris
>
> Am 16.02.20 um 08:19 schrieb Lademann, Klaus:
>> Hallo,
>>
>> nach dem ich erfolgreich mir das aktuelle Joomla besorgt habe,
>> MySQL/MariaDB installiert, php-mysql installiert habe,
>>
>> beschwert sich die Installationsroutine von Joomla, das es sich nicht
>> mit dem Server verbinden kann.
>>
>> Hat jemand vielleicht ähnliche Probleme oder weiß wo ich erstmals
>> nachschauen sollte?
>>
>> Gruß Klaus
>>
>

Reply | Threaded
Open this post in threaded view
|

Re: CMS Joomla auf Buster

Marc Haber-14
In reply to this post by Lademann, Klaus-2
On Sun, 16 Feb 2020 08:19:21 +0100, "Lademann, Klaus"
<[hidden email]> wrote:
>nach dem ich erfolgreich mir das aktuelle Joomla besorgt habe,
>MySQL/MariaDB installiert, php-mysql installiert habe,
>
>beschwert sich die Installationsroutine von Joomla, das es sich nicht
>mit dem Server verbinden kann.

Mit welchem Server? Mit dem Datenbankserver? Was hast Du als
Datenbankserver angegeben? Läuft das MySQL/MariaDB? Welches der beiden
überhaupt?

Grüße
Marc
--
-------------------------------------- !! No courtesy copies, please !! -----
Marc Haber         |   " Questions are the         | Mailadresse im Header
Mannheim, Germany  |     Beginning of Wisdom "     |
Nordisch by Nature | Lt. Worf, TNG "Rightful Heir" | Fon: *49 621 72739834

Reply | Threaded
Open this post in threaded view
|

Re: CMS Joomla auf Buster

Lademann, Klaus-2
Am 16.02.20 um 11:49 schrieb Marc Haber:

> On Sun, 16 Feb 2020 08:19:21 +0100, "Lademann, Klaus"
> <[hidden email]> wrote:
>> nach dem ich erfolgreich mir das aktuelle Joomla besorgt habe,
>> MySQL/MariaDB installiert, php-mysql installiert habe,
>>
>> beschwert sich die Installationsroutine von Joomla, das es sich nicht
>> mit dem Server verbinden kann.
>
> Mit welchem Server? Mit dem Datenbankserver? Was hast Du als
> Datenbankserver angegeben? Läuft das MySQL/MariaDB? Welches der beiden
> überhaupt?
>
> Grüße
> Marc
>
● mariadb.service - MariaDB 10.3.22 database server
    Loaded: loaded (/lib/systemd/system/mariadb.service; enabled; vendor
preset: enabled)
    Active: active (running) since Sun 2020-02-16 12:29:19 CET; 23s ago
      Docs: man:mysqld(8)
            https://mariadb.com/kb/en/library/systemd/
   Process: 12954 ExecStartPre=/usr/bin/install -m 755 -o mysql -g root
-d /var/run/mysqld (code=exited, status=0/SUCCESS)
   Process: 12955 ExecStartPre=/bin/sh -c systemctl unset-environment
_WSREP_START_POSITION (code=exited, status=0/SUCCESS)
   Process: 12958 ExecStartPre=/bin/sh -c [ ! -e
/usr/bin/galera_recovery ] && VAR= ||   VAR=`/usr/bin/galera_recovery`;
[ $? -eq 0 ]   && systemctl set-environment _WSREP_START_POSITION=$VAR
|| exit 1 (code=exited, status=0/SUCCESS)
   Process: 13040 ExecStartPost=/bin/sh -c systemctl unset-environment
_WSREP_START_POSITION (code=exited, status=0/SUCCESS)
   Process: 13042 ExecStartPost=/etc/mysql/debian-start (code=exited,
status=0/SUCCESS)
  Main PID: 13009 (mysqld)
    Status: "Taking your SQL requests now..."
     Tasks: 31 (limit: 4915)
    Memory: 94.2M
    CGroup: /system.slice/mariadb.service
            └─13009 /usr/sbin/mysqld

Feb 16 12:29:16 TUX-hoelle1 systemd[1]: Starting MariaDB 10.3.22
database server...
Feb 16 12:29:17 TUX-hoelle1 mysqld[13009]: 2020-02-16 12:29:17 0 [Note]
/usr/sbin/mysqld (mysqld 10.3.22-MariaDB-0+deb10u1) starting as process
13009 ...
Feb 16 12:29:19 TUX-hoelle1 systemd[1]: Started MariaDB 10.3.22 database
server.

Das gibt mir der Status aus. Ich bin lange nicht mehr in der Materie
gewesen.

Reply | Threaded
Open this post in threaded view
|

Re: CMS Joomla auf Buster

S. Kremer
mit welchem Datenbank User willst Du Dich bei der Installation von Joomla anmelden?

Mit dem root User wird das so einfach nicht funktionieren:
https://kofler.info/root-login-problem-mit-mariadb/
https://www.codeflow.site/de/article/how-to-install-mariadb-on-debian-10




--- Original Nachricht ---
Betreff: Re: CMS Joomla auf Buster
Von: "Lademann, Klaus" <[hidden email]>
An: [hidden email]
Datum: 16-02-2020 12:32



Am 16.02.20 um 11:49 schrieb Marc Haber:
> On Sun, 16 Feb 2020 08:19:21 +0100, "Lademann, Klaus"
> <[hidden email]> wrote:
>> nach dem ich erfolgreich mir das aktuelle Joomla besorgt habe,
>> MySQL/MariaDB installiert, php-mysql installiert habe,
>>
>> beschwert sich die Installationsroutine von Joomla, das es sich nicht
>> mit dem Server verbinden kann.
>
> Mit welchem Server? Mit dem Datenbankserver? Was hast Du als
> Datenbankserver angegeben? Läuft das MySQL/MariaDB? Welches der beiden
> überhaupt?
>
> Grüße
> Marc
>
● mariadb.service - MariaDB 10.3.22 database server
    Loaded: loaded (/lib/systemd/system/mariadb.service; enabled; vendor
preset: enabled)
    Active: active (running) since Sun 2020-02-16 12:29:19 CET; 23s ago
      Docs: man:mysqld(8)
            https://mariadb.com/kb/en/library/systemd/
   Process: 12954 ExecStartPre=/usr/bin/install -m 755 -o mysql -g root
-d /var/run/mysqld (code=exited, status=0/SUCCESS)
   Process: 12955 ExecStartPre=/bin/sh -c systemctl unset-environment
_WSREP_START_POSITION (code=exited, status=0/SUCCESS)
   Process: 12958 ExecStartPre=/bin/sh -c [ ! -e
/usr/bin/galera_recovery ] && VAR= ||   VAR=`/usr/bin/galera_recovery`;
[ $? -eq 0 ]   && systemctl set-environment _WSREP_START_POSITION=$VAR
|| exit 1 (code=exited, status=0/SUCCESS)
   Process: 13040 ExecStartPost=/bin/sh -c systemctl unset-environment
_WSREP_START_POSITION (code=exited, status=0/SUCCESS)
   Process: 13042 ExecStartPost=/etc/mysql/debian-start (code=exited,
status=0/SUCCESS)
  Main PID: 13009 (mysqld)
    Status: "Taking your SQL requests now..."
     Tasks: 31 (limit: 4915)
    Memory: 94.2M
    CGroup: /system.slice/mariadb.service
            └─13009 /usr/sbin/mysqld

Feb 16 12:29:16 TUX-hoelle1 systemd[1]: Starting MariaDB 10.3.22
database server...
Feb 16 12:29:17 TUX-hoelle1 mysqld[13009]: 2020-02-16 12:29:17 0 [Note]
/usr/sbin/mysqld (mysqld 10.3.22-MariaDB-0+deb10u1) starting as process
13009 ...
Feb 16 12:29:19 TUX-hoelle1 systemd[1]: Started MariaDB 10.3.22 database
server.

Das gibt mir der Status aus. Ich bin lange nicht mehr in der Materie
gewesen.

logo_ik.png (11K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: CMS Joomla auf Buster

Boris-27
In reply to this post by Lademann, Klaus-2
Hallo Klaus,

Am 16.02.20 um 09:46 schrieb Lademann, Klaus:

> Am 16.02.20 um 09:26 schrieb Boris:
>> Hallo Klaus,
>>
>> schildere doch erstmal, was Du vor hast.
>>
>> Dann separiere die Aufgaben.
>> Läuft Dein WebServer? Welcher?
>> Läuft Dein PHP? Was sagt phpinfo()?
> Das läuft alles. Apache2 und php7.3.
>
> Wie komme ich denn ran, um zu schauen ob der Datenbankserver überhaupt
> funktiniert?

Du kannst
a) im Terminal nach dem Status schauen:
# systemctl status mariadb.service
b) Dich im Terminal mit dem Server verbinden:
# mysql -u <Benutzer> -p <Passwort>
c) Infos über Deinen LAMP-Stack mit phpinfo() erzeugen.
Dazu erzeugst Du in Deinem Webspace (standardmäßig /var/www/html/) einen
Datei phpinfo.php mit folgendem Inhalt und besuchst diese anschließend
mit dem Browser:

<?php
phpinfo();
?>

Als Schweizer Taschenmesser für einen solchen Aufbau empfiehlt sich
weiterhin die Installation von phpmyadmin (von extern) oder adminer (aus
dem Debian Repsitory).

Boris

>
>>
>> Dann sehen wir weiter....
>> Wie lautet die Fehlermeldung?
>>

Reply | Threaded
Open this post in threaded view
|

Re: CMS Joomla auf Buster

Boris-27
In reply to this post by Lademann, Klaus-2
Am 16.02.20 um 09:46 schrieb Lademann, Klaus:

> Am 16.02.20 um 09:26 schrieb Boris:
>> Hallo Klaus,
>>
>> schildere doch erstmal, was Du vor hast.
>>
>> Dann separiere die Aufgaben.
>> Läuft Dein WebServer? Welcher?
>> Läuft Dein PHP? Was sagt phpinfo()?
> Das läuft alles. Apache2 und php7.3.
>
> Wie komme ich denn ran, um zu schauen ob der Datenbankserver überhaupt
> funktiniert?
>
>>
>> Dann sehen wir weiter....
>> Wie lautet die Fehlermeldung?

Die Installation ist auf vielen Seiten ausführlich beschrieben, z.B.
auch hier, wenngleich etwas Transferleistung bzgl. der Versionen zu
erbringen ist:

https://www.howtoforge.de/anleitung/wie-man-joomla-mit-apache-auf-debian-9-stretch-installiert/

Boris

Reply | Threaded
Open this post in threaded view
|

Re: CMS Joomla auf Buster

Boris-27
In reply to this post by Lademann, Klaus-2
Am 16.02.20 um 09:46 schrieb Lademann, Klaus:

> Am 16.02.20 um 09:26 schrieb Boris:
>> Hallo Klaus,
>>
>> schildere doch erstmal, was Du vor hast.
>>
>> Dann separiere die Aufgaben.
>> Läuft Dein WebServer? Welcher?
>> Läuft Dein PHP? Was sagt phpinfo()?
> Das läuft alles. Apache2 und php7.3.
>
> Wie komme ich denn ran, um zu schauen ob der Datenbankserver überhaupt
> funktiniert?
>
>>
>> Dann sehen wir weiter....
>> Wie lautet die Fehlermeldung?

Die Installation ist auf vielen Seiten ausführlich beschrieben, z.B.
auch hier, wenngleich etwas Transferleistung bzgl. der Versionen zu
erbringen ist:

https://www.howtoforge.de/anleitung/wie-man-joomla-mit-apache-auf-debian-9-stretch-installiert/

Boris

Reply | Threaded
Open this post in threaded view
|

Re: CMS Joomla auf Buster

Boris-27
In reply to this post by Lademann, Klaus-2
Am 16.02.20 um 09:46 schrieb Lademann, Klaus:

> Am 16.02.20 um 09:26 schrieb Boris:
>> Hallo Klaus,
>>
>> schildere doch erstmal, was Du vor hast.
>>
>> Dann separiere die Aufgaben.
>> Läuft Dein WebServer? Welcher?
>> Läuft Dein PHP? Was sagt phpinfo()?
> Das läuft alles. Apache2 und php7.3.
>
> Wie komme ich denn ran, um zu schauen ob der Datenbankserver überhaupt
> funktiniert?
>
>>
>> Dann sehen wir weiter....
>> Wie lautet die Fehlermeldung?

Die Installation ist auf vielen Seiten ausführlich beschrieben, z.B.
auch hier, wenngleich etwas Transferleistung bzgl. der Versionen zu
erbringen ist:

https://www.howtoforge.de/anleitung/wie-man-joomla-mit-apache-auf-debian-9-stretch-installiert/

Boris

Reply | Threaded
Open this post in threaded view
|

Re: CMS Joomla auf Buster

Boris-27
In reply to this post by Lademann, Klaus-2
Am 16.02.20 um 09:46 schrieb Lademann, Klaus:

> Am 16.02.20 um 09:26 schrieb Boris:
>> Hallo Klaus,
>>
>> schildere doch erstmal, was Du vor hast.
>>
>> Dann separiere die Aufgaben.
>> Läuft Dein WebServer? Welcher?
>> Läuft Dein PHP? Was sagt phpinfo()?
> Das läuft alles. Apache2 und php7.3.
>
> Wie komme ich denn ran, um zu schauen ob der Datenbankserver überhaupt
> funktiniert?
>
>>
>> Dann sehen wir weiter....
>> Wie lautet die Fehlermeldung?

Die Installation ist auf vielen Seiten ausführlich beschrieben, z.B.
auch hier, wenngleich etwas Transferleistung bzgl. der Versionen zu
erbringen ist:

https://www.howtoforge.de/anleitung/wie-man-joomla-mit-apache-auf-debian-9-stretch-installiert/

Boris

Reply | Threaded
Open this post in threaded view
|

Re: CMS Joomla auf Buster

Boris-27
In reply to this post by Lademann, Klaus-2
Am 16.02.20 um 09:46 schrieb Lademann, Klaus:

> Am 16.02.20 um 09:26 schrieb Boris:
>> Hallo Klaus,
>>
>> schildere doch erstmal, was Du vor hast.
>>
>> Dann separiere die Aufgaben.
>> Läuft Dein WebServer? Welcher?
>> Läuft Dein PHP? Was sagt phpinfo()?
> Das läuft alles. Apache2 und php7.3.
>
> Wie komme ich denn ran, um zu schauen ob der Datenbankserver überhaupt
> funktiniert?
>
>>
>> Dann sehen wir weiter....
>> Wie lautet die Fehlermeldung?

Die Installation ist auf vielen Seiten ausführlich beschrieben, z.B.
auch hier, wenngleich etwas Transferleistung bzgl. der Versionen zu
erbringen ist:

https://www.howtoforge.de/anleitung/wie-man-joomla-mit-apache-auf-debian-9-stretch-installiert/

Boris

Reply | Threaded
Open this post in threaded view
|

Re: CMS Joomla auf Buster

Boris-27
In reply to this post by Lademann, Klaus-2
Am 16.02.20 um 09:46 schrieb Lademann, Klaus:

> Am 16.02.20 um 09:26 schrieb Boris:
>> Hallo Klaus,
>>
>> schildere doch erstmal, was Du vor hast.
>>
>> Dann separiere die Aufgaben.
>> Läuft Dein WebServer? Welcher?
>> Läuft Dein PHP? Was sagt phpinfo()?
> Das läuft alles. Apache2 und php7.3.
>
> Wie komme ich denn ran, um zu schauen ob der Datenbankserver überhaupt
> funktiniert?
>
>>
>> Dann sehen wir weiter....
>> Wie lautet die Fehlermeldung?

Die Installation ist auf vielen Seiten ausführlich beschrieben, z.B.
auch hier, wenngleich etwas Transferleistung bzgl. der Versionen zu
erbringen ist:

https://www.howtoforge.de/anleitung/wie-man-joomla-mit-apache-auf-debian-9-stretch-installiert/

Boris

Reply | Threaded
Open this post in threaded view
|

Re: CMS Joomla auf Buster

Boris-27
In reply to this post by Lademann, Klaus-2
Am 16.02.20 um 09:46 schrieb Lademann, Klaus:

> Am 16.02.20 um 09:26 schrieb Boris:
>> Hallo Klaus,
>>
>> schildere doch erstmal, was Du vor hast.
>>
>> Dann separiere die Aufgaben.
>> Läuft Dein WebServer? Welcher?
>> Läuft Dein PHP? Was sagt phpinfo()?
> Das läuft alles. Apache2 und php7.3.
>
> Wie komme ich denn ran, um zu schauen ob der Datenbankserver überhaupt
> funktiniert?
>
>>
>> Dann sehen wir weiter....
>> Wie lautet die Fehlermeldung?

Die Installation ist auf vielen Seiten ausführlich beschrieben, z.B.
auch hier, wenngleich etwas Transferleistung bzgl. der Versionen zu
erbringen ist:

https://www.howtoforge.de/anleitung/wie-man-joomla-mit-apache-auf-debian-9-stretch-installiert/

Boris

Reply | Threaded
Open this post in threaded view
|

Re: CMS Joomla auf Buster

Boris-27
In reply to this post by Lademann, Klaus-2
Am 16.02.20 um 09:46 schrieb Lademann, Klaus:

> Am 16.02.20 um 09:26 schrieb Boris:
>> Hallo Klaus,
>>
>> schildere doch erstmal, was Du vor hast.
>>
>> Dann separiere die Aufgaben.
>> Läuft Dein WebServer? Welcher?
>> Läuft Dein PHP? Was sagt phpinfo()?
> Das läuft alles. Apache2 und php7.3.
>
> Wie komme ich denn ran, um zu schauen ob der Datenbankserver überhaupt
> funktiniert?
>
>>
>> Dann sehen wir weiter....
>> Wie lautet die Fehlermeldung?
Die Installation ist auf vielen Seiten ausführlich beschrieben, z.B.
auch hier, wenngleich etwas Transferleistung bzgl. der Versionen zu
erbringen ist:

https://www.howtoforge.de/anleitung/wie-man-joomla-mit-apache-auf-debian-9-stretch-installiert/

Boris



Reply | Threaded
Open this post in threaded view
|

sorry, Mailserver hat sich verschluckt..... war [Re: CMS Joomla auf Buster]

Boris-27
In reply to this post by Boris-27
Sorry, das ist ein bisschen zu oft verschickt worden.....

Am 16.02.20 um 14:01 schrieb Boris:

> Am 16.02.20 um 09:46 schrieb Lademann, Klaus:
>> Am 16.02.20 um 09:26 schrieb Boris:
>>> Hallo Klaus,
>>>
>>> schildere doch erstmal, was Du vor hast.
>>>
>>> Dann separiere die Aufgaben.
>>> Läuft Dein WebServer? Welcher?
>>> Läuft Dein PHP? Was sagt phpinfo()?
>> Das läuft alles. Apache2 und php7.3.
>>
>> Wie komme ich denn ran, um zu schauen ob der Datenbankserver überhaupt
>> funktiniert?
>>
>>>
>>> Dann sehen wir weiter....
>>> Wie lautet die Fehlermeldung?
>
> Die Installation ist auf vielen Seiten ausführlich beschrieben, z.B.
> auch hier, wenngleich etwas Transferleistung bzgl. der Versionen zu
> erbringen ist:
>
> https://www.howtoforge.de/anleitung/wie-man-joomla-mit-apache-auf-debian-9-stretch-installiert/
>
> Boris
>