EIZO-Monitor bekommt keinen ausreichenden Impuls - Modesetting Treiber

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

EIZO-Monitor bekommt keinen ausreichenden Impuls - Modesetting Treiber

Manfred Rebentisch-2
Guten morgen!

Ich habe ein Problem mit modernen Monitoren am Debian Rechner. Sie
bleiben beim Start des Debian-Rechners schwary (kein Signal).

Mit dem Monitor "LG 27UD88-W (27" ) 4K LED Monitor EEK" gab es schon
Probleme, aber es funktioniert zumindest mit Blind-Eingabe des Passworts.
Aktuell habe ich das Problem mit dem "EIZO FlexScan EV3237-GY".
Dieser will überhaupt nicht einschalten, wenn ich den Debian-Rechner starte.
Der EIZO-Support hat mir geholfen, die richtigen Einstellungen am
Monitor vorzunehmen. Hilft aber nicht. Jetzt hoffe ich, am
Debian-Rechner Einstellungen vornehmen zu können.


Der Rechner, inxi -F

System:    Host: ws24 Kernel: 4.9.0-6-amd64 x86_64 (64 bit)
            Desktop: Xfce 4.12.3
            Distro: Debian GNU/Linux 9 (stretch)
Machine:   Device: desktop Mobo: Intel model: NUC6i5SYB v: H81131-504
            UEFI [Legacy]: Intel v: SYSKLi35.86A.0054.2016.0930.1102
            date: 09/30/2016
CPU:       Dual core Intel Core i5-6260U (-HT-MCP-) cache: 4096 KB
            clock speeds: max: 1800 MHz 1: 699 MHz 2: 699 MHz 3: 699 MHz
            4: 699 MHz
Graphics:  Card: Intel Iris Graphics 540
            Display Server: X.Org 1.19.2 drivers: modesetting (unloaded:
            fbdev,vesa)
            Resolution: 3840x2160@29.98hz
            GLX Renderer: Mesa DRI Intel Iris Graphics 540 (Skylake GT3e)
            GLX Version: 3.0 Mesa 13.0.6

Ich habe es sowohl mit DisplayPort als auch HDMI probiert.

Ich hatte ein ähnliches Problem schon in anderer Hardware-Kombination
(mit dem LG-Monitor) im August 2017 geschildert:

Am 23.08.2017 um 06:09 schrieb Uwe Laverenz:
 > Hallo Manfred,
 >
 > Am 22.08.2017 um 14:36 schrieb Manfred Rebentisch:
 >> Nachtrag: es muß sich ja trotzdem softwareseitig etwas verändert haben,
 >> da die gleiche Hardware mit Jessie einwandfrei funktionierte.
 >
 > Ich hatte ebenfalls Probleme(*) mit Intel-Graphics und Debian Stretch.
 > Im Gegensatz zu Jessie verwendet Stretch nicht mehr den alten Xorg-Intel
 > Treiber sondern den Modesetting-Treiber für Intel-Grafikchips. Der ist
 > zumindest für ältere Chips in Debians 4.9er Kernel aber kaputt.
 >
 > Da sich niemand um das Problem kümmert, kann man als workaround für die
 > Verwendung des alten Treibers sorgen indem an die Datei
 > "/etc/X11/xorg.conf.d/20-intel.conf" anlegt (Options bei Bedarf wieder
 > aktivieren):
 >
 >
 > Section "Device"
 >         Identifier      "Intel Graphics"
 >         Driver          "intel"
 >         #Option          "AccelMethod"   "SNA"
 >         #Option          "TearFree"      "true"
 >         #Option          "Tiling"        "true"
 > EndSection
 >
 >
 > Der alte Treiber findet sich im Paket "xserver-xorg-video-intel".
 >
 > hth,
 > Uwe

Uwe meint, dass der Modeseting-Treiber nicht in Ordnung ist. Bevor ich
mich damit beschäftige, den alten Xorg-Intel Treiber zu installieren,
wüsste ich gerne, ob es da eine Chance für eine aktuelle Lösung gibt.

Vielen Dank für Tips!


--
Manfred Rebentisch
29456 Hitzacker

Reply | Threaded
Open this post in threaded view
|

Re: EIZO-Monitor bekommt keinen ausreichenden Impuls - Modesetting Treiber

ternaryd
On Wed, 16 May 2018 06:02:42 +0200
Manfred Rebentisch <[hidden email]>
wrote:

> Ich habe ein Problem mit modernen Monitoren
> am Debian Rechner. Sie > bleiben beim Start
> des Debian-Rechners schwary (kein Signal).

Schwarz != kein Signal. Kein Signal wird
üblicherweise auf dem Monitor angezeigt, und
das würde darauf hinweisen, daß ein Modus oder
eine PCI Adresse (Grafikarte) nicht
übereinstimmen. Ansonsten:

Meine Eizos sind zwar keine 4k haben aber die
30-Bit Farben. Und da gibt es sehr viel
Software (z.B. Gimp) die nicht damit zurecht
kommt. X11 tut das, aber, wenn der Windowmanager
nicht mitspielt, dann hilfts nicht viel. Man
könnte es ja mit einem anderen WM versuchen.
Ich verwende Mate und da geht es leidlich. Oder
vielleicht nur mit startx auf der Konsole.

Reply | Threaded
Open this post in threaded view
|

Re: EIZO-Monitor bekommt keinen ausreichenden Impuls - Modesetting Treiber

Manfred Rebentisch-2
In reply to this post by Manfred Rebentisch-2
Ich habe vergessen, zu erwähnen, dass der EIZO Monitor sehr wohl
funktionert, WENN ich den Computer mit dem alten Monitor starte und dann
das Kabel umstöpsle. Wenn der grafische Desktop erstmal läuft,
funktioniert es. Nur beim Starten selbst kommt er nicht von alleine in
Gang, auch nicht, wenn ich die Anmeldedaten blind eintippe.

Manfred

--
Manfred Rebentisch
29456 Hitzacker