Error message installing Google-Web-Designer

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Error message installing Google-Web-Designer

SDA-2
Greetings.

Running Gnome-Shell 3.8.x on Debian Jessie, after installing
Google-Web-Designer the following message is presented:

        Setting up google-webdesigner (1.0.1.0-1) ...
        Error in file "/usr/share/gnome/applications/display.im6.desktop":
        "NoDisplay=true" is an invalid MIME type ("NoDisplay=true" does not
        contain a subtype)

Which results in the application showing up without any toolbars or
"chrome" just a blank shell.

Any idea what's wrong/needed to fix this? Google's page says it's
compatible with Debian/Ubuntu.

Thanks!


--
To UNSUBSCRIBE, email to [hidden email]
with a subject of "unsubscribe". Trouble? Contact [hidden email]
Archive: https://lists.debian.org/20140606151740.GA29302@Jessie

Reply | Threaded
Open this post in threaded view
|

Re: Error message installing Google-Web-Designer

Josselin Mouette
Le vendredi 06 juin 2014 à 11:17 -0400, Stephen Allen a écrit :
> Greetings.
>
> Running Gnome-Shell 3.8.x on Debian Jessie, after installing
> Google-Web-Designer the following message is presented:
>
> Setting up google-webdesigner (1.0.1.0-1) ...
> Error in file "/usr/share/gnome/applications/display.im6.desktop":
> "NoDisplay=true" is an invalid MIME type ("NoDisplay=true" does not
> contain a subtype)

This message is proof that this package’s postinst script is doing
completely unneeded or irrelevant stuff. (There is a real bug here which
is #692141, fixed in svn, but it’s unrelated.)

> Which results in the application showing up without any toolbars or
> "chrome" just a blank shell.

Tell Google to stop writing hundreds of useless lines in their postinst
scripts.

> Any idea what's wrong/needed to fix this? Google's page says it's
> compatible with Debian/Ubuntu.

Apparently, it is not. All of freedesktop stuff is automatically handled
by triggers, in both Debian and Ubuntu. What this package does risks
breaking your system.

--
 .''`.        Josselin Mouette
: :' :
`. `'
  `-


--
To UNSUBSCRIBE, email to [hidden email]
with a subject of "unsubscribe". Trouble? Contact [hidden email]
Archive: https://lists.debian.org/1402069883.21068.94.camel@dsp0698014