Etch: About gstreamer and cd reading/extracting

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

Etch: About gstreamer and cd reading/extracting

Frédéric Brin-2
Hy all,

This bug was annoying me for a few mounth .. Any gnome CD related
program can not read a CD... This impacts (at least):
+ sound-juicer
+ gnome-cd
+ bmpx

This is due to a gstreamer bug ..

See http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=402738

The current solution is to install the
gstreamer0.10-plugins-base-0.10.11 from experimental.

The bug is to me a Blocker for the Current Etch.... I really don't
understand why its severity has been lowered to normal. I mean, what
will user think of the Debian Desktop, if it can't even read a CD ;)

I really do think (and hope) the 0.10.11 package would be included in
the etch release.

Frédéric Brin

signature.asc (196 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Etch: About gstreamer and cd reading/extracting

Sven Arvidsson
On Thu, 2007-01-18 at 20:28 +0100, Frédéric Brin wrote:

> This bug was annoying me for a few mounth .. Any gnome CD related
> program can not read a CD... This impacts (at least):
> + sound-juicer
> + gnome-cd
> + bmpx
>
> This is due to a gstreamer bug ..
>
> See http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=402738
>
> The current solution is to install the
> gstreamer0.10-plugins-base-0.10.11 from experimental.
>
> The bug is to me a Blocker for the Current Etch.... I really don't
> understand why its severity has been lowered to normal. I mean, what
> will user think of the Debian Desktop, if it can't even read a CD ;)
>
> I really do think (and hope) the 0.10.11 package would be included in
> the etch release.
Hi,

Actually, the severity of these bugs are set to important, but as I
stated in 405479 (one of the reports merged) I'm starting to think that
quite a lot of users are, or will be affected of this bug so maybe the
severity should be raised to "grave"?

I think the reason for not catching this earlier was that most of these
bugs were scattered and filed against the audio player in question
(gnome-media, sound-juicer, etc).

--
Cheers,
Sven Arvidsson
http://www.whiz.se
PGP Key ID 760BDD22

signature.asc (196 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Etch: About gstreamer and cd reading/extracting

Gustavo Franco-2
On 1/18/07, Sven Arvidsson <[hidden email]> wrote:

> On Thu, 2007-01-18 at 20:28 +0100, Frédéric Brin wrote:
> > This bug was annoying me for a few mounth .. Any gnome CD related
> > program can not read a CD... This impacts (at least):
> > + sound-juicer
> > + gnome-cd
> > + bmpx
> >
> > This is due to a gstreamer bug ..
> >
> > See http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=402738
> >
> > The current solution is to install the
> > gstreamer0.10-plugins-base-0.10.11 from experimental.

Is the bug really fixed there? Btw, if we've a fix and we know (Sven?)
what the fix is, that's enough isolate the patch and backport it to
current gstreamer in testing, if the code change isn't too intrusive.

> > The bug is to me a Blocker for the Current Etch.... I really don't
> > understand why its severity has been lowered to normal. I mean, what
> > will user think of the Debian Desktop, if it can't even read a CD ;)
> >
> > I really do think (and hope) the 0.10.11 package would be included in
> > the etch release.

I disagree since 0.10.11-1 is a new upstream, actually we've 0.10.10-2
for Etch. I don't think the release team will agree with the bump and
that it would be sane keep just base 0.10.11-1 and the rest of the
gstreamer related packages as 0.10.10-2.

> (...)

With some hints i could backport the patch, but that would be better
if someone else from pkg-gstreamer does. Thoughts?

regards,
-- stratus
http://stratusandtheswirl.blogspot.com

Reply | Threaded
Open this post in threaded view
|

Re: Etch: About gstreamer and cd reading/extracting

Sven Arvidsson
On Thu, 2007-01-18 at 18:09 -0200, Gustavo Franco wrote:
> > > The current solution is to install the
> > > gstreamer0.10-plugins-base-0.10.11 from experimental.
>
> Is the bug really fixed there? Btw, if we've a fix and we know (Sven?)
> what the fix is, that's enough isolate the patch and backport it to
> current gstreamer in testing, if the code change isn't too intrusive.

Most users who reported this bug claims that the problems are fixed in
0.10.11. I haven't seen anything in the changelog about changes to the
cdparanoia element, so I'm not sure what the problem really is or what
has changed between the two versions.

Maybe it would be a good idea to contact upstream and see if they can
pinpoint the exact problem and fix?

--
Cheers,
Sven Arvidsson
http://www.whiz.se
PGP Key ID 760BDD22

signature.asc (196 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Etch: About gstreamer and cd reading/extracting

Tim Müller
On Thu, 2007-01-18 at 21:31 +0100, Sven Arvidsson wrote:

> Most users who reported this bug claims that the problems are fixed in
> 0.10.11. I haven't seen anything in the changelog about changes to the
> cdparanoia element, so I'm not sure what the problem really is or what
> has changed between the two versions.
>
> Maybe it would be a good idea to contact upstream and see if they can
> pinpoint the exact problem and fix?

At least I don't have the slightest idea what particular fix might have
solved this.

Has anyone tried if upgrading just the core but not gst-plugins-base
fixes this as well? (ie. running core 0.10.11 + -base 0.10.10)

 Cheers
  -Tim



--
To UNSUBSCRIBE, email to [hidden email]
with a subject of "unsubscribe". Trouble? Contact [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Etch: About gstreamer and cd reading/extracting

Sven Arvidsson
On Thu, 2007-01-18 at 20:41 +0000, Tim Müller wrote:
> Has anyone tried if upgrading just the core but not gst-plugins-base
> fixes this as well? (ie. running core 0.10.11 + -base 0.10.10)

I asked a few of the bug reporters to try that, but it doesn't seem to
fix the bug:

On Fri, 2007-01-19 at 21:06 +0100, Helge Kreutzmann wrote:

> dpkg -l libgstreamer0.10-0 => 0.10.11-1
> dpkg -l gstreamer0.10-plugins-base => 0.10.10-2
>
> This does *not* work, in sound juicer I get again "This CD has no
> audio tracks". Before downgrading or after
> dpkg -l gstreamer0.10-plugins-base => 0.10.11-1
>
> audio playing works flawlessly again.
>
> The answer is clerly: No, this combination does not fix the problem.
--
Cheers,
Sven Arvidsson
http://www.whiz.se
PGP Key ID 760BDD22

signature.asc (196 bytes) Download Attachment