Forcibly switching to PATA/libata

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Forcibly switching to PATA/libata

Bastian Blank
Hi folks

I intend to do the switch to PATA in 2.6.31, even if there is nothing to
convert the whole shit yet. I'm sick of all the whining.

Bastian

--
... The prejudices people feel about each other disappear when they get
to know each other.
                -- Kirk, "Elaan of Troyius", stardate 4372.5


--
To UNSUBSCRIBE, email to [hidden email]
with a subject of "unsubscribe". Trouble? Contact [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Forcibly switching to PATA/libata

Ben Hutchings-3
On Sat, 2009-07-11 at 15:13 +0200, Bastian Blank wrote:
> Hi folks
>
> I intend to do the switch to PATA in 2.6.31, even if there is nothing to
> convert the whole shit yet. I'm sick of all the whining.

What do we do about IDE drivers that claim the same device ids?  Stop
building them?  Blacklist them?

Ben.

--
Ben Hutchings
No political challenge can be met by shopping. - George Monbiot

signature.asc (196 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Forcibly switching to PATA/libata

Evgeni Golov
In reply to this post by Bastian Blank
Hi,

On Sat, 11 Jul 2009 15:13:23 +0200 Bastian Blank wrote:

> I intend to do the switch to PATA in 2.6.31, even if there is nothing to
> convert the whole shit yet. I'm sick of all the whining.

Mh, while thinking about it:
1. Is there any way to force libata on 2.6.30 atm? The UltraBay DVD/CD
   from my Thinkpad Z61m just does not want to play with ata_piix on a
   Debian kernel, while doing fine when using a custom built one with
   IDE=n.
2. Will there be a way to continue using old IDE drivers on .31? I
   remember problems (and no real time to invesigate) with libata on my
   ICH4 ThinkPad X31.

Regards
Evgeni


--
To UNSUBSCRIBE, email to [hidden email]
with a subject of "unsubscribe". Trouble? Contact [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Forcibly switching to PATA/libata

maximilian attems-9
On Mon, 13 Jul 2009, Evgeni Golov wrote:

> On Sat, 11 Jul 2009 15:13:23 +0200 Bastian Blank wrote:
>
> > I intend to do the switch to PATA in 2.6.31, even if there is nothing to
> > convert the whole shit yet. I'm sick of all the whining.

there had been no pata status report since some time, so not sure if
we should really switch *all*
 
> Mh, while thinking about it:
> 1. Is there any way to force libata on 2.6.30 atm? The UltraBay DVD/CD
>    from my Thinkpad Z61m just does not want to play with ata_piix on a
>    Debian kernel, while doing fine when using a custom built one with
>    IDE=n.
> 2. Will there be a way to continue using old IDE drivers on .31? I
>    remember problems (and no real time to invesigate) with libata on my
>    ICH4 ThinkPad X31.

no to both questions.
either you use old ide or newer pata drivers.


--
To UNSUBSCRIBE, email to [hidden email]
with a subject of "unsubscribe". Trouble? Contact [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Forcibly switching to PATA/libata

Bastian Blank
In reply to this post by Ben Hutchings-3
On Sat, Jul 11, 2009 at 04:35:54PM +0100, Ben Hutchings wrote:
> On Sat, 2009-07-11 at 15:13 +0200, Bastian Blank wrote:
> > I intend to do the switch to PATA in 2.6.31, even if there is nothing to
> > convert the whole shit yet. I'm sick of all the whining.
> What do we do about IDE drivers that claim the same device ids?  Stop
> building them?  Blacklist them?

Stop building them.

Bastian

--
Killing is stupid; useless!
                -- McCoy, "A Private Little War", stardate 4211.8


--
To UNSUBSCRIBE, email to [hidden email]
with a subject of "unsubscribe". Trouble? Contact [hidden email]