Groovy 2.4.16 + Java 11 is broken in debian buster stable

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

Groovy 2.4.16 + Java 11 is broken in debian buster stable

Jayant Tripathi

Is there a way to download patched groovy version in debian buster through apt?
As default groovy version in Buster stable is: Groovy Version: 2.4.16 JVM: 11.0.6 Vendor: Debian OS: Linux

Regards
Jayant Tripathi
Reply | Threaded
Open this post in threaded view
|

Re: Groovy 2.4.16 + Java 11 is broken in debian buster stable

Liam O'Toole
On Wed, 22 Apr, 2020 at 22:15:09 +0530, Jayant Tripathi wrote:

>    [1]https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=929460
>    Is there a way to download patched groovy version in debian buster
>    through apt?
>    As default groovy version in Buster stable is: Groovy Version: 2.4.16
>    JVM: 11.0.6 Vendor: Debian OS: Linux
>    Regards
>    Jayant Tripathi
>
> References
>
>    1. https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=929460

Groovy 2.4.17 is available in bullseye (testing). Try requesting a
backport on the debian-backports list. Alternatively, you could attempt
building a backport yourself:

https://wiki.debian.org/SimpleBackportCreation

Reply | Threaded
Open this post in threaded view
|

Re: Groovy 2.4.16 + Java 11 is broken in debian buster stable

Sven Hartge-5
Liam O'Toole <[hidden email]> wrote:
> On Wed, 22 Apr, 2020 at 22:15:09 +0530, Jayant Tripathi wrote:

>>    [1]https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=929460
>>    Is there a way to download patched groovy version in debian buster
>>    through apt?
>>    As default groovy version in Buster stable is: Groovy Version: 2.4.16
>>    JVM: 11.0.6 Vendor: Debian OS: Linux
>>    Regards
>>    Jayant Tripathi
>>
>> References
>>
>>    1. https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=929460

> Groovy 2.4.17 is available in bullseye (testing). Try requesting a
> backport on the debian-backports list.

Backports must not be used to fix bugs in Stable. If groovy from Stable
does not work with the openjdk-11 from Stable, then this is a bug in
Stable and has to be fixed in Stable.

Grüße,
Sven.

--
Sigmentation fault. Core dumped.

Reply | Threaded
Open this post in threaded view
|

Re: Groovy 2.4.16 + Java 11 is broken in debian buster stable

Liam O'Toole
On Thu, 23 Apr, 2020 at 11:08:27 +0200, Sven Hartge wrote:

> Liam O'Toole <[hidden email]> wrote:
> > On Wed, 22 Apr, 2020 at 22:15:09 +0530, Jayant Tripathi wrote:
>
> >>    [1]https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=929460
> >>    Is there a way to download patched groovy version in debian buster
> >>    through apt?
> >>    As default groovy version in Buster stable is: Groovy Version: 2.4.16
> >>    JVM: 11.0.6 Vendor: Debian OS: Linux
> >>    Regards
> >>    Jayant Tripathi
> >>
> >> References
> >>
> >>    1. https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=929460
>
> > Groovy 2.4.17 is available in bullseye (testing). Try requesting a
> > backport on the debian-backports list.
>
> Backports must not be used to fix bugs in Stable. If groovy from Stable
> does not work with the openjdk-11 from Stable, then this is a bug in
> Stable and has to be fixed in Stable.
>

This is indeed a bug in stable. However, any package in testing becomes
a candidate for stable-backports. There's more than one way to skin this
cat.

Reply | Threaded
Open this post in threaded view
|

Re: Groovy 2.4.16 + Java 11 is broken in debian buster stable

Sven Hartge-5
Liam O'Toole <[hidden email]> wrote:
> On Thu, 23 Apr, 2020 at 11:08:27 +0200, Sven Hartge wrote:

>> Backports must not be used to fix bugs in Stable. If groovy from
>> Stable does not work with the openjdk-11 from Stable, then this is a
>> bug in Stable and has to be fixed in Stable.

> This is indeed a bug in stable. However, any package in testing
> becomes a candidate for stable-backports.

Sure. But the official stance of Debian is the one I lined out above, by
both the SRMs and the Backports-RMs.

 You must not be forced to install packages from backports just to get a
 bug fixed.

In this case one could argue that the bug in groovy is indeed
release-critical, since it does not work at all.

Grüße,
Sven.

--
Sigmentation fault. Core dumped.

Reply | Threaded
Open this post in threaded view
|

Re: Groovy 2.4.16 + Java 11 is broken in debian buster stable

Liam O'Toole
On Thu, 23 Apr, 2020 at 11:53:14 +0200, Sven Hartge wrote:

> Liam O'Toole <[hidden email]> wrote:
> > On Thu, 23 Apr, 2020 at 11:08:27 +0200, Sven Hartge wrote:
>
> >> Backports must not be used to fix bugs in Stable. If groovy from
> >> Stable does not work with the openjdk-11 from Stable, then this is a
> >> bug in Stable and has to be fixed in Stable.
>
> > This is indeed a bug in stable. However, any package in testing
> > becomes a candidate for stable-backports.
>
> Sure. But the official stance of Debian is the one I lined out above, by
> both the SRMs and the Backports-RMs.
>
>  You must not be forced to install packages from backports just to get a
>  bug fixed.
>
> In this case one could argue that the bug in groovy is indeed
> release-critical, since it does not work at all.
>

No one is suggesting using force. :-)