[Help] Re: Bug#953052: psychopy: python2 dependencies

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

[Help] Re: Bug#953052: psychopy: python2 dependencies

Andreas Tille-5
Control: tags -1 help

Hi DPMT,

I need to admit I'm currentl overwhelmed with COVID-19 hackathon.
A quick view does not really show any suspicious things to me.
Any help (including team upload / NMU) would be appreciated.

Kind regards

      Andreas.

On Tue, Mar 03, 2020 at 09:34:24PM +0100, Bob wrote:

> Package: psychopy
> Version: 2020.1.1+dfsg-1
> Severity: important
>
> Dear Maintainer,
>
> Psychopy seems to have python2 dependencies.
>
> I do not have any python2 packages installed anymore.
> When installing psychopy 2020.1.1 with apt-get from the official debian repo,
> it pulls in a selection of python2 packages:
>
> ipython libpython-stdlib libpython2-stdlib libpython2.7-minimal
> libpython2.7-stdlib python
>   python-backports-shutil-get-terminal-size python-chardet python-decorator
> python-enum34 python-ipython
>   python-ipython-genutils python-minimal python-pathlib2 python-pexpect python-
> pickleshare python-pkg-resources
>   python-prompt-toolkit python-ptyprocess python-pygments python-scandir
> python-simplegeneric python-six python-traitlets
>   python-wcwidth python2 python2-minimal python2.7 python2.7-minimal
>
> When manually installing the deb with gdebi it does not install these python2
> packages.
>
> Seems to be some kind of packaging error.
>
> Best,
> Bob
>
>
>
> -- System Information:
> Debian Release: bullseye/sid
>   APT prefers testing
>   APT policy: (500, 'testing')
> Architecture: amd64 (x86_64)
> Foreign Architectures: i386
>
> Kernel: Linux 5.5.0-7.1-liquorix-amd64 (SMP w/8 CPU cores; PREEMPT)
> Kernel taint flags: TAINT_PROPRIETARY_MODULE, TAINT_FIRMWARE_WORKAROUND, TAINT_OOT_MODULE
> Locale: LANG=en_NL.UTF-8, LC_CTYPE=en_DK.UTF-8 (charmap=UTF-8), LANGUAGE=en_US (charmap=UTF-8)
> Shell: /bin/sh linked to /usr/bin/dash
> Init: systemd (via /run/systemd/system)
>
> Versions of packages psychopy depends on:
> ii  python3                3.7.5-3
> ii  python3-configobj      5.0.6-3
> ii  python3-freetype       2.1.0.post1-2
> ii  python3-future         0.18.2-1
> ii  python3-gevent         1.4.0-1+b1
> ii  python3-git            3.0.7-1
> ii  python3-gitlab         1:2.0.1-1
> ii  python3-json-tricks    3.11.0-2
> ii  python3-lxml           4.5.0-1
> ii  python3-matplotlib     3.1.2-2
> ii  python3-msgpack        0.5.6-3
> ii  python3-msgpack-numpy  0.4.4-1
> ii  python3-numpy          1:1.17.4-5
> ii  python3-opengl         3.1.0+dfsg-2
> ii  python3-openpyxl       3.0.3-1
> ii  python3-pandas         0.25.3+dfsg-7
> ii  python3-pil            6.2.1-2+b1
> ii  python3-psutil         5.6.7-1
> ii  python3-pygame         1.9.6+dfsg-2
> ii  python3-pyglet         1.4.10-1
> ii  python3-requests       2.22.0-2
> ii  python3-scipy          1.3.3-3
> ii  python3-serial         3.4-5.1
> ii  python3-soundfile      0.10.3+post1-1
> ii  python3-tables         3.6.1-2
> ii  python3-xlrd           1.1.0-5
> ii  python3-yaml           5.3-1
> ii  python3-zmq            17.1.2-4
>
> Versions of packages psychopy recommends:
> pn  ipython               <none>
> ii  libxxf86vm1           1:1.1.4-1+b2
> ii  python3-cryptography  2.8-3
> ii  python3-distro        1.4.0-1
> ii  python3-opencv        4.2.0+dfsg-5
> ii  python3-pygame        1.9.6+dfsg-2
> ii  python3-pyglet        1.4.10-1
> ii  python3-pyo           1.0.0-2.1
> ii  python3-questplus     2019.4-2
> ii  python3-wxgtk4.0      4.0.7+dfsg-2
> ii  python3-xlib          0.23-2
>
> Versions of packages psychopy suggests:
> pn  libavbin0       <none>
> pn  python3-iolabs  <none>
> pn  python3-pyxid   <none>
>
> _______________________________________________
> Debian-med-packaging mailing list
> [hidden email]
> https://alioth-lists.debian.net/cgi-bin/mailman/listinfo/debian-med-packaging

--
http://fam-tille.de

Reply | Threaded
Open this post in threaded view
|

Re: [Help] Re: Bug#953052: psychopy: python2 dependencies

Sandro Tosi-6
On Wed, Apr 8, 2020 at 12:09 PM Andreas Tille <[hidden email]> wrote:
>
> Control: tags -1 help
>
> Hi DPMT,
>
> I need to admit I'm currentl overwhelmed with COVID-19 hackathon.
> A quick view does not really show any suspicious things to me.
> Any help (including team upload / NMU) would be appreciated.

didnt take much to figure it out..

$ aptitude why psychopy python2.7
p   psychopy    Recommends python3-pyo
p   python3-pyo Recommends jackd2
p   jackd2      Depends    python-dbus
p   python-dbus Depends    python2 (>= 2.7~)
p   python2     Depends    python2.7 (>= 2.7.17~rc1-1~)


--
Sandro "morph" Tosi
My website: http://sandrotosi.me/
Me at Debian: http://wiki.debian.org/SandroTosi
Twitter: https://twitter.com/sandrotosi